Article ID: 939311 - Last Review: July 10, 2007 - Revision: 1.0

The menu appears as empty white space when a user clicks Site Actions or My Settings in a SharePoint Server 2007 site or in a Windows SharePoint Services 3.0 site

Expand all | Collapse all

SYMPTOMS

A user connects to a site in Microsoft Office SharePoint Server 2007 or in Microsoft Windows SharePoint Services 3.0 by using Windows Internet Explorer 7 or by using Microsoft Internet Explorer 6. Then, the user clicks either Site Actions or My Settings. However, the menu does not appear as expected. The menu flashes briefly on the screen, and then it appears as empty white space. All menu items are missing from the menu.

CAUSE

This issue occurs if a wildcard character (*) MIME mapping is added to the Web site in Internet Information Services (IIS) 6.0.

RESOLUTION

To resolve this issue, remove the wildcard character (*) MIME mapping from the Web site in IIS, and then restart IIS. After these steps are performed on the server, the cache must be cleared in Internet Explorer on each client computer that experiences this issue.

To do this, follow these steps:
  1. Remove the wildcard character (*) MIME mapping from the Web site in IIS 6.0. To do this, follow these steps:
    1. Click Start, point to All Programs, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
    2. Expand ServerName, expand Web Sites, right-click the Web site that you want to configure, and then click Properties.
    3. Click the HTTP Headers tab, and then click MIME Types.
    4. In the Registered MIME types (file extensions) box, click the wildcard character (*) MIME mapping, and then click Remove.
    5. When you are prompted to confirm the removal, click Yes.
    6. Click OK two times.
  2. Restart IIS. To do this, click Start, click Run, type iisreset, and then click OK.
  3. Clear the Internet Explorer cache on each client computer that experiences this issue. To do this, follow these steps:
    1. Start Internet Explorer.
    2. On the Tools menu, click Internet Options, and then click the General tab.
    3. Do one of the following:
      • If you are running Windows Internet Explorer 7, click Delete under Browsing history. Then, in the Temporary Internet Files area, click Delete files. Click Yes when you are prompted to confirm the deletion. Click Close, and then click OK.
      • If you are running Internet Explorer 6, click Delete Files under Temporary Internet files. Then, click OK two times.

MORE INFORMATION

For more information about MIME mappings in IIS 6.0, see the "Working with MIME Types" topic in the Server Administration Guide of the IIS 6.0 documentation. To view this topic online, visit the following Microsoft Web site:
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/eb5556e2-f6e1-4871-b9ca-b8cf6f9c8134.mspx?mfr=true (http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/eb5556e2-f6e1-4871-b9ca-b8cf6f9c8134.mspx?mfr=true)
For more information about MIME types and about Internet Explorer, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/ms775148.aspx (http://msdn2.microsoft.com/en-us/library/ms775148.aspx)

APPLIES TO
  • Microsoft Office SharePoint Server 2007
  • Microsoft Windows SharePoint Services 3.0
Keywords: 
kbtshoot kbprb kbexpertiseinter KB939311
 

Article Translations