Article ID: 939363 - Last Review: October 8, 2011 - Revision: 2.0

SMS 2003 OSD Feature Pack continues to deploy new images even though the Windows USMT 3.0 or a later version returns an error code

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SYMPTOMS

Microsoft Systems Management Server (SMS) 2003 Operating System Deployment (OSD) Feature Pack continues to deploy new images even though the Windows User State Migration Tool (USMT) 3.0 or a later version returns an error code.

This behavior prevents user information from being migrated to a new operating system.

After this problem occurs, the Scanstate.log file contains information that resembles the following:

Error [0x000000] Migration failed to complete successfully
Error [0x000000] Execute Internal failed to complete successfully
Error [0x000000] USMT is unable to complete successfully.
Error [0x000000] Internal Error: USMT was unable to complete the migration. If you continue to receive this error, contact Customer Service and Support (CSS).
Info [0x000000] Please see the log file for more details. Info [0x000000] USMT error Code (status) = 11

In addition, the OSDusmtscanstate.log file contains information that resembles the following:

Running USMTScan\osdUSMTScanState.exe osdUSMTScanState 6/15/2007 3:34:28 PM 1980 (0x07BC)
Exe = <path>\scanstate.exe" osdUSMTScanState 6/15/2007 3:34:28 PM 1980 (0x07BC)
Shared environment successfully initialized osdUSMTScanState 6/15/2007 3:34:28 PM 1980 (0x07BC)
Executing command line: <path>\scanstate.exe" /v:5 /o /uel:90 /i:MigUser.xml /l:"C:\MININT\SMSOSD\OSDLOGS\scanstate.log" "C:\MININT\SMSOSD\StateStore" osdUSMTScanState 6/15/2007 3:34:28 PM 1980 (0x07BC)
CreateProcess completed with exit code 11 osdUSMTScanState 6/15/2007 3:35:58 PM 1980 (0x07BC)
osdUSMTScanState 6/15/2007 3:35:58 PM 1980 (0x07BC)
Success : Exiting with return code 0. osdUSMTScanState 6/15/2007 3:35:58 PM 1980 (0x07BC)

CAUSE

This problem occurs because the OSDUSMTScanState.exe module returns an incorrect exit code of "0" when USMT returns an error code.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires the following prerequisites:
  • Microsoft Systems Management Server (SMS) 2003 Service Pack 2 or a later service pack
  • Operating System Deployment (OSD) Feature Pack Update package

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Osdeployment.msiNot Applicable79,124,99228-Jun-200704:49Not Applicable
Osdusmtloadstate.exe2.50.3726.200376,80028-Jun-200704:25x86
Osdusmtscanstate.exe2.50.3726.200382,43228-Jun-200704:26x86

WORKAROUND

To work around this problem, do not use the OSDUSMTScanState.exe wrapper. Instead, directly use the Scanstate.exe tool. To do this, follow these steps:
  1. Click Start, point to All Programs, point to Systems Management Server, and then click SMS Administrator Console.
  2. In the console tree, expand Image Packages, expand the operating system deployment package, and then click Programs.
  3. Right-click the program, and then click Properties.
  4. Click the Advanced tab.
  5. In the Phase list, select State Capture, and then click Add.
  6. In the list of action types, click Custom, and then click OK.
  7. Configure the command-line options for the Scanstate.exe file.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

You can use the Microsoft Systems Management (SMS) 2003 Operating System Deployment (OSD) Feature Pack to create operating system images in SMS 2003. Therefore, you can use Zero Touch Installation (ZTI) or Lite Touch Installation (LTI) to deploy the images to client computers and to manage the images. The Solution Accelerator for Business Desktop Deployment (BDD) recommends that you use the OSD Feature Pack to create, to deploy, and to manage operating system images.

To obtain the SMS 2003 Operating System Deployment Feature Pack Update package, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/sms/bb676770.aspx (http://technet.microsoft.com/en-us/sms/bb676770.aspx)
You can use Microsoft Windows User State Migration Tool (USMT) 3.0 to deploy large user files and settings to Windows operating systems. USMT can help you improve your migration process. USMT can also help you simplify your migration process. For more information, visit the following Microsoft TechNet Web site:
http://technet2.microsoft.com/WindowsVista/en/library/91f62fc4-621f-4537-b311-1307df0105611033.mspx?mfr=true (http://technet2.microsoft.com/WindowsVista/en/library/91f62fc4-621f-4537-b311-1307df0105611033.mspx?mfr=true)
For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Systems Management Server 2003
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