Article ID: 939408 - Last Review: October 31, 2007 - Revision: 1.1

Error message when you start Forefront Server Security Administrator: "ERROR: Unable to connect to service. An error was returned. Location: CocreateInstanceEx. Error: Access is denied"

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SYMPTOMS

When you start Microsoft Forefront Server Security Administrator, you may receive an error message that resembles the following:
ERROR: Unable to connect to service. An error was returned. Location: CocreateInstanceEx. Error: Access is denied

CAUSE

This issue occurs if a member of the administrator's group tries to start the Forefront Server Security Administrator and the member has read-only permissions to Forefront Security.

This error is caused by a Microsoft Windows Server 2003 Service Pack 1 (SP1) security enhancement.

RESOLUTION

To resolve this issue, follow these steps:
  1. Click Start, click Run, type dcomcnfg, and then click OK.
  2. In the navigation pane, expand Component Services, expand Computers, expand My Computer, and then expand DCOM Config.
  3. In the right pane, right-click My Computer, click Properties, and then click the COM Security tab.
  4. Right-click FSCController, and then click Properties.
  5. Click the Security tab, and then click Edit in the Launch and Activation Permissions area.
  6. Make sure that the user account is listed under Group or user names. If the user account is not listed, add the user account.
  7. Click to select the Allow check box for the following permissions:
    • Local Launch
    • Remote Launch
    • Local Activation
    • Remote Activation
  8. Click OK two times.

APPLIES TO
  • Microsoft Forefront Security for Exchange Server
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