Forefront Server Security or Forefront Protection 2010 for Exchange Server does not obtain scan engine updates, and the following error message is logged in the Programlog.txt file: "Error: The <EngineName> scan engine update timed out"

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Article ID: 939411 - View products that this article applies to.
Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
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Symptoms

Microsoft Forefront Server Security or Microsoft Forefront Protection 2010 for Exchange Server (FPE) does not obtain scan engine updates. Additionally, one of the following error messages is logged in the Programlog.txt file and in the Application log:
Error: The EngineName scan engine update timed out while downloading files.
Error: The EngineName scan engine update timed out while disabling the scan engine.

Cause

This issue occurs if Forefront Server Security or Forefront Protection 2010 for Exchange Server (FPE) takes more than five minutes to download the scan engine. By default, the time-out setting for the engine download process is 300 seconds (five minutes).

Typically, this issue occurs when intermittent network problems occur or when you download scan engines over a slow Internet connection.

Resolution

To resolve this issue, follow these steps.

For Forefront Security for Exchange or Forefront Security for SharePoint

To have us fix this problem for you, go to the "Fix it for me" section. If you’d rather fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me

To fix this problem automatically, click the Fix this problem link. Then, click Run in the File Download dialog box and follow the steps in this wizard.
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Fix this problem
Microsoft Fix it 50503
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Note this wizard may be in English only; however, the automatic fix also works for other language versions of Windows.

Note If you are not on the computer that has the problem, you can save the automatic fix to a flash drive or to a CD so that you can run it on the computer that has the problem.

Let me fix it myself

To fix this problem yourself, follow these steps:

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then right-click the following registry subkey, as appropriate for your version of Forefront Security.

    Microsoft Forefront Security for Exchange

    • For AMD64-based computers:
      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Forefront Server Security\Exchange Server

    Microsoft Forefront Security for SharePoint

    • For x86-based computers:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Forefront Server Security\Sharepoint
    • For AMD64-based computers:
      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Forefront Server Security\Sharepoint
  3. Click New, and then click DWORD Value.
  4. Type EngineDownloadTimeout, and then press ENTER.
  5. Right-click EngineDownloadTimeout, and then click Modify.
  6. Type 600 in the Value data box, and then click OK. This setting causes the scan engine download process to time out after 600 seconds (10 minutes).
  7. Exit Registry Editor.
Note You do not have to restart Forefront Server services or Exchange Server services after you change this registry entry.

For Forefront Protection 2010 for Exchange Server

To have us fix this problem for you, go to the "Fix it for me" section. If you’d rather fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me

To fix this problem automatically, click the Fix this problem link. Then, click Run in the File Download dialog box and follow the steps in this wizard.
Collapse this imageExpand this image
assets fixit1
Fix this problem
Microsoft Fix it 50504
Collapse this imageExpand this image
assets fixit2

Note this wizard may be in English only; however, the automatic fix also works for other language versions of Windows.

Note If you are not on the computer that has the problem, you can save the automatic fix to a flash drive or to a CD so that you can run it on the computer that has the problem.

Let me fix it myself

To fix this problem yourself, follow these steps:
  1. Open the FPE console, and then click Policy Management.
  2. Click Global Settings, and then click Engine Options.
  3. Type 600 in the Engine download timeout (seconds) field, and then click Save. This setting causes the scan engine download process to time out after 600 seconds (10 minutes).

Properties

Article ID: 939411 - Last Review: September 22, 2013 - Revision: 4.0
Applies to
  • Microsoft Forefront Security for Exchange Server
  • Microsoft Forefront Security for SharePoint
  • Microsoft Forefront Protection 2010 for Exchange Server
Keywords: 
kberrmsg kbtshoot kbexpertiseadvanced kbprb kbmsifixme kbfixme KB939411

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