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Data may not be migrated or duplicated as expected in Windows Home Server

Article ID:939426
Last Review:July 20, 2007
Revision:1.2
Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/) Description of the Microsoft Windows registry
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SYMPTOMS

In Windows Home Server, data may not be migrated or duplicated as expected.

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CAUSE

This problem may occur if the Drive Extender feature in Windows Home Server is not working correctly. The Drive Extender feature does not work correctly if one of the following conditions is true:
The Defilter.sys file system filter driver is not started.
The Windows Home Server Storage service or the Drive Extender Migrator service is not started.

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RESOLUTION

To resolve this problem, make sure that the Defilter.sys driver, the Windows Home Server Storage service, and the Drive Extender Migrator service are all started. You can do this by performing the procedures in the "Defilter.sys driver" section and in the "Drive Extender Migrator service" section. If these procedures do not resolve the problem, you can try to troubleshoot the problem by viewing the log files that are mentioned in the "Advanced troubleshooting steps" section.

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The Defilter.sys driver

Verify that the Defilter.sys driver is started

To verify that the Defilter.sys driver is started, follow these steps:
1. Click Start, click Run, type cmd, and then press ENTER.
2.At the command prompt, type the following command, and then press ENTER:
Net Start Defilter
3.If you receive the following message, go to the "Drive Extender Migrator service" section:
The requested service has already been started.
If you receive a message that the driver could not be started, go to the "How to start the Defilter driver" section.

How to start the Defilter driver

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
1.Click Start, click Run, type regedit, and then click OK.
2. In the navigation pane, locate, the following registry key, and then click it:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DEFilter
3.In the details pane, double-click the following registry entry:
Value name: Start
Value type: REG_DWORD
4.In the Value data box, type 0, and then click OK.
5. Exit Registry Editor.
6. At a command prompt, type the following command to start the Defilter driver:
Net Start Defilter
If the Defilter driver still does not start, compare all the entries in the Defilter registry key to the entries on a working server computer.

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The Drive Extender Migrator service

Verify that the Server Storage service and the Drive Extender Migrator service are started

1.Click Start, click Run, type services.msc, and then click OK.
2. Verify that the following two services display the Status value and the Startup type value as follows:
NameStatusStartup type
Drive Extender Migrator ServiceStartedManual
Windows Home Server Storage StartedAutomatic
3.If the Status column for any of these services does not display the "Started" value, go to the "How to start the services" section.

How to start the services

1.Double-click the Windows Home Server Storage service.
2. In the Startup type box, click Automatic, and then click Start under Service status.
3. After the service is started, click OK.
4. Double-click Drive Extender Migrator Service.
5. In the Startup type box, click Manual, and then click Start under Service status.
6. After the service is started, click OK.

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Advanced troubleshooting steps

If you still cannot resolve the problem, follow these steps to troubleshoot the problem by viewing the cited log files:
1.Check the following log file to view Drive Extender filter driver errors:
C:\logs\qsm.log
2.Check the following log file to view Drive Extender Migrator service errors:
C:\logs\q_de.log

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REFERENCES

For more information about Windows Home Server, visit the following Microsoft Web sites:
http://www.microsoft.com/WindowsHomeServer (http://www.microsoft.com/WindowsHomeServer)
http://forums.microsoft.com/WindowsHomeServer (http://forums.microsoft.com/WindowsHomeServer)

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APPLIES TO
Windows Home Server

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Keywords: 
kbexpertisebeginner kbtshoot kbmigrate kbprb KB939426

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