Jeśli użytkownik loguje się do Communications Server 2007 za pomocą Communicator 2007, nie może pobrać firmowej książki adresowej i jest wyświetlany komunikat o błędzie: „Cannot Synchronize Address Book” (Nie można zsynchronizować książki adresowej)

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 939530 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Symptomy

Jeśli użytkownik loguje się do programu Microsoft Office Communications Server 2007 za pomocą programu Microsoft Office Communicator 2007, nie może pobrać firmowej książki adresowej. Podczas wyszukiwania kontaktów według nazw nie są wyświetlane żadne wyniki.

Ponadto w programie Communicator 2007 jest wyświetlany następujący komunikat o błędzie:

„Cannot Synchronize Address Book” (Nie można zsynchronizować książki adresowej).
Po kliknięciu tej wiadomości w celu wyświetlenia szczegółów jest wyświetlany następujący komunikat o błędzie:

„Cannot synchronize with the corporate address book because the file could not be found. Please contact your system administrator with this information” (Nie można zsynchronizować z firmową książką adresową, ponieważ nie można odnaleźć pliku. Przekaż tę informację administratorowi systemu).
Po uruchomieniu na serwerze typu front-end programu Communications Server 2007 kreatora sprawdzania poprawności w dzienniku zostanie zarejestrowany następujący komunikat o błędzie:

„Failure [0xC3FC200D] One or more errors were detected” (Awaria [0xC3FC200D] Wykryto jeden lub więcej błędów).
W dzienniku kreatora sprawdzania poprawności rozwiń węzeł Diagnose WebComponents, rozwiń węzeł Check Connectivity, a następnie rozwiń węzeł Checking Address Book Server configuration. W polu Check Http URL jest podany adres URL lokalizacji pobierania książki adresowej i następujący komunikat o błędzie.

„Internal Error: ConnectFailure” (Błąd wewnętrzny: ConnectFailure).

Przyczyna

Ten problem występuje, jeśli dla witryny sieci Web, gdzie znajduje się książka adresowa, nie jest zainstalowany prawidłowy certyfikat protokołu Secure Sockets Layer (SSL).

Rozwiązanie

Aby rozwiązać ten problem, należy sprawić, aby dla witryny sieci Web, gdzie znajduje się książka adresowa, był zainstalowany prawidłowy certyfikat protokołu SSL. Aby to zrobić, wykonaj następujące kroki:
  1. Na komputerze, na którym jest uruchomiony program Internet Information Services (IIS), kliknij przycisk Start i polecenie Uruchom. Wpisz polecenie inetmgr.msc, a następnie kliknij przycisk OK.
  2. Rozwiń węzeł Nazwa_komputera (komputer lokalny), rozwiń węzeł Witryny sieci Web, kliknij prawym przyciskiem myszy witrynę sieci Web, gdzie znajduje się książka adresowa, a następnie kliknij polecenie Właściwości.
  3. Kliknij kartę Zabezpieczenia katalogów.
  4. W sekcji Bezpieczna komunikacja sprawdź, czy jest dostępny przycisk Wyświetl certyfikat.

    Uwaga: Jeśli przycisk Wyświetl certyfikat jest dostępny, kliknij go. Wtedy możesz określić, czy certyfikat jest prawidłowy.
    • Jeśli certyfikat jest nieprawidłowy, wykonaj następujące kroki:
      1. W oknie dialogowym Właściwości: Nazwa_witryny_sieci_Web kliknij przycisk Certyfikat serwera.
      2. Kliknij przycisk Dalej, a następnie kliknij opcję Odnów bieżący certyfikat. Możesz też kliknąć opcję Zamień bieżący certyfikat. Następnie postępuj zgodnie z instrukcjami, aby zakończyć działanie kreatora certyfikatów programu IIS.

        Uwaga: Kreator certyfikatów programu IIS pomaga odnowić certyfikat lub zamienić certyfikat na prawidłowy.

        Aby uzyskać więcej informacji dotyczących żądania certyfikatu i instalowania certyfikatu w programie IIS, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
        299875 Implementowanie protokołu SSL w programie IIS
    • Jeśli przycisk Wyświetl certyfikat jest niedostępny, oznacza to, że na komputerze nie jest zainstalowany żaden certyfikat. Musisz zainstalować certyfikat dla tej witryny sieci Web. Aby to zrobić, wykonaj następujące kroki:
      1. W oknie dialogowym Właściwości: Nazwa_witryny_sieci_Web kliknij przycisk Certyfikat serwera.
      2. Kliknij przycisk Dalej, kliknij opcję Utwórz nowy certyfikat, a następnie postępuj zgodnie z instrukcjami, aby zakończyć działanie kreatora certyfikatów programu IIS.

        Uwaga: Kreator certyfikatów programu IIS pomaga zainstalować certyfikat dla tej witryny sieci Web.

        Aby uzyskać więcej informacji dotyczących żądania certyfikatu i instalowania certyfikatu w programie IIS, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
        299875 Implementowanie protokołu SSL w programie IIS

Właściwości

Numer ID artykułu: 939530 - Ostatnia weryfikacja: 3 stycznia 2008 - Weryfikacja: 1.3
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office Communications Server 2007 Enterprise Edition
  • Microsoft Office Communications Server 2007 Standard Edition
  • Microsoft Office Communicator 2007
Słowa kluczowe: 
kberrmsg kbtshoot kbprb kbexpertiseinter KB939530

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com