An application that is packaged by a version of InstallShield that is earlier than InstallShield 12 cannot be installed under the system account context in Windows Vista

Article translations Article translations
Article ID: 939677 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

In Windows Vista, an application that is packaged by a version of InstallShield that is earlier than InstallShield 12 cannot be installed under the system account context.

CAUSE

This behavior occurs because of a design change for the system profile in Windows Vista.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, no prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Update.mumNot Applicable2,51828-Jun-200713:39Not Applicable
X86_681e9760df61e7573759a1869f9304ec_31bf3856ad364e35_6.0.6000.20629_none_298fdaead10a3e28.manifestNot Applicable72528-Jun-200713:39Not Applicable
X86_6e4937124d956d4dd68da83b0aec1012_31bf3856ad364e35_6.0.6000.20629_none_49fd62e3e38a3e7a.manifestNot Applicable72528-Jun-200713:39Not Applicable
X86_microsoft-windows-a..ence-mitigations-c1_31bf3856ad364e35_6.0.6000.20629_none_0ab8f72b0e4b9970.manifestNot Applicable4,53728-Jun-200713:41Not Applicable
X86_microsoft-windows-a..ence-mitigations-c4_31bf3856ad364e35_6.0.6000.20629_none_0abbf8090e48e575.manifestNot Applicable9,99928-Jun-200713:41Not Applicable
Acres.dll6.0.6000.206292,56027-Jun-200723:30x86
Sysmain.sdbNot Applicable3,216,43227-Jun-200722:34Not Applicable
Acspecfc.dll6.0.6000.20629449,53628-Jun-200702:13x86
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_3c621e72f87696c71449980bb76e2bcf_31bf3856ad364e35_6.0.6000.20629_none_6be90e4ee268e0f7.manifestNot Applicable1,09828-Jun-200713:39Not Applicable
Amd64_ad65ec401aa98b840cb6b11d1c5b6908_31bf3856ad364e35_6.0.6000.20629_none_a51122619cb75409.manifestNot Applicable1,10028-Jun-200713:39Not Applicable
Amd64_microsoft-windows-a..ence-mitigations-c1_31bf3856ad364e35_6.0.6000.20629_none_66d792aec6a90aa6.manifestNot Applicable3,55728-Jun-200713:46Not Applicable
Amd64_microsoft-windows-a..ence-mitigations-c4_31bf3856ad364e35_6.0.6000.20629_none_66da938cc6a656ab.manifestNot Applicable4,68428-Jun-200713:46Not Applicable
Update.mumNot Applicable3,02028-Jun-200713:39Not Applicable
Wow64_microsoft-windows-a..ence-mitigations-c1_31bf3856ad364e35_6.0.6000.20629_none_712c3d00fb09cca1.manifestNot Applicable4,46028-Jun-200713:46Not Applicable
Sysmain.sdbNot Applicable41,83627-Jun-200722:33Not Applicable
Acspecfc.dll6.0.6000.2062988,06428-Jun-200703:23x64
Acres.dll6.0.6000.206292,56027-Jun-200723:30x86
Sysmain.sdbNot Applicable3,216,43227-Jun-200722:34Not Applicable

WORKAROUND

In Windows Vista, the system profile is separate from the rest of the profiles, and nothing is pre-created in the system profile. Therefore, if the application has to be installed under the system account context of Windows Vista, the application has to create a directory that can store the content that is used in the system profile.

To work around this behavior, the following directory can be created to store the files for the application in Window Vista:
%systemroot%\System32\config\systemprofile\AppData\Roaming\Microsoft\Windows\Start Menu\Programs

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

For more information about InstallShield, visit the following Web site:
http://www.installshield.com
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Properties

Article ID: 939677 - Last Review: October 8, 2011 - Revision: 3.0
APPLIES TO
  • Windows Vista Business
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Enterprise
Keywords: 
kbautohotfix kbvistasp1fix kbexpertiseadvanced kbbug kbfix kbHotfixServer kbqfe KB939677

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com