Depois de criptografar recursos usando sistema RITMO antipirataria InterLok em um computador baseado no Windows Vista, alguns aplicativos podem funcionar incorretamente

Traduções deste artigo Traduções deste artigo
ID do artigo: 939750 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Depois de criptografar recursos usando sistema RITMO antipirataria InterLok em um computador baseado no Windows Vista, alguns aplicativos podem funcionar incorretamente. Esse problema ocorre se os aplicativos acessam recursos criptografados.

Causa

Esse problema é causado por uma alteração de design de segurança no Windows Vista. No Windows Vista, ' o sistema do Windows Resource Manager ' (WSRM) valida a estrutura de dados mais detalhadamente que Windows XP.

Resolução

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Vista. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
935791Como obter o service pack mais recente do Windows Vista

Informações sobre o hotfix

Um hotfix está disponível para resolver esse problema. Depois de habilitar o hotfix, o hotfix desativa a validação para alguns processos específicos. Portanto, os aplicativos podem funcionar corretamente. Entretanto, após a validação estiver desativada, esses processos específicos ficam vulneráveis a ataques por arquivos corrompidos. Além disso, esses processos podem carregar recursos criptografados que não são válidos.Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisitos de reinicialização

Você precisa reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes lançados anteriormente.

Informações do registro

Para usar um dos hotfixes neste pacote, não é necessário fazer alterações no registro.

Como habilitar o hotfix

importante Essas etapas podem aumentar o risco de segurança. Essas etapas também podem tornar o computador ou rede mais vulneráveis aos ataques de usuários mal-intencionados ou softwares mal-intencionados como vírus. Recomendamos o processo descrito neste artigo para ativar programas para operar como eles são criados para ou para implementar recursos específicos do programa. Antes de fazer essas alterações, recomendamos que avalie os riscos associados à implementação deste processo no seu ambiente específico. Caso você decida implementar esse processo, execute quaisquer etapas apropriadas adicionais para ajudar a proteger o sistema. Recomendamos que você use esse processo apenas se você realmente precisar esse processo.

Para habilitar o hotfix, siga estas etapas:
  1. Inicie o Compatibility Administrator.

    Observação Administrador de compatibilidade é um componente do Microsoft Application Compatibility Toolkit 5.0. Para baixar o Microsoft Application Compatibility Toolkit 5.0, visite o seguinte site da Microsoft:
    http://technet.microsoft.com/en-us/windowsvista/aa905102.aspx
  2. No nó de Bancos de dados personalizados da árvore de console, clique com o botão direito do mouse Novo banco de dados , aponte para Criar novo e, em seguida, clique em Corrigir aplicativos .
  3. Na caixa nome do programa para ser corrigido , digite o nome do aplicativo.
  4. Na caixa nome do fornecedor para este programa , digite o nome do fornecedor.
  5. Clique em localização do arquivo de programa , clique no caminho, clique no nome do aplicativo, clique em Abrir e, em seguida, clique em Avançar .
  6. Na caixa Brazilian OS modos , clique em Nenhuma e, em seguida, clique em Avançar .
  7. Na caixa Correção de compatibilidade , clique em para selecionar a caixa de seleção NoHardeningLoadResource , clique em Avançar e, em seguida, clique em Concluir .
A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Versões de 32 bits do Windows Vista
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Update.mumNão aplicável2,51816 De julho de 200720: 26Não aplicável
X86_6dfdee4c6b5e16b50b38bb3d73e646be_31bf3856ad364e35_6.0.6000.20640_none_c62ebee6ad00682a.manifestNão aplicável72516 De julho de 200720: 26Não aplicável
X86_f63798249566b1f7cb51e442d7f71d41_31bf3856ad364e35_6.0.6000.20640_none_8297781cfd915268.manifestNão aplicável72516 De julho de 200720: 26Não aplicável
X86_microsoft-windows-um...ence-atenuações-c1_31bf3856ad364e35_6.0.6000.20640_none_0a9a54b90e63ed43.manifestNão aplicável4,53716 De julho de 200720: 29Não aplicável
X86_microsoft-windows-um...ence-atenuações-c3_31bf3856ad364e35_6.0.6000.20640_none_0a9c554d0e621ff1.manifestNão aplicável10,31916 De julho de 200720: 29Não aplicável
Acres.dll6.0.6000.206402,56013 De julho de 200723: 41x 86
Sysmain.sdbNão aplicável3,217,65613 De julho de 200722: 46Não aplicável
Acgenral.dll6.0.6000.206402,144,76814 De julho de 200702: 29x 86
Versões de 64 bits do Windows Vista
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Amd64_05b495736897f0758c42f80f5ac7a961_31bf3856ad364e35_6.0.6000.20640_none_07002eb3ba7ffcda.manifestNão aplicável1.09816 De julho de 200720: 26Não aplicável
Amd64_c11c781d31995fee90773633fe7820ba_31bf3856ad364e35_6.0.6000.20640_none_039f581d984ecc6f.manifestNão aplicável1,10016 De julho de 200720: 26Não aplicável
Amd64_microsoft-windows-um...ence-atenuações-c1_31bf3856ad364e35_6.0.6000.20640_none_66b8f03cc6c15e79.manifestNão aplicável3,55716 De julho de 200720: 49Não aplicável
Amd64_microsoft-windows-um...ence-atenuações-c3_31bf3856ad364e35_6.0.6000.20640_none_66baf0d0c6bf9127.manifestNão aplicável6,99416 De julho de 200720: 49Não aplicável
Update.mumNão aplicável3,02016 De julho de 200720: 26Não aplicável
Wow64_microsoft-windows-um...ence-atenuações-c1_31bf3856ad364e35_6.0.6000.20640_none_710d9a8efb222074.manifestNão aplicável4,46016 De julho de 200720: 49Não aplicável
Sysmain.sdbNão aplicável41,83613 De julho de 200722: 43Não aplicável
Acgenral.dll6.0.6000.20640275.45614 De julho de 200703: 29x 64
Acres.dll6.0.6000.206402,56013 De julho de 200723: 41x 86
Sysmain.sdbNão aplicável3,217,65613 De julho de 200722: 46Não aplicável

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a". Esse problema foi corrigido primeiro no Windows Vista Service Pack 1.

Mais Informações

Para obter mais informações sobre o sistema RITMO antipirataria InterLok, visite o seguinte site RITMO antipirataria Web:
http://www.paceap.com/
A Microsoft fornece terceiros informações de contatos para ajudá-lo a encontrar suporte técnico. Essa informações de contatos podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações contatos de terceiros.

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Os produtos de terceiros mencionados neste artigo são fabricados por empresas que são independentes da Microsoft. Microsoft não oferece garantia, implícita ou não, sobre o desempenho ou confiabilidade desses produtos.

Propriedades

ID do artigo: 939750 - Última revisão: segunda-feira, 19 de maio de 2008 - Revisão: 3.1
A informação contida neste artigo aplica-se a:
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Palavras-chave: 
kbmt kbautohotfix kbvistasp1fix kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB939750 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 939750

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com