Artikel-ID: 939767 - Geändert am: Donnerstag, 23. Oktober 2008 - Version: 3.0

Fehlermeldung, wenn ein NFS-Client eine Datei auf einer NFS-Freigabe in Windows Storage Server 2003, Windows Server 2003 R2 oder Windows Services for UNIX 3.5 zugreift: "Stop 0x0000007E (SYSTEM_THREAD_EXCEPTION_NOT_HANDLED)"

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Problembeschreibung

Einem Computer mit Microsoft Windows Storage Server 2003, Windows Server 2003 R2 oder Microsoft Windows Services for UNIX 3.5 reagiert möglicherweise nicht mehr nach dem Zufallsprinzip. Außerdem erhalten Sie die folgende STOP-Fehlermeldung:
Stop 0x0000007E (SYSTEM_THREAD_EXCEPTION_NOT_HANDLED)
Dieses Problem bei Auftreten der folgenden Bedingungen true:
  • Ein Clientcomputer NFS (Network File System) wird verwendet, um eine Datei zuzugreifen.
  • Die Datei hat das Attribut SYSTEM mithilfe von NFS.
STOP-Fehlers ist es wahrscheinlicher in das folgende Szenario auftreten:
  • Der NFS-Client-Computer ändert die Dateiattribute einer Datei.
    Der NFS-Client-Computer ändert z. B. Besitzer -Attribut oder die Gruppe -Attribut.
  • Diese Datei hat das Attribut SYSTEM .
  • Das Attribut SYSTEM wurde mithilfe von Windows Storage Server oder mithilfe von Windows Services für UNIX festlegen.

Ursache

Dieses Problem aufgrund eines Problems in Server für NFS. Wenn die folgenden Bedingungen erfüllt sind, erkennt Server for NFS asynchrone e/a-Abschluss-Operationen für Lesevorgänge Metadaten nicht ordnungsgemäß:
  • Es ist ein Handle für eine Datei auf dem Server für NFS-Cache behandelt.
  • Das Handle auf dem Server für NFS-Handle Cache wurde für asynchrone e/A aufgrund von einer früheren Anforderung an Server für NFS geöffnet.
  • Die Metadaten für die Datei sind nicht vorhanden in der Windows-Datei Systemcache.
Unter diesen Bedingungen erkennt Server for NFS keine asynchrone e/A-Abschlüsse für die Metadaten Lesevorgang Server for NFS versucht, die Datei Attribut Metadaten abzurufen.

Daher weiterhin Server for NFS Wartens der e/a-Vorgang abzuschließen. Einige Zeit später wird das Dateisystem e/a-Vorgang beendet. Anschließend schreibt das Dateisystem den Abschlussstatus e/A an einem Speicherort auf dem CPU-Stapel, die beim Starten von e/a-Vorgang. Speicherbeschädigung kann auftreten, wenn wieder der Stapel Speicherort verwendet. Daher kann der Computer reagiert.

Hinweis: Das Dateiattribut SYSTEM ist nicht direkt mit dem Problem verbunden, die in diesem Artikel beschriebene. Wenn dieses Attribut festgelegt ist, ist jedoch ein Zeitsteuerungsproblem tritt eher auf. Dieses Timing-Problem betrifft die Möglichkeit, die das NTFS-Dateisystem die Art und Weise ändert, die e/a-Vorgang abgeschlossen ist. Da das Problem, das in diesem Artikel erwähnten auf ein Zeitsteuerungsproblem bezieht, konnte eine Änderung im Verhalten von NTFS die Art und Weise auswirken, die der Server für NFS-Problem Auswirkungen auf den Computer.

Lösung

Hotfix-Informationen

Informationen zum Hotfix-installation

  • Die Komponente "Server für NFS" ist jetzt Teil des Betriebssystems Windows Server 2003 R2. Installation von Services for UNIX 3.5 auf einem Windows Server 2003 R2-basierten System NFS-Funktionalität erhalten ist nicht mehr erforderlich. Es ist jetzt eine optionale Windows-Komponente und kann an ein System R2 mithilfe des Software Windows Komponenten-Assistenten hinzugefügt werden.
  • Storage Server-Paket nur installiert werden kann, in Windows Storage Server 2003.
  • Die Services für UNIX 3.5-Paket können auf jedem Windows 2000-basierten, Windows-basierte, Windows 2003-Computer installiert werden, auf dem Server für NFS-Dienst von Services für UNIX 3.5-Software ausgeführt wird. Allerdings kann das Paket nicht auf einem Computer mit Windows Server 2003 R2 installiert.

Windows Server 2003 R2

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieses Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.
Voraussetzungen
Um diesen Hotfix installieren, muss auf Ihrem Computer Windows Server 2003 R2 mit Service Pack 1 (SP1) oder Windows Server 2003 R2 mit Service Pack 2 (SP2) und Microsoft Services für NFS ausgeführt werden.
Neustartanforderung
Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfixes.
Dateiinformationen
Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time aufgeführt (UTC). Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Windows Storage Server 2003 R2 mit Service Pack 1, x 86-edition
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-Anforderung
Nfssvr.sys5.2.3790.3038467,45601-Nov 200711: 55X 86SP1
Windows Storage Server 2003 mit SP2, x 86-edition
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-Anforderung
Nfssvr.sys5.2.3790.4182467,45602-Nov 200715: 32X 86SP2
Windows Storage Server 2003 mit SP1, x 64 edition
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-Anforderung
Nfssvr.sys5.2.3790.3038813,56805-Nov 200702: 35X 64SP1
Windows Storage Server 2003 R2 mit SP2, x 64 edition
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-Anforderung
Nfssvr.sys5.2.3790.4182813,56805-Nov 200703: 00X 64SP2

Windows Storage Server 2003

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieses Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.
Voraussetzungen
Um diesen Hotfix anwenden, muss Ihr Computer Windows Storage Server 2003 mit Service Pack 1 (SP1) oder Windows Storage Server 2003 mit Service Pack 2 (SP2) ausgeführt werden.
Neustartanforderung
Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfixes.
Dateiinformationen
Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time aufgeführt (UTC). Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Nfssvc.exe8.0.2254.1957,85618-Jul-200707: 33X 86
Nfssvr.sys8.0.2254.19449,02418-Jul-200707: 33Nicht zutreffend

Windows Services for UNIX 3.5

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, senden Sie eine Anfrage an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.
Voraussetzungen
Um diesen Hotfix installieren, müssen Sie Windows Services for UNIX 3.5 ausgeführt werden.
Neustartanforderung
Sie müssen den Computer neu starten um die Änderungen anzuwenden, nachdem Sie diesen Hotfix anwenden.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keinen anderen Hotfix.
Dateiinformationen
Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time aufgeführt (UTC). Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP AnforderungServicebereich
NTDSA.dll5.2.3790.6231,416,19220-Dez. 200609: 28X 86KeinerRTMGDR
NTDSA.dll5.2.3790.6231,432,06420-Dez. 200609: 30X 86KeinerRTMQFE
Ws03res.dll5.2.3790.62367,07219-Dez. 200609: 36X 86KeinerRTMQFE
Nfssvc.exe8.0.2254.1957,85626-Jul-200706: 04X 86KeinerNicht zutreffend
Nfssvr.sys8.0.2254.19448,89626-Jul-200706: 04Nicht zutreffendKeinerNicht zutreffend
NTDSA.dll5.2.3790.28511,623,04020-Dez. 200609: 44X 86SP1SP1GDR
Ntdsa.HP.dll5.2.3790.285181,92020-Dez. 200609: 44X 86SP1SP1GDR
NTDSA.dll5.2.3790.28511,521,66420-Dez. 200609: 49X 86SP1SP1QFE
W03a2409.dll5.2.3790.285127,13619-Dez. 200613: 31X 86SP1SP1QFE

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Wenn Hotifx 939767 deinstalliert, ein ? STATUS_USER_MAPPED_FILE eingeben Fehler auftreten. Fehler tritt auf, weil der Nfssvr.sys [8.0.2254.19] Datei wurde überschrieben wurde. Diese Datei befindet sich der C:\WINDOWS\system32\drivers-Verzeichnis. Das Betriebssystem überschreibt die Datei mit der alten Version der Nfssvr.sys Datei, die im Verzeichnis %WINDIR%\$NtUninstallKB939767 befindet. Selbst wenn der Kopiervorgang Datei fehlschlägt, wird der Installationsvorgang abgeschlossen.

In Windows Storage Server 2003 Wenn Hotfix 939767 deinstalliert wird, wird das Nfssvr.sys-Modul nicht mehr die alte Version zurückgesetzt. Wenn dieses Problem auftritt, gehen Sie folgendermaßen vor:
  1. Geben Sie an einer Eingabeaufforderung Folgendes ersetzen Sie den aktiven Treiber (Nfssvr.sys):
    InUse.exe %WINDIR%\$NtUninstallKB939767$\nfssvr.sys %WINDIR%\system32\drivers\nfssvr.sys
  2. Verwenden Sie die Software in der Systemsteuerung um Hotfix 939767 zu entfernen.
  3. Starten Sie den Computer neu.
  4. Überprüfen Sie die folgenden Punkte:
    • Die Version der Nfssvr.sys-Datei wurde auf die alte Version zurückgesetzt.
    • Hotfix 939767 wurde aus dem Hinzufügen oder entfernen entfernt Programme Element.
    • Das Verzeichnis %WINDIR%\$NtUninstallKB939767$ wurde entfernt.
    • Die System- und Protokolldateien enthalten keine Fehler, die mit NFS verknüpft sind.
Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Storage Server 2003
  • Microsoft Windows Services for UNIX 3.5
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 939767  (http://support.microsoft.com/kb/939767/en-us/ )
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