ID do artigo: 939767 - Última revisão: quinta-feira, 23 de outubro de 2008 - Revisão: 3.0

Mensagem de erro quando um cliente NFS acessa um arquivo em um compartilhamento NFS no Windows Storage Server 2003, no Windows Server 2003 R2 ou no Windows Services for UNIX 3.5: "Stop 0x0000007E (SYSTEM_THREAD_EXCEPTION_NOT_HANDLED)"

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Um computador que esteja executando o Microsoft Windows Storage Server 2003, Windows Server 2003 R2 ou Microsoft Windows Services for UNIX 3.5 aleatoriamente pode parar de responder. Além disso, é exibida a seguinte mensagem de erro Stop:
STOP 0x0000007E (SYSTEM_THREAD_EXCEPTION_NOT_HANDLED)
Esse problema pode ocorrer quando as condições seguintes forem ambas verdadeiras:
  • Um computador de cliente NFS (Network File System) é usado para acessar um arquivo.
  • O arquivo tem o atributo de sistema definido usando o NFS.
O erro de parada é mais provável de ocorrer na seguinte situação:
  • O computador do cliente NFS modifica os atributos de arquivo de um arquivo.
    Por exemplo, o computador do cliente NFS modifica o atributo de proprietário ou o atributo de grupo .
  • Este arquivo tem tido o atributo de sistema definido.
  • O atributo sistema foi definido pelo usando o Windows Storage Server ou usando o Windows Services for UNIX.

Causa

Esse problema ocorre devido a um problema no Server for NFS. Quando as seguintes condições forem verdadeiras, o Server for NFS não detecta corretamente operações de conclusão E/s assíncronas para operações de leitura de metadados:
  • Há um identificador para um arquivo no servidor para NFS manipular cache.
  • O identificador no servidor para NFS cache de identificador foi aberto para E/s assíncrona devido uma solicitação anterior para o Server for NFS.
  • Os metadados para o arquivo não está presente no Windows arquivo cache do sistema.
Sob essas condições, Server for NFS não detecta as conclusões E/s assíncronas para a operação de leitura quando o Server for NFS tenta recuperar os metadados de atributo de arquivo de metadados.

Portanto, Server for NFS continua sem esperar que a operação de E/s concluir. Algum tempo posterior, o sistema de arquivos termina a operação de E/s. Em seguida, o sistema de arquivo grava o status de conclusão E/s para um local na pilha de CPU que existia quando a operação de E/s iniciada. Se o local de pilha tem sido reutilizado, pode ocorrer corrupção de memória. Portanto, o computador pode parar de responder.

Observação O atributo de arquivo de sistema não está diretamente relacionado ao problema descrito neste artigo. No entanto, se esse atributo é definido, é mais provável de ocorrer um problema de sincronismo. Esse problema tempo afeta a maneira como o sistema de arquivos NTFS altera a forma que a operação de E/s é concluída. Como o problema mencionado neste artigo é relacionado a um problema de sincronismo, uma alteração no comportamento do NTFS pode afetar a maneira que o servidor para NFS problema afeta o computador.

Resolução

Informações sobre o hotfix

Informações sobre a instalação do hotfix

  • O componente "Server para NFS" agora é parte do sistema operacional Windows Server 2003 R2. Instalando o Services for UNIX 3.5 em um sistema baseado no Windows Server 2003 R2 para obter funcionalidade NFS não é mais necessário. Agora é um componente opcional do Windows e pode ser adicionado a um sistema R2 usando o Assistente de componentes do Windows Adicionar ou remover.
  • O pacote do servidor armazenamento só pode ser instalado no Windows Storage Server 2003.
  • Os serviços para UNIX 3.5 pacote podem ser instalados em qualquer computador baseado no Windows 2000, baseado no Windows XP, Windows Server 2003 que esteja executando Server para NFS serviço do Services for UNIX 3.5 software. No entanto, o pacote não pode ser instalado em um computador com Windows Server 2003 R2.

Windows Server 2003 R2

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos
Para aplicar esse hotfix, seu computador deve estar executando o Windows Server 2003 R2 com Service Pack 1 (SP1) ou Windows Server 2003 R2 com o Service Pack 2 (SP2) e serviços de NFS da Microsoft.
Requisitos de reinicialização
Reinicie o computador após aplicar esse hotfix.
Informações sobre a substituição do hotfix
Esse hotfix não substitui um hotfix lançado anteriormente.
Informações sobre o arquivo
A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows Storage Server 2003 R2 com Service Pack 1, x 86 edition
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Nfssvr.sys5.2.3790.3038467,45601-Novembro de 200711: 55x 86SP1
Windows Storage Server 2003 com SP2, x 86 edition
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Nfssvr.sys5.2.3790.4182467,45602-Novembro de 200715: 32x 86SP2
Windows Storage Server 2003 com SP1, x 64 edition
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Nfssvr.sys5.2.3790.3038813,56805 De novembro de 200702: 35x 64SP1
Windows Storage Server 2003 R2 com SP2, x 64 edition
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SP
Nfssvr.sys5.2.3790.4182813,56805 De novembro de 200703: 00x 64SP2

Windows Storage Server 2003

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos
Para aplicar esse hotfix, seu computador deve estar executando o Windows Storage Server 2003 com Service Pack 1 (SP1) ou o Windows Storage Server 2003 com Service Pack 2 (SP2).
Requisitos de reinicialização
Reinicie o computador após aplicar esse hotfix.
Informações sobre a substituição do hotfix
Esse hotfix não substitui um hotfix lançado anteriormente.
Informações sobre o arquivo
A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Nfssvc.exe8.0.2254.1957,85618 De julho de 200707: 33x 86
Nfssvr.sys8.0.2254.19449,02418 De julho de 200707: 33Não aplicável

Windows Services for UNIX 3.5

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibido, envie uma solicitação para suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos
Para instalar esse hotfix, você deve estar executando o Windows Services for UNIX 3.5.
Requisitos de reinicialização
Reinicie o computador para aplicar as alterações depois de aplicar esse hotfix.
Informações sobre a substituição do hotfix
Esse hotfix não substitui nenhum outro hotfix.
Informações sobre o arquivo
A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaSP requisitoRamificação do serviço
Ntdsa.dll5.2.3790.6231,416,19220 De dezembro de 200609: 28x 86NenhumRTMGDR
Ntdsa.dll5.2.3790.6231,432,06420 De dezembro de 200609: 30x 86NenhumRTMQFE
Ws03res.dll5.2.3790.62367,07219 De dezembro de 200609: 36x 86NenhumRTMQFE
Nfssvc.exe8.0.2254.1957,85626 De julho de 200706/04:x 86NenhumNão aplicável
Nfssvr.sys8.0.2254.19448,89626 De julho de 200706/04:Não aplicávelNenhumNão aplicável
Ntdsa.dll5.2.3790.28511,623,04020 De dezembro de 200609: 44x 86SP1SP1GDR
Ntdsa.HP.dll5.2.3790.285181,92020 De dezembro de 200609: 44x 86SP1SP1GDR
Ntdsa.dll5.2.3790.28511,521,66420 De dezembro de 200609: 49x 86SP1SP1QFE
W03a2409.dll5.2.3790.285127,13619 De dezembro de 200613: 31x 86SP1SP1QFE

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Quando hotifx 939767 é desinstalado, pode ocorrer um erro ? STATUS_USER_MAPPED_FILE ?. Este erro ocorre porque o Nfssvr.sys [8.0.2254.19] do arquivo foi substituído. Esse arquivo está localizado na C:\Windows\System32\Drivers diretório. O sistema operacional substitui o arquivo com a versão antiga do Nfssvr.sys arquivo que está localizado no diretório %WINDIR%\$NtUninstallKB939767. Mesmo se a operação de cópia de arquivo falha, o processo de instalação é concluído.

No Windows Storage Server 2003, quando o hotfix 939767 é desinstalado, o módulo Nfssvr.sys não é revertido para a versão antiga. Se esse problema ocorrer, execute estas etapas:
  1. Em um prompt de comando, digite o seguinte comando para substituir o driver ativo (Nfssvr.sys):
    inuse.exe %WINDIR%\$NtUninstallKB939767$\nfssvr.sys %WINDIR%\system32\drivers\nfssvr.sys
  2. Use o item Adicionar ou remover programas no painel de controle para remover o hotfix 939767.
  3. Reinicie o computador.
  4. Verifique os seguintes itens:
    • A versão do arquivo Nfssvr.sys foi revertido para a versão antiga.
    • Hotfix 939767 foi removido do Adicionar ou remover programas item.
    • O diretório %WINDIR%\$NtUninstallKB939767$ foi removido.
    • Os arquivos de log sistema e de aplicativos não contêm erros relacionados ao NFS.
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Storage Server 2003
  • Microsoft Windows Services for UNIX 3.5
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
Palavras-chave: 
kbmt kbautohotfix kberrmsg kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB939767 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 939767  (http://support.microsoft.com/kb/939767/en-us/ )