Error message when a Windows XP SP2-based or Windows Server 2003-based multiprocessor computer uses driver Battc.sys: "STOP 0x000000D1 DRIVER_IRQL_NOT_LESS_OR_EQUAL"

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Article ID: 939780 - View products that this article applies to.
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SYMPTOMS

When you work with a Windows XP Service Pack 2-based or Windows Server 2003-based multiprocessor computer, you receive an error message that resembles the following:
STOP 0x000000D1 (parameter1, parameter2, parameter3, parameter4)
DRIVER_IRQL_NOT_LESS_OR_EQUAL
Note The values of the parameters vary in different situations.

This problem occurs if one of the following conditions is true:
  • The computer is a portable computer.
  • The computer is plugged into an uninterruptable power supply (UPS).

CAUSE

This error occurs because of a problem in the battery driver (Battc.sys).

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have one of the following installed:
  • Windows XP Service Pack 2 (SP2)

    For more information about how to obtain this service pack, click the following article number to view the article in the Microsoft Knowledge Base:
    322389 How to obtain the latest Windows XP service pack
  • Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2)

    For more information about how to obtain this service pack, click the following article number to view the article in the Microsoft Knowledge Base:
    889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP, 32-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimeSP requirementService branch
Battc.sys5.1.2600.317914,20817-Jul-200711:27SP2SP2QFE
Windows Server 2003, 32-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimeSP requirementService branch
Battc.sys5.2.3790.334314,72014-May-200909:47SP1SP1QFE
Battc.sys5.2.3790.451414,72014-May-200910:46SP2SP2QFE
Windows Server 2003, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Battc.sys5.2.3790.334319,20015-May-200903:24x64SP1SP1QFE
Battc.sys5.2.3790.451419,07215-May-200903:33x64SP2SP2QFE
Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimeSP requirementService branch
Battc.sys5.2.3790.334329,31215-May-200903:24SP1SP1QFE
Battc.sys5.2.3790.451429,31215-May-200903:29SP2SP2QFE

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 939780 - Last Review: October 8, 2011 - Revision: 5.0
APPLIES TO
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbexpertisebeginner kbexpertiseadvanced kbfix kbqfe kbHotfixServer KB939780

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