Artikel-ID: 939797 - Geändert am: Freitag, 26. Oktober 2007 - Version: 1.2

Update: Message Delivery möglicherweise verzögert werden bis 23: 59 Uhr in BizTalk Server 2006

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Problembeschreibung

Wenn Microsoft BizTalk Server 2006 ein Abonnement für eine Anforderung / Antwort-Nachricht erstellt, konvertiert BizTalk Server Universal Time Coordinated (UTC) in die lokale Zeit. Zu diesem Zweck berechnet BizTalk Server die Differenz zwischen der aktuellen lokalen Zeit und die aktuelle UTC-Zeit. BizTalk Server hat das Dienstfenster des Sendeports dann diesen Wert hinzugefügt. Dieser Zeitunterschied konnte das Dienstfenster aktivieren, obwohl das Service-Fenster auf den Sendeport nicht explizit aktiviert wurde.

Dieses Problem möglicherweise Nachrichtenübermittlung an bis 23: 59 Uhr verzögert werden. Die Client-Anwendung kann auch Timeout Meldungen anstelle des erwarteten Antwort angezeigt.

Ursache

Dieses Problem tritt auf, wenn eine Differenz von mehreren Millisekunden zwischen den aufrufen, die BizTalk Server in die GetUTCDate -Funktion und der GetLocalDate -Funktion. Dieser Unterschied kann BizTalk Server messaging Service-Fenster auf den Sendeport aktivieren, obwohl der Ersteller das Dienstfenster nicht explizit aktiviert wurde. Endpunkt-Manager (EPM) fordert ein Dienstfenster nicht, wenn die ENDPUNKTZUORDNUNG das Abonnement erstellt. Daher werden die Antwortnachrichten aus der MessageBox bis 23: 59 Uhr nicht zugestellt.

Lösung

Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben.

Methode 1

Aktualisieren Sie den Computer, auf dem BizTalk Server 2006 zu BizTalk Server 2006 R2 ausgeführt wird. Weitere Informationen der folgenden Microsoft-Website:
http://www.microsoft.com/downloads/details.aspx?FamilyID=df2e8a88-fb23-49a4-9ac7-d17f72517d12 (http://www.microsoft.com/downloads/details.aspx?FamilyID=df2e8a88-fb23-49a4-9ac7-d17f72517d12)

Methode 2

Wenden Sie den folgenden Hotfix auf dem Computer mit BizTalk Server 2006.

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.
Voraussetzungen
Benötigen Sie BizTalk Server 2006 installiert haben, um diesen Hotfix anwenden.
Neustartanforderung
Sie müssen den Computer nach Installation dieses Hotfixes neu starten.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keine anderen Hotfixes.
Dateiinformationen
Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Tabelle minimierenTabelle vergrößern
DateinameFileversionDateigrößeDatumUhrzeitPlattform
Msgbox_application_logic.SQLNicht zutreffend506,22206-Jul-200711: 39Nicht zutreffend
Hinweis: Aufgrund kann wechselseitiger Abhängigkeiten zwischen der aktuellste Hotfix, der diese Datei enthält weitere Dateien enthalten.

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft BizTalk Server 2006 Standard Edition
  • Microsoft BizTalk Server 2006 Enterprise Edition
  • Microsoft BizTalk Server 2006 Developer Edition
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 939797  (http://support.microsoft.com/kb/939797/en-us/ )
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