The logon screen is not available after you remove a second monitor when Windows Vista is asleep or in hibernation

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Article ID: 939805 - View products that this article applies to.
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SYMPTOMS

Consider the following scenarios:
  • An additional monitor is connected to a Windows Vista-based desktop computer. The additional monitor is designated as the primary display (the main monitor). The computer goes into hibernation or goes to sleep. This additional monitor is disconnected. The computer resumes from sleep or from hibernation.
  • An external monitor is connected to a portable Windows Vista-based computer. The additional monitor is designated as the primary display (the main monitor). The built-in screen is designated as the secondary display. The computer goes into hibernation or goes to sleep. This external monitor is disconnected. The computer resumes from sleep or from hibernation.
In these scenarios, you cannot see the logon screen. Therefore, you cannot log on to the computer.

CAUSE

This issue occurs because the primary monitor is removed from the computer when the operating system is inactive. The logon screen ordinarily appears on the primary monitor. Therefore, the logon screen is not viewable.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Package_1_for_kb939805~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,78714-Aug-200713:33Not Applicable
Package_2_for_kb939805~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable2,00014-Aug-200713:33Not Applicable
Update.mumNot Applicable1,91314-Aug-200713:33Not Applicable
X86_2274108187eba5e8f4d17303c0f3fe7e_31bf3856ad364e35_6.0.6000.20660_none_d853afd2e4ef6ec0.manifestNot Applicable69614-Aug-200713:33Not Applicable
X86_e894f7e0ee9214b60f72aa8e2eb07cfb_31bf3856ad364e35_6.0.6000.20660_none_a7ce6568c8cd40da.manifestNot Applicable69414-Aug-200713:33Not Applicable
X86_microsoft-windows-lddmcore_31bf3856ad364e35_6.0.6000.20660_none_aa2b1555ffb47ed4.manifestNot Applicable8,95814-Aug-200713:33Not Applicable
X86_microsoft-windows-win32k_31bf3856ad364e35_6.0.6000.20660_none_b755f671b6ae8318.manifestNot Applicable6,92814-Aug-200713:33Not Applicable
Cdd.dll6.0.6000.2066037,37614-Aug-200702:21x86
Dxgkrnl.sys6.0.6000.20660621,56814-Aug-200701:09x86
Win32k.sys6.0.6000.206602,028,54414-Aug-200701:10x86
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_55e3af1d8b7c65affcac8a5ce39f64c0_31bf3856ad364e35_6.0.6000.20660_none_b54cf089a60d84e1.manifestNot Applicable69814-Aug-200713:33Not Applicable
Amd64_78ffc5e2a0f66ed81c05bcce428fd6d9_31bf3856ad364e35_6.0.6000.20660_none_ef1c2ee885abc7c2.manifestNot Applicable70014-Aug-200713:33Not Applicable
Amd64_microsoft-windows-lddmcore_31bf3856ad364e35_6.0.6000.20660_none_0649b0d9b811f00a.manifestNot Applicable9,22314-Aug-200713:38Not Applicable
Amd64_microsoft-windows-win32k_31bf3856ad364e35_6.0.6000.20660_none_137491f56f0bf44e.manifestNot Applicable6,94414-Aug-200713:38Not Applicable
Package_1_for_kb939805~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,79714-Aug-200713:33Not Applicable
Package_2_for_kb939805~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable2,01214-Aug-200713:33Not Applicable
Update.mumNot Applicable1,91314-Aug-200713:33Not Applicable
Cdd.dll6.0.6000.2066047,10414-Aug-200704:38x64
Dxgkrnl.sys6.0.6000.20660879,10414-Aug-200701:19x64
Win32k.sys6.0.6000.206602,750,46414-Aug-200701:21x64

WORKAROUND

To work around this issue, use the following methods in the order that they are presented.

Method 1

Press CTRL+ALT+DELETE, type your password, and then press ENTER. Windows Vista sets the current monitor as the primary monitor, and the display appears.

Method 2

If Method 1 does not work, type your password, and then press ENTER. Do not press CTRL+ALT+DELETE first. Windows Vista sets the current monitor as the primary monitor, and the display appears.

Method 3

If Method 1 and Method 2 do not work, reconnect the second monitor, and then log on. Turn off the computer, disconnect the monitor, and then start the computer. Windows Vista sets the current monitor as the primary monitor, and the display appears.

Method 4

Use Method 4 if the previous methods do not work and a second monitor is not available. Turn off the computer, and then restart the computer. In some cases, you may have to press and hold the power button for five seconds or longer to turn off the computer. Start the computer. Windows Vista sets the current monitor as the primary monitor, and the display appears.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

We do not recommend that you remove devices from the computer while the computer is asleep or is in hibernation. Instead, remove devices when the computer is off or is in a fully running state.

For more information about how to set up multiple monitors, visit the following Microsoft Web site:
http://windowshelp.microsoft.com/Windows/en-US/Help/90b6964d-2673-40e5-9fdf-6edad3916af31033.mspx
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 939805 - Last Review: May 21, 2008 - Revision: 2.1
APPLIES TO
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Starter
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Ultimate
Keywords: 
kbautohotfix kbvistasp1fix kbbug kbfix kbprb kbexpertiseinter kbwinvistapostrtmfix kbqfe kbtshoot kbhotfixserver KB939805

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