Puede recibir un mensaje de error cuando intenta cargar un informe personalizado para Microsoft Dynamics CRM 3.0 o SQL Server Reporting Services o al intentar modificar el informe en Visual Studio Report Designer

Seleccione idioma Seleccione idioma
Id. de artículo: 939867 - Ver los productos a los que se aplica este artículo
La revisión que se describe en este artículo no está disponible para la versión china de Microsoft Dynamics CRM o para la versión japonesa de Microsoft Dynamics CRM.
Expandir todo | Contraer todo

En esta página

Síntomas

Síntoma 1

Considere la situación siguiente en Microsoft Dynamics CRM 3.0. Puede descargar un informe personalizado que contiene el código de Microsoft Dynamics CRM Pre-Filtering. A continuación, intenta cargar el informe en Microsoft Dynamics CRM 3.0. En esta situación, recibe el siguiente mensaje de error:
Error al cargar el informe
Error al intentar agregar el informe a Microsoft CRM. Intente volver a agregar el informe. Si el problema persiste, póngase en contacto con el administrador del sistema.

Es el error de plataforma de CRM
Se produjo excepción de tipo Microsoft.Crm.CrmException. Descripción: Se produjo una excepción no controlada durante la ejecución de la solicitud web actual. Revise la traza de la pila para obtener más información acerca del error y dónde se originó en el código. Detalles de la excepción: Microsoft.Crm.CrmException: excepción de tipo Microsoft.Crm.CrmException producida.

Error de código fuente:
Se ha generado una excepción no controlada durante la ejecución de la solicitud Web actual. La información sobre el origen y la ubicación de la excepción pueden identificarse utilizando la excepción del seguimiento de la pila siguiente.

Pila:
[CrmException: excepción de tipo producida Microsoft.Crm.CrmException.]
Microsoft.Crm.Application.Platform.Report.InternalCreate(String XML) +721
Microsoft.Crm.Application.Platform.Entity.Create() +109
Microsoft.Crm.Application.Forms.AppForm.RaiseDataEvent(FormEventId eventId) +406
Microsoft.Crm.Application.Forms.EndUserForm.Initialize(Entity Entity) +57
Microsoft.Crm.Application.Forms.EndUserForm.Execute(Entity Entity) + 13
Microsoft.Crm.Web.Tools.ReportProperty.ReportPropertyPage.ConfigureForm() +202
Microsoft.Crm.Application.Controls.AppPage.OnPreRender(EventArgs e) + 30
System.Web.UI.Control.PreRenderRecursiveInternal() +62
System.Web.UI.Page.ProcessRequestMain() +1499
Este problema se produce si utiliza Microsoft SQL Server 2005 Reporting Services (SSRS) en Microsoft Dynamics CRM.

Síntoma 2

Considere la situación siguiente en Microsoft Dynamics CRM 3.0. Puede descargar un informe personalizado que contiene el código de Microsoft Dynamics CRM Pre-Filtering. A continuación, intenta cargar el informe directamente en Reporting Services o intenta modificar el informe en Microsoft Visual Studio Report Designer. En esta situación, recibe el siguiente mensaje de error:
Error de deserialización:
El elemento 'Informes 'en espacio de nombres 'http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition' tiene no válido un elemento secundario 'Custom' en espacio de nombres' http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition'. Lista de posibles elementos que se esperaba: ' http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition:Description http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition:Author http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition:AutoRefresh http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition:DataSources http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition:DataSets http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition:Body http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition:ReportParameters http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition:Code http://schemas.microsoft.com/sqlserver/reporting/2005/... Línea de 56, posición 2034.

Causa

Este problema se produce porque el informe descargado era el formato correcto. El informe contiene el código de Microsoft Dynamics CRM Pre-Filtering anexado para el esquema de 2003 de SQL Server Reporting Services o para el esquema de SQL Server 2000 Reporting Services. El esquema de 2003 de SQL Server Reporting Services y el esquema de SQL Server 2000 Reporting Services utilizan la <custom> etiqueta pre-filtering. El esquema de SQL 2005 Reporting Services contiene nuevas definiciones de esquema. Las nuevas definiciones de esquema no debe utilizar el <custom> etiqueta cuando re-upload el informe. Por lo tanto, Microsoft Dynamics CRM no puede validar el código XML en el informe.

Solución

Este problema se corrigió en 3 de informe de actualización de Microsoft Dynamics CRM 3.0.
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
935364El paquete acumulativo de actualizaciones 3 está disponible para Microsoft Dynamics CRM 3.0
Para resolver este problema, modifique el informe para utilizar el formato correcto. Para ello, utilice el método apropiado:
  • Si no se reinició el servidor, es en el entorno original. Utilice el método 1 para resolver este problema.
  • Si se reinició el servidor, no está en el entorno original. Por lo tanto, no puede aplicar el hotfix que se menciona en el método 1. En este caso, si debe cargar el informe en el nuevo entorno, utilice el método 2 para resolver este problema.

    Nota Por ejemplo, exporta el informe como parte de un plan de copia de seguridad. Posteriormente, se ha bloqueado el equipo que ejecuta Reporting Services. Después de volver a crear el equipo que ejecuta Reporting Services, ya no está en el entorno original. Por lo tanto, no puede aplicar la revisión. Debe modificar el informe para utilizar las etiquetas de lenguaje RDL (Report Definition Language) 2005.

Método 1

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.

servidor de Microsoft Dynamics CRM 3.0
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Crmmsg.dll1.2.3297.12316,08829 De marzo de 200720: 18x 86
Microsoft.CRM.Reporting.dll3.0.5300.168670,67216-Oct-200706: 49x 86
Mscrmcustom.dll3.0.5300.1656181,09621-Ago-200712: 47x 86
MSVCR71.dll7.10.3052.4355,03229 De marzo de 200720: 18x 86
Pkgutil.cmdNo aplicable11329 De marzo de 200705: 18No aplicable
Pkgutil.exe1.2.3297.10188,79229 De marzo de 200720: 18x 86
Microsoft.CRM.Reporting.dll3.0.5300.168670,67216-Oct-200706: 50x 86
Microsoft.CRM.Reporting.dll3.0.5300.164,26417-Nov-200504: 38x 86
Crmhotfix.CDFNo aplicable2.27216-Oct-200707: 00No aplicable
Mscrmcustom.dll3.0.5300.1656181,09621-Ago-200712: 47x 86
Updspapi.dll6.1.22.0371,93629 De marzo de 200720: 18x 86
cliente de equipo portátil de Microsoft Dynamics CRM 3.0 para Microsoft Office Update de compatibilidad de Outlook
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Setup.XmlNo aplicable1,18916-Oct-200707: 12No aplicable
V3cclientpatch30.mspNo aplicable51,71216-Oct-200707: 35No aplicable
Microsoft.CRM.Reporting.dll3.0.5300.168670,67216-Oct-200706: 50x 86
cliente para equipo portátil de Microsoft Dynamics CRM 3.0 para Microsoft Office Outlook
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Crmmsg.dll1.2.3297.12316,08829 De marzo de 200720: 18x 86
Microsoft.CRM.Reporting.dll3.0.5300.168670,67216-Oct-200706: 49x 86
Mscrmcustom.dll3.0.5300.1656181,09621-Ago-200712: 47x 86
MSVCR71.dll7.10.3052.4355,03229 De marzo de 200720: 18x 86
Pkgutil.cmdNo aplicable11329 De marzo de 200705: 18No aplicable
Pkgutil.exe1.2.3297.10188,79229 De marzo de 200720: 18x 86
Microsoft.CRM.Reporting.dll3.0.5300.164,28017-Nov-200504: 42x 86
Crmhotfix.CDFNo aplicable1,97816-Oct-200707: 00No aplicable
Mscrmcustom.dll3.0.5300.1656181,09621-Ago-200712: 47x 86
Updspapi.dll6.1.22.0371,93629 De marzo de 200720: 18x 86
Después de aplicar la revisión a Microsoft Dynamics CRM, el informe se dará formato correctamente.

Información de instalación

Instale esta revisión en equipos que ejecutan el servidor de Microsoft Dynamics CRM 3.0 y el cliente de Microsoft Dynamics CRM 3.0 para Microsoft Office Outlook.

Requisitos previos

Debe tener el servidor de Microsoft Dynamics CRM 3.0 y el cliente de Microsoft Dynamics CRM 3.0 para Microsoft Office Outlook instalado para aplicar esta revisión.

Requisito de reinicio

Si se le pide, reinicie el equipo después de aplicar la revisión.

Información acerca de cómo quitar

Para quitar esta revisión de un equipo que ejecuta Windows Server 2003, Windows XP o Microsoft Windows 2000, utilice Agregar o quitar programas en el panel de control.Los administradores del sistema pueden utilizar la herramienta Spuninst.exe para quitar esta revisión de un equipo que ejecuta Windows Server 2003, Windows XP o Microsoft Windows 2000.

La herramienta Spuninst.exe se encuentra en la carpeta %Windir%\$NTUninstallKB939867$\Spuninst.

Método 2

Para resolver este problema, modifique el informe para utilizar las etiquetas de RDL 2005 en lugar de las etiquetas de RDL 2003 en XML. Para ello, siga estos pasos:
  1. Abra el informe con el Bloc de notas o mediante un editor XML de texto enriquecido.
  2. Busque el CRM prefiltrado de sección en el informe. Reemplace el código existente con el código de reemplazo como sigue.

    código existente
    <Custom>
    <MSCRM xmlns="mscrm"><ReportFilter><ReportEntity paramname="P1"><
    fetch version="1.0" output-format="xml-platform" mapping="logical" 
    distinct="false"><entity name="account"><all-attributes /><
    filter type="and"><condition attribute="modifiedon" operator="last-x-days" 
    value="30" /></filter></entity></fetch></ReportEntity></ReportFilter></MSCRM>
    </Custom>  
    
    
    Código sustituto
    <CustomProperties> 
    <CustomProperty> 
    <Name></Name> 
    <Value></Value> 
    <MSCRM xmlns="mscrm"><ReportFilter><ReportEntity paramname="P1"><
    fetch version="1.0" output-format="xml-platform" mapping="logical" 
    distinct="false"><entity name="account"><all-attributes /><
    filter type="and"><condition attribute="modifiedon" operator="last-x-days" 
    value="30" /></filter></entity></fetch></ReportEntity></ReportFilter></MSCRM>
    </CustomProperty> 
    </CustomProperties> 
    
    Notes
    • En este código, se agregan las siguientes etiquetas. SQL Server 2005 Reporting Services requiere estas etiquetas.
      <Name></Name>
      <Value></Value>
      
    • En este código, etiquetas de SQL Server 2005 Reporting Services se modifican las siguientes etiquetas 2003 SQL Server Reporting Services.
      <Custom>
      ...
      </Custom> 

Más información

Para obtener más información acerca de la terminología relativa de la actualización de software, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft
887283Los estándares de nomenclatura de paquete de actualización y revisiones de software de Microsoft Business Solutions CRM

Propiedades

Id. de artículo: 939867 - Última revisión: jueves, 03 de abril de 2008 - Versión: 2.2
La información de este artículo se refiere a:
  • Microsoft CRM 3.0
Palabras clave: 
kbmt kbautohotfix kbmbsreports kbhotfixserver kbqfe kbmbsmigrate KB939867 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 939867

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com