FIX: Error message when you use BizTalk Adapter 2.0 for mySAP Business Suite: "Unable to cast object of 'xxxx'"

Article translations Article translations
Article ID: 939885 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

You use Microsoft BizTalk Adapter 2.0 for mySAP Business Suite in Microsoft BizTalk Server 2004, in Microsoft BizTalk Server 2006 or in Microsoft BizTalk Server 2006 R2. When the BizTalk Server receives the SAP Business Objects by using the SAP Business Application Programming Interface (BAPI), you receive an error message that resembles the following:
Unable to cast object of type 'RFCProxy.f__BMWf__PEP_TYPES_TAB' to type 'Invoke.IXMLSAPStructure'

CAUSE

This problem occurs because of an error in the Microsoft BizTalk Adapter 2.0 for mySAP Business Suite.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: -
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft BizTalk Adapter 2.0 for mySAP Business Suite Service Pack 1 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart the BizTalk host instance service after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Microsoft BizTalk Server 2004
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rfcschemaproxygenerator.dll2.0.1015.0107,89624-Jul-200711:41x86
Saptransmitter.dll2.0.1015.087,40024-Jul-200711:41x86

Microsoft BizTalk Server 2006
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rfcschemaproxygenerator.dll2.0.1015.0m107,89624-Jul-200711:41x86
Saptransmitter.dll2.0.1015.087,40024-Jul-200711:41x86

Microsoft BizTalk Server 2006 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rfcschemaproxygenerator.dll2.0.1311.0107,56012-Feb-200815:56x86
Saptransmitter.dll2.0.1311.087,06412-Feb-200815:56x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Properties

Article ID: 939885 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft BizTalk Adapter 2.0 for mySAP Business Suite
Keywords: 
kbbtsadapters kbbiztalk2004sp2fix kbbiztalk2006presp1fix kbbiztalk2006r2sp1fix kbsurveynew kbqfe kbfix KB939885

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com