Использование средства Process Monitor можно создать файл журнала для приложения в виртуальной среде App-V (SoftGrid)

Переводы статьи Переводы статьи
Код статьи: 939896 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

ВВЕДЕНИЕ

В данной статье описывается использование средства Process Monitor (ProcMon.exe) для создания файла журнала для приложения в виртуальной среде Microsoft App-V (SoftGrid). Файл журнала содержит сведения о файлы и разделы реестра, которые приложение обращается к при запуске процесса монитора.

Дополнительная информация

Как получить Process Monitor

  1. Загрузите монитор процессов. Для этого посетите следующий веб-узел корпорации Майкрософт:
    http://TechNet.Microsoft.com/en-US/Sysinternals/bb896645.aspx
  2. Нажмите кнопку Загрузить монитор процессов (913 K), а затем нажмите кнопку Сохранить.
  3. Сохраните файл в папке по выбору пользователя.
  4. Щелкните правой кнопкой мыши файл, который вы загрузили и нажмите кнопку Чтобы извлечь.
  5. Укажите, где нужно извлечь файл и нажмите кнопку Извлечь.

Как подготовить Process Monitor

  1. В папке, в которую были извлечены файл дважды щелкните файл Procmon.exe.
  2. Нажмите кнопку Согласен Чтобы принять условия лицензионного соглашения.
  3. На Параметры меню, нажмите кнопку Включение дополнительных выходных данных.
  4. На Редактирование меню, нажмите кнопку Автопрокрутка.
  5. На Файл меню, нажмите кнопку Выход Чтобы закрыть Process Monitor.

Как подготовить виртуального приложения App-V (SoftGrid)

  1. Если Устранение неполадок приложения, открытие содержимого общего ресурса приложения и измените OSD-файла приложения для добавления Cmd.exe команда.

    Чтобы сделать это, добавьте следующие строки после <dependency> тег.<b00></b00></dependency>
    <SCRIPT EVENT="LAUNCH" TIMING="PRE" PROTECT="FALSE" WAIT="TRUE" TIMEOUT="0">
    <SCRIPTBODY>cmd.exe</SCRIPTBODY>
    </SCRIPT>
    
  2. На компьютере клиента App-V (SoftGrid) запустите оснастку консоли управления (MMC) «управления App-V (SoftGrid) клиента. Если приложение уже существует в списке Приложения, удалить новый OSD-файла используется при следующем запуске приложения.

Как создать файл журнала приложения

  1. На компьютере клиента App-V (SoftGrid) запуска виртуального приложения App-V (SoftGrid).

    Примечание При этом перед запуском приложения на рабочем столе появится командная строка.
  2. В командной строке введите: procmon.exe, и нажмите клавишу ВВОД, чтобы запустить Process Monitor.
  3. Закройте командную строку.

    Примечание При этом запускается процесс монитора.
  4. Воспроизвести проблему.
  5. На Файл меню, нажмите кнопку Сохранить Чтобы сохранить файл журнала Process Monitor.
  6. В группе События для сохранения, выберите Все события флажок.
  7. В группе Формат, выберите Собственный формат монитора процессов (PML) флажок.
  8. В Путь поле, укажите папку на локальном жестком диске, где требуется сохранить файл.

Свойства

Код статьи: 939896 - Последний отзыв: 19 июня 2011 г. - Revision: 5.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft SoftGrid for Terminal Services
  • Microsoft SoftGrid for Windows Desktops
  • Microsoft Application Virtualization for Terminal Services 4.6
  • Microsoft Application Virtualization 4.6 for Windows Desktops
  • Microsoft Application Virtualization 4.5 for Terminal Services
  • Microsoft Application Virtualization 4.5 for Windows Desktops
Ключевые слова: 
kbexpertiseinter kbhowto kbinfo kbmt KB939896 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:939896

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com