Nachdem Sie einige Zeichen in das Textfeld-HTML-Seite in Internet Explorer 7 angefügt haben, werden die ursprünglichen Zeichen im Textfeld durch neu eingegebenen Zeichen ersetzt.

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256986Beschreibung der Microsoft Windows-Registrierung
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Problembeschreibung

Betrachten Sie das folgende Szenario auf Windows Vista, Windows XP oder einem Windows 2003-Computer mit Windows Internet Explorer 7:
  • In Internet Explorer 7 öffnen Sie eine HTML-Seite, die ein Textfeld enthält.
  • In das Textfeld verwenden Sie die japanische Eingabe-Editor (IME) einige Zeichen eingeben. Darüber hinaus nach der Eingabe der Zeichen Sie nicht zur Bestätigung EINGABETASTE.
  • Sie klicken, eine beliebige Stelle außerhalb des Textfeldes.

    Hinweis: Wenn Sie eine beliebige Stelle außerhalb des Textfeldes klicken, tritt das OnChange -Ereignis.
  • Geben Sie, einige neuen Zeichen angefügt werden soll, in das Textfeld.
  • Klicken Sie Sie an einer beliebigen Stelle außerhalb des Textfeldes erneut.
In diesem Szenario werden die ursprünglichen Zeichen in das Textfeld mit den Zeichen ersetzt, die Sie anfügen.

Ursache

Dieses Problem rührt das OnChange -Ereignis ausgelöst ist bevor IME-Komposition beendet wird. Daher erhält IME falsche Informationen über den Textbereich. Diese Informationen falsch Text Bereich bewirkt, dass IME zum Entfernen der ursprünglichen Zeichen im Textfeld.

Lösung

Informationen zu Service Packs

Installieren Sie das neueste Servicepack für Windows Vista, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
935791Wie Sie das neueste Windows Vista Servicepack erhalten

Hotfix-Informationen

Windows Vista

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.
Voraussetzungen
Es gelten keine Voraussetzungen.
Neustartanforderung
Sie müssen den Computer nach Installation dieses Hotfixes neu starten.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfixes.
Informationen zur Registrierung
Um eines der Updates in diesem Paket verwenden, müssen Sie einige Änderungen an der Registrierung vornehmen. Weitere Informationen finden Sie Abschnitt "Hotfix aktivieren".
Dateiinformationen
Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Windows Vista, X 86-basierte Versionen
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DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Mshtml.dll7.0.6000.206363,583,48810-Jul-200702: 24X 86
Mshtml.tlb7.0.6000.206361,383,42409-Jul-200723: 46Nicht zutreffend

Windows XP

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.
Voraussetzungen
Um diesen Hotfix installieren, müssen Sie Windows XP Service Pack 2 (SP2) installiert sein.
Neustartanforderung
Sie müssen den Computer nach Installation dieses Hotfixes neu starten.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfixes.
Informationen zur Registrierung
Um eines der Updates in diesem Paket verwenden, müssen Sie einige Änderungen an der Registrierung vornehmen. Weitere Informationen finden Sie Abschnitt "Hotfix aktivieren".
Dateiinformationen
Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Windows XP mit SP2, x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Mshtml.dll7.0.6000.206363,583,48812-Jul-200713: 29X 86

Windows Server 2003

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.
Voraussetzungen
Um diesen Hotfix installieren, müssen Sie Windows Server 2003 Service Pack 2 (SP2) installiert sein.
Neustartanforderung
Sie müssen den Computer nach Installation dieses Hotfixes neu starten.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfixes.
Informationen zur Registrierung
Um eines der Updates in diesem Paket verwenden, müssen Sie einige Änderungen an der Registrierung vornehmen. Weitere Informationen finden Sie Abschnitt "Hotfix aktivieren".
Dateiinformationen
Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Windows Server 2003 mit SP2, x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Mshtml.dll7.0.6000.206363,583,48814-Jul-200706: 18X 86

Wie Sie diesen Hotfix aktivieren

Warnung Schwerwiegende Probleme können auftreten, wenn Sie die Registrierung falsch mithilfe des Registrierungs-Editors oder mithilfe einer anderen Methode ändern. Diese Probleme erfordern möglicherweise eine das Betriebssystem neu installieren. Microsoft kann nicht garantieren, dass diese Probleme gelöst werden können. Ändern Sie die Registrierung auf eigene Gefahr.

Je nach Ihrer Situation folgendermaßen Sie vor um diesen Hotfix zu aktivieren.

Windows Vista

  1. Klicken Sie auf Start
    Bild minimierenBild vergrößern
    Start Button
    , geben Sie Regedit im Feld Suche starten und klicken Sie dann Regedit in der Liste Programme auf.
    Bild minimierenBild vergrößern
    Security Shield
    Wenn Sie ein Administratorkennwort oder eine Bestätigung aufgefordert werden, geben Sie das Kennwort oder klicken Sie auf Weiter .
  2. Suchen Sie den folgenden Registrierungsunterschlüssel, und klicken Sie dann auf:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. Klicken Sie im Menü Bearbeiten auf neu zeigen Sie und klicken Sie dann auf Schlüssel .
  4. Geben Sie den folgenden Schlüssel Namen, und drücken Sie anschließend die [EINGABETASTE]:
    FEATURE_IME_KEEP_TEXT_AFTER_ONCHANGE_KB939913
  5. Klicken Sie im Menü Bearbeiten auf neu , und klicken Sie dann auf DWORD-Wert .
  6. Geben Sie "Iexplore.exe" , und drücken Sie anschließend die [EINGABETASTE].
  7. Klicken Sie im Menü Bearbeiten auf Ändern .
  8. Geben Sie 1 ein, und klicken Sie dann auf OK .
  9. Beenden Sie den Registrierungs-Editor.

Windows XP und Windows Server 2003

  1. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie regedit ein und klicken Sie dann auf OK .
  2. Suchen Sie den folgenden Registrierungsunterschlüssel, und klicken Sie dann auf:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. Klicken Sie im Menü Bearbeiten auf neu zeigen Sie und klicken Sie dann auf Schlüssel .
  4. Geben Sie den folgenden Schlüssel Namen, und drücken Sie anschließend die [EINGABETASTE]:
    FEATURE_IME_KEEP_TEXT_AFTER_ONCHANGE_KB939913
  5. Klicken Sie im Menü Bearbeiten auf neu , und klicken Sie dann auf DWORD-Wert .
  6. Geben Sie "Iexplore.exe" , und drücken Sie anschließend die [EINGABETASTE].
  7. Klicken Sie im Menü Bearbeiten auf Ändern .
  8. Geben Sie 1 ein, und klicken Sie dann auf OK .
  9. Beenden Sie den Registrierungs-Editor.

Abhilfe

Um dieses Problem zu umgehen, verwenden Sie das OnBlur -Ereignis anstelle von das OnChange -Ereignis.

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind. Dieses Problem wurde erstmals in Windows Vista Service Pack 1.

Weitere Informationen

Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Eigenschaften

Artikel-ID: 939913 - Geändert am: Donnerstag, 15. Mai 2008 - Version: 2.1
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
  • Windows Internet Explorer 7 in Windows Vista
Keywords: 
kbmt kbautohotfix kbvistasp1fix kbexpertisebeginner kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB939913 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 939913
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