Después de anexar algunos caracteres de un cuadro de texto de página HTML en Internet Explorer 7, los caracteres originales en el cuadro de texto se reemplazan con los caracteres recién escritos

Seleccione idioma Seleccione idioma
Id. de artículo: 939913 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de que copia el registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
Expandir todo | Contraer todo

En esta página

Síntomas

Considere el escenario siguiente en basado en Windows Vista, basado en Windows XP o un equipo basado en Windows Server 2003 que está ejecutando Windows Internet Explorer 7:
  • En Internet Explorer 7, abrir una página HTML que contenga un cuadro de texto.
  • En el cuadro de texto utilice el Editor de método de entrada (IME) japonés para escribir algunos caracteres. Además, después de escribir los caracteres, no presione ENTRAR para confirmación.
  • Haga clic en cualquier lugar fuera del cuadro de texto.

    Nota Al hacer clic en cualquier lugar fuera del cuadro de texto, se produce el evento OnChange .
  • En el cuadro de texto, escriba para anexar algunos caracteres nuevos.
  • Puede clic en cualquier lugar fuera del cuadro de texto de nuevo.
En este escenario, los caracteres originales en el cuadro de texto se reemplazan con los caracteres que se anexan.

Causa

Este problema se produce porque el evento OnChange se desencadena antes de composición del IME se detenga. Por tanto, IME recibe información incorrecta sobre el intervalo de texto. Esta información de intervalo de texto incorrecta hace que el IME quitar los caracteres originales en el cuadro de texto.

Solución

Información de Service Pack

Para resolver este problema, obtenga el service pack más reciente para Windows Vista. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
935791Cómo obtener el service pack más reciente de Windows Vista

Información de revisiones

Windows Vista

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
No se necesita ningún requisito previo.
Requisito de reinicio
Tendrá que reiniciar el equipo después de aplicar este hotfix.
Información acerca de la sustitución de la revisión
Esta revisión no sustituye a ninguna otro publicada previamente.
Información del registro
Para utilizar una de las revisiones de este paquete, deberá realizar algunos cambios en el registro. Para obtener más información, consulte la sección "Cómo habilitar esta revisión".
Información de archivo
La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows Vista, versiones basadas en 86 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Mshtml.dll7.0.6000.206363,583,48810-Jul-200702: 24x 86
Mshtml.tlb7.0.6000.206361,383,42409-Jul-200723: 46No aplicable

Windows XP

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
Para aplicar este hotfix, debe tener instalado Windows XP Service Pack 2 (SP2).
Requisito de reinicio
Tendrá que reiniciar el equipo después de aplicar este hotfix.
Información acerca de la sustitución de la revisión
Esta revisión no sustituye a ninguna otro publicada previamente.
Información del registro
Para utilizar una de las revisiones de este paquete, deberá realizar algunos cambios en el registro. Para obtener más información, consulte la sección "Cómo habilitar esta revisión".
Información de archivo
La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows XP con SP2, x 86
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Mshtml.dll7.0.6000.206363,583,48812-Jul-200713: 29x 86

Windows Server 2003

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
Para aplicar este hotfix, debe tener instalado Windows Server 2003 Service Pack 2 (SP2).
Requisito de reinicio
Tendrá que reiniciar el equipo después de aplicar este hotfix.
Información acerca de la sustitución de la revisión
Esta revisión no sustituye a ninguna otro publicada previamente.
Información del registro
Para utilizar una de las revisiones de este paquete, deberá realizar algunos cambios en el registro. Para obtener más información, consulte la sección "Cómo habilitar esta revisión".
Información de archivo
La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows Server 2003 con SP2, versiones basadas en 86 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Mshtml.dll7.0.6000.206363,583,48814-Jul-200718: 06x 86

Cómo habilitar esta revisión

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Para habilitar esta revisión, siga estos pasos, según su situación.

Windows Vista

  1. Haga clic en Inicio
    Contraer esta imagenAmpliar esta imagen
    Start Button
    , escriba regedit en el cuadro Iniciar búsqueda y, a continuación, haga clic en regedit en la lista de programas .
    Contraer esta imagenAmpliar esta imagen
    Security Shield
    Si se le pide una contraseña de administrador o de confirmación, escriba la contraseña o haga clic en continuar .
  2. Busque la siguiente subclave del registro y a continuación, haga clic en él:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en clave .
  4. Escriba el nombre de clave siguiente y, a continuación, presione ENTRAR:
    FEATURE_IME_KEEP_TEXT_AFTER_ONCHANGE_KB939913
  5. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  6. Escriba iexplore.exe y, a continuación, presione ENTRAR.
  7. En el menú Edición , haga clic en Modificar .
  8. Escriba 1 y, a continuación, haga clic en Aceptar .
  9. Editor de registro de salida.

Windows XP y Windows Server 2003

  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque la siguiente subclave del registro y a continuación, haga clic en él:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en clave .
  4. Escriba el nombre de clave siguiente y, a continuación, presione ENTRAR:
    FEATURE_IME_KEEP_TEXT_AFTER_ONCHANGE_KB939913
  5. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  6. Escriba iexplore.exe y, a continuación, presione ENTRAR.
  7. En el menú Edición , haga clic en Modificar .
  8. Escriba 1 y, a continuación, haga clic en Aceptar .
  9. Editor de registro de salida.

Solución

Para evitar este problema, utilice el evento OnBlur en lugar del evento OnChange .

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:". Este problema se corrigió por primera vez en Windows Vista Service Pack 1.

Más información

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 939913 - Última revisión: jueves, 15 de mayo de 2008 - Versión: 2.1
La información de este artículo se refiere a:
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
  • Windows Internet Explorer 7 in Windows Vista
Palabras clave: 
kbmt kbautohotfix kbvistasp1fix kbexpertisebeginner kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB939913 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 939913

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com