Dopo aver accodato alcuni caratteri in una casella di testo pagina HTML in Internet Explorer 7, i caratteri originali nella casella di testo vengono sostituiti con i caratteri appena digitati.

Traduzione articoli Traduzione articoli
Identificativo articolo: 939913 - Visualizza i prodotti a cui si riferisce l?articolo.
importante Vengono fornite informazioni su come modificare il Registro di sistema. Assicurarsi di backup del Registro di sistema prima di modificarlo. Verificare che come ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
256986Descrizione del Registro di sistema di Microsoft Windows
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Si consideri il seguente scenario su basato su Windows Vista, basato su Windows XP o un computer basato su Windows Server 2003 che esegue Windows Internet Explorer 7:
  • In Internet Explorer 7, Ŕ possibile aprire una pagina HTML che contiene una casella di testo.
  • Nella casella di testo, Ŕ possibile utilizzare IME (Input Method Editor) giapponese per digitare alcuni caratteri. Inoltre, dopo avere digitato i caratteri, non si preme INVIO per conferma.
  • Si fa clic in un punto qualsiasi all'esterno la casella di testo.

    Nota Quando si sceglie un punto qualsiasi all'esterno della casella di testo, si verifica l'evento OnChange .
  • Nella casella di testo digitare per aggiungere alcuni nuovi caratteri.
  • ╚ in un punto qualsiasi all'esterno della casella di testo fare nuovamente clic.
In questo scenario, i caratteri originali nella casella di testo vengono sostituiti con i caratteri che Ŕ aggiungere.

Cause

Questo problema si verifica perchÚ l'evento di OnChange viene generato prima della composizione IME Ŕ stato arrestato. Di conseguenza, IME riceve informazioni errate sull'intervallo di testo. Queste informazioni di intervallo di testo non corretto determina l'IME rimuovere i caratteri originali nella casella di testo.

Risoluzione

Informazioni sul Service pack

Per risolvere il problema, ottenere il service pack pi¨ recente per Windows Vista. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
935791Come ottenere il service pack pi¨ recente per Windows Vista

Informazioni sull'hotfix

Windows Vista

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.
Prerequisiti
Non Ŕ richiesto alcun prerequisito.
NecessitÓ di riavvio
╚ necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).
Informazioni sulla sostituzione della correzione
Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix rilasciati in precedenza.
Informazioni del Registro di sistema
Per utilizzare uno degli aggiornamenti rapidi in questo pacchetto, Ŕ necessario apportare alcune modifiche al Registro di sistema. Per ulteriori informazioni, vedere la sezione "attivare questo aggiornamento rapido (hotfix)".
Informazioni sui file
La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.
Windows Vista, versioni x 86
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Mshtml.dll7.0.6000.206363,583,48810-07-200702: 24x 86
Mshtml.tlb7.0.6000.206361,383,42409-Lug-200723: 46Non applicabile

Windows XP

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.
Prerequisiti
Per applicare questo aggiornamento rapido (hotfix), Ŕ necessario Windows XP Service Pack 2 (SP2).
NecessitÓ di riavvio
╚ necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).
Informazioni sulla sostituzione della correzione
Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix rilasciati in precedenza.
Informazioni del Registro di sistema
Per utilizzare uno degli aggiornamenti rapidi in questo pacchetto, Ŕ necessario apportare alcune modifiche al Registro di sistema. Per ulteriori informazioni, vedere la sezione "attivare questo aggiornamento rapido (hotfix)".
Informazioni sui file
La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.
Windows XP con SP2, versioni 86 e x
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Mshtml.dll7.0.6000.206363,583,48812-07-200713: 29x 86

Windows Server 2003

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.
Prerequisiti
Per applicare questo aggiornamento rapido (hotfix), Ŕ necessario Windows Server 2003 Service Pack 2 (SP2).
NecessitÓ di riavvio
╚ necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).
Informazioni sulla sostituzione della correzione
Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix rilasciati in precedenza.
Informazioni del Registro di sistema
Per utilizzare uno degli aggiornamenti rapidi in questo pacchetto, Ŕ necessario apportare alcune modifiche al Registro di sistema. Per ulteriori informazioni, vedere la sezione "attivare questo aggiornamento rapido (hotfix)".
Informazioni sui file
La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.
Windows Server 2003 con SP2, versioni 86 e x
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Mshtml.dll7.0.6000.206363,583,48814-Lug-200706: 18x 86

Come attivare questo aggiornamento rapido (hotfix)

avviso Pu˛ causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema Ŕ a rischio e pericolo dell'utente.

Per attivare questo hotfix, attenersi alla procedura appropriata per la propria situazione.

Windows Vista

  1. Scegliere il
    Riduci l'immagineEspandi l'immagine
    Start Button
    , digitare regedit nella casella Inizia ricerca , quindi regedit nell'elenco programmi .
    Riduci l'immagineEspandi l'immagine
    Security Shield
    Se viene chiesto di immettere una password di amministratore o di confermare, digitare la password o fare clic su Continua .
  2. Individuare la seguente sottochiave del Registro di sistema e quindi fare clic su:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Scegliere Nuovo dal menu Modifica , quindi chiave .
  4. Digitare il seguente nome chiave e premere INVIO:
    FEATURE_IME_KEEP_TEXT_AFTER_ONCHANGE_KB939913
  5. Scegliere Nuovo dal menu Modifica , quindi Valore DWORD .
  6. Digitare iexplore.exe e quindi premere INVIO.
  7. Nel menu Modifica , fare clic su Modifica .
  8. Digitare 1 e quindi fare clic su OK .
  9. Uscire dall'editor del Registro di sistema.

Windows XP e Windows Server 2003

  1. Fare clic su Start , scegliere Esegui , digitare regedit e quindi fare clic su OK .
  2. Individuare la seguente sottochiave del Registro di sistema e quindi fare clic su:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Scegliere Nuovo dal menu Modifica , quindi chiave .
  4. Digitare il seguente nome chiave e premere INVIO:
    FEATURE_IME_KEEP_TEXT_AFTER_ONCHANGE_KB939913
  5. Scegliere Nuovo dal menu Modifica , quindi Valore DWORD .
  6. Digitare iexplore.exe e quindi premere INVIO.
  7. Nel menu Modifica , fare clic su Modifica .
  8. Digitare 1 e quindi fare clic su OK .
  9. Uscire dall'editor del Registro di sistema.

Workaround

Per risolvere questo problema, utilizzare l'evento OnBlur invece dell'evento OnChange .

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a". Questo problema Ŕ stato innanzitutto corretto in Windows Vista Service Pack 1.

Informazioni

Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

ProprietÓ

Identificativo articolo: 939913 - Ultima modifica: giovedý 15 maggio 2008 - Revisione: 2.1
Le informazioni in questo articolo si applicano a:
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
  • Windows Internet Explorer 7 in Windows Vista
Chiavi:á
kbmt kbautohotfix kbvistasp1fix kbexpertisebeginner kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB939913 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 939913
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com