Pokud adresa webu v zóně zabezpečení používá zástupný znak nespustí web v zóně očekávané zabezpečení v aplikaci Internet Explorer 7

Překlady článku Překlady článku
ID článku: 939940 - Produkty, které se vztahují k tomuto článku.
Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zazálohovat. Seznamte se také s postupem obnovení registru v případě, že nastane problém. Další informace o zálohování, obnovení a úpravě registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Web v zóně očekávané zabezpečení v aplikaci Internet Explorer 7 nespustí, pokud adresa webu v zóně zabezpečení používá zástupný znak. Při přidání webů do zóny zabezpečení v aplikaci Internet Explorer 7 se například vyskytnout následující příznaky:

Příznak 1

Adresa webu, který používá zástupný znak přepíše adresu webu, který používá přesný název. Předpokládejme například, že jste přidali "*. subdomain. domain .com" zóny zabezpečení Místní Intranet adresu webu. Také přidat "server. subdomain. domain .com" zóny zabezpečení Důvěryhodné servery adresu webu. Přístup k následujícím webu očekáváte webu spustit v zóně zabezpečení Důvěryhodné servery:
http:// server. subdomain. domain .com
Panel stav aplikace Internet Explorer však označuje, že na webu spuštěna v zóně zabezpečení Místní Intranet.

Příznak 2

Adresa webu, který používá zástupný znak nevztahuje adresu webu, která je vnořená oboru názvů. Místo toho adresu webu, který používá zástupný znak se vztahuje pouze na web, který je přímo v definovaném oboru názvů.

Předpokládejme například, že jste přidali "*. subdomain. domain .com" zóny zabezpečení Místní Intranet adresu webu. Při přístupu na následujícím webu očekáváte, bude na webu spuštěna v zóně zabezpečení Místní Intranet:
server http:// .dns. subdomain. domain .com
Panel stav aplikace Internet Explorer však označuje, že na webu spuštěna v zóně zabezpečení Internet.

V tomto případě se pouze po jedné následující adresy přidat do zóny zabezpečení Místní Intranet spuštěna v zóně zabezpečení Místní Intranet na webu:
  • *.DNS subdomain. domain .com
  • server.DNS subdomain. domain .com
Poznámka: Na webu spuštěna ve správné zóně aplikace Internet Explorer 6.

Příčina

Tyto příznaky dojít, protože modul Urlmon.dll nesprávně kontroluje webu přístup.

Řešení

Informace o aktualizaci Service Pack pro systém Windows Vista

Problém vyřešíte instalací nejnovější aktualizace Service Pack pro systém Windows Vista. Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
935791Jak získat nejnovější aktualizaci Service Pack pro systém Windows Vista

Informace o opravě hotfix pro aplikaci Internet Explorer 7 v systému Windows Vista

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Neexistují žádné požadavky.

Požadavek na restartování

Po instalaci této opravy hotfix bude třeba restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava Hotfix nenahrazuje žádné další opravy Hotfix.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v položce datum a čas v ovládacím.
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Update.mumNelze použít2,03110. Července 200714: 07Nelze použít
X86_9bea2207ce8599dc91db2690638058dd_31bf3856ad364e35_6.0.6000.20636_none_e5e53045c3e3bfd7.manifestNelze použít72410. Července 200714: 07Nelze použít
X86_microsoft-windows-i..ersandsecurityzones_31bf3856ad364e35_6.0.6000.20636_none_b36c0612f2d3e8e2.manifestNelze použít283,49210. Července 200714: 10Nelze použít
Urlmon.dll7.0.6000.206361,155,07210. Července 200702: 26X86

Informace o opravě hotfix pro aplikaci Internet Explorer 7 v systému Microsoft Windows Server 2003

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Chcete-li použít tuto opravu hotfix, musí mít Windows Server 2003 Service Pack 2 v počítači nainstalována. Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
889100Jak získat nejnovější aktualizaci Service Pack pro systém Windows Server 2003

Požadavek na restartování

Po instalaci této opravy hotfix bude třeba restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava Hotfix nenahrazuje žádné další opravy Hotfix.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v položce datum a čas v ovládacím.
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Urlmon.dll7.0.6000.206361,155,07214. Července 200705: 35X86

Informace o opravě hotfix pro aplikaci Internet Explorer 7 v systému Windows XP

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Chcete-li použít tuto opravu hotfix, musí mít Windows XP Service Pack 2 v počítači nainstalována. Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
322389získání nejnovější aktualizace Service Pack pro systém Windows XP

Požadavek na restartování

Po instalaci této opravy hotfix bude třeba restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava Hotfix nenahrazuje žádné další opravy Hotfix.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v položce datum a čas v ovládacím.
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Urlmon.dll7.0.6000.206361,155,07212. Července 200713: 08X86

Po instalaci informace

Upozornění Při nesprávných úpravách registru pomocí Editoru registru nebo jiným způsobem může dojít k vážným problémům. Tyto problémy mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nezaručuje, že tyto problémy bude možné vyřešit. Úpravy registru provádíte na vlastní nebezpečí.

Po použití této opravy hotfix je třeba upravit registru povolit opravu hotfix. Postupujte takto:
  1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz regedit a klepněte na tlačítko OK.

    Poznámka: V počítači se systémem Windows Vista klepněte na tlačítko Start, do pole Zahájit hledání zadejte regedit a stiskněte klávesu ENTER.
  2. Vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. V nabídce Úpravy přejděte na příkaz Nový a klepněte na příkaz klíč.
  4. Zadejte FEATURE_ZONES_WILDCARD_PRECEDENCE_KB939940 a stiskněte klávesu ENTER.
  5. V nabídce Úpravy přejděte na příkaz Nový a potom klepněte na příkaz Hodnota DWORD.
  6. Typ *, a stiskněte klávesu ENTER.
  7. V nabídce Úpravy klepněte na tlačítko změnit.
  8. V poli Údaj hodnoty zadejte 1 a potom klepněte na tlačítko OK.
  9. Ukončete program Editor registru.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt. Tento problém byl poprvé opraven v aktualizaci Windows Vista Service Pack 1.

Další informace

Další informace o terminologii používané v aktualizacích softwaru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 939940 - Poslední aktualizace: 16. května 2008 - Revize: 3.1
Informace v tomto článku jsou určeny pro produkt:
  • Windows Internet Explorer 7 in Windows Vista
  • Windows Internet Explorer 7 for Windows Server 2003
  • Windows Internet Explorer 7 for Windows XP
Klíčová slova: 
kbmt kbautohotfix kbvistasp1fix kbwinxppresp3fix kbexpertisebeginner kbwinvistapostrtmfix kbexpertiseinter kbwinserv2003postsp2fix kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB939940 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:939940

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com