FIX: You receive an error message when you try to access a report after you configure SQL Server 2005 Reporting Services to run under the SharePoint integrated mode

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Article ID: 939942 - View products that this article applies to.
Bug #: 50001392 (SQL Hotfix)
Microsoft distributes Microsoft SQL Server 2005 fixes as one downloadable file. Because the fixes are cumulative, each new release contains all the hotfixes and all the security fixes that were included with the previous SQL Server 2005 fix release.
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SUMMARY

This article describes the following about this hotfix release:
  • The issues that are fixed by the hotfix package
  • The prerequisites for installing the hotfix package
  • Whether you must restart the computer after you install the hotfix package
  • Whether the hotfix package is replaced by any other hotfix package
  • Whether you must make any registry changes
  • The files that are contained in the hotfix package

SYMPTOMS

Consider the following scenario. To use Microsoft SQL Server 2005 Service Pack 2 together with Microsoft SharePoint Products and Technologies, you configure Microsoft SQL Server 2005 Reporting Services to run under the SharePoint integrated mode. Additionally, you configure Reporting Services to use a trusted account. You configure the SharePoint Products and Technologies Web application to use forms-based authentication. In this scenario, you receive the following error message when you try to access a report:
<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href="/_layouts/login.aspx?ReturnUrl=%2fsites%2ftestsite%2f_vti_bin%2fReportServer%2fReportService2006.asmx">here</a>.</h2>
</body></html>

CAUSE

This problem occurs because the WebRequestHelper.SetRequestHeaders(webRequest) function deletes the forms authentication cookie. However, a later call of the WebRequestHelper.SetRequestHeaders(webRequest) function does not add the forms authentication cookie again. SharePoint Products and Technologies correctly adds the forms authentication cookie when SharePoint Products and Technologies connects to the SOAP proxy. SharePoint Products and Technologies connects to the SOAP proxy when you try to access the report.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

  • SQL Server 2005 Service Pack 2

    For more information about how to obtain SQL Server 2005 Service Pack 2, click the following article number to view the article in the Microsoft Knowledge Base:
    913089 How to obtain the latest service pack for SQL Server 2005

Restart information

You do not have to restart the computer after you apply this hotfix.

Registry information

You do not have to change the registry.

Hotfix file information

This hotfix contains only those files that are required to correct the issues that this article lists. This hotfix may not contain all the files that you must have to fully update a product to the latest build.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Microsoft.reportingservices.sharepoint.ui.webparts.dll9.0.3186.01,029,48811-Aug-200702:19x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the naming schema for SQL Server updates, click the following article number to view the article in the Microsoft Knowledge Base:
822499 New naming schema for Microsoft SQL Server software update packages
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 939942 - Last Review: October 8, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft SQL Server 2005 Reporting Services
Keywords: 
kbautohotfix kbsql2005rs kbexpertiseadvanced kbqfe kbHotfixServer KB939942

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