How to perform a mail merge in Works 9

Article translations Article translations
Article ID: 940002 - View products that this article applies to.
Expand all | Collapse all

On This Page

SUMMARY

This article describes how to perform a mail merge in Microsoft Works 9. Additionally, this article describes how to perform the mail merge by using one of the following sources:
  • A Works Database or Works Spreadsheet file.
  • The Address Book in Microsoft Windows XP or the Windows Contacts book in Windows Vista.
To perform the mail merge, follow these steps:
  1. Create a data source for the mail merge.
  2. Perform the mail merge.
  3. Filter the merged document.
  4. Complete the mail merge.

INTRODUCTION

This article contains a step-by-step guide to perform a mail merge in Works 9.

MORE INFORMATION

Create a data source for the mail merge

A data source is a file that contains fields such as names, addresses, and other information that you may want to merge into another document. You can create a data source for a mail merge by using the Works Spreadsheet or the Works Database. Additionally, Works 9 can merge records from the following sources:
  • The Address Book in Windows XP or Windows Contacts book in Windows Vista.
  • Microsoft Excel (*.xls).
  • Several text formats.
This article describes how to perform a mail merge from the Works Database, from the Works Spreadsheet, from the Address Book, or from the Windows Contacts book.

Create a data source in the Works 9 Spreadsheet

  1. Open a new, blank spreadsheet in the Works Spreadsheet.
  2. Add the records that you want to merge to the Works Spreadsheet. Put field names in the first row.
  3. On the File menu, click Save, and then save the file as a Works Spreadsheet (*.xlr) file.

Create a data source in the Works 9 Database

  1. Open a new, blank database in the Works 9 Database.
  2. Create the correct number and format of fields for your records. Make sure that you give descriptive names to each field.
  3. On the File menu, click Save, and then save the file as a Works Database (*.wdb) file.

Mail merge a Works 9 Database or a Works 9 Spreadsheet file

  1. Start the Works Task Launcher, click Templates, and then click Letters & Labels.
  2. Click Mail-Merge Documents. The Works Word Processor will now start.
  3. In the Open Data Source dialog box, click Merge information from another type of file.
  4. In the Open Data Source dialog box, under Files of Type, select the data source type that you want.
  5. Select the Works 9 Database or the Works 9 Spreadsheet file that you want, and then click Open.
  6. If you are using a Works 9 Spreadsheet, you will be asked whether the first row of the sheet contains field names. Click Yes or No as appropriate. If you are not using a Works 9 Spreadsheet, go to step 7. The Insert Fields dialog box appears.

    Note At this point, the Works 9 Database file or the Works 9 Spreadsheet file is attached to the mail merge main document.
  7. Type the contents of the mail merge main document, as appropriate. For example, type the form letter.
  8. In the main document, put the pointer where you want the merged fields to appear.
  9. In the Insert Fields dialog box, select the field that you want, and then click Insert.
  10. Continue to select the fields that you want to insert, and then click Insert until you have all the fields that you want.

    Note When you insert the fields, type the punctuation marks and the spaces between the fields, and then press ENTER to move to a new line. Format the layout the way that you want it to appear.
  11. After you insert and format the fields, click View Results in the Insert Fields dialog box to view the fields. You can use the View Results dialog box to view each record in the Works 9 Database file that you want.

Mail merge from the address book

Note These steps assume that you have already added records to the Address Book or to the Windows Contacts book.
  1. Start the Works Task Launcher, click Templates, and then click Letters & Labels.
  2. Click Mail-Merge Documents. The Works Word Processor will now start.
  3. In the Open Data Source dialog box, click Merge from the Address Book. The Insert Fields dialog box appears.

    Note At this point, the Works Database file or Works Spreadsheet file is attached to the mail merge main document.
  4. Type the contents of the mail merge main document, as appropriate. For example, type the form letter.
  5. In the main document, put the pointer where you want the merged fields to appear. In the Insert Fields dialog box, select the field that you want, and then click Insert.
  6. Continue to select the fields that you want to insert, and then click Insert until you have all the fields that you want.

    Note When you insert your fields, type the punctuation marks and the spaces between the fields, and then press ENTER to move to a new line. Format the layout the way that you want it to appear.
  7. After you insert and format the fields that you want, click View Results in the Insert Fields dialog box to view the fields. You can use the View Results dialog box to view each record in the Works 9 Database file that you want.

Filter a merged document

If the View Results display does not correctly include the records that you have selected in the Works Spreadsheet file or in the Works Database file, you can filter the records in a merged document. To do this, follow these steps:
  1. In the merged document, on the Tools menu, point to Mail Merge, and then click Filter and Sort.
  2. If it is not already selected, click the Filter tab.
  3. In the Field list, click the field that you want to use to filter.
  4. In the Comparison box, select the comparison phrase that you want.
  5. In the Compare To box, select the text that you want to compare to the contents of the first field.
  6. To add more filters, repeat steps 4 through 6.
  7. Select And to require that names and addresses in the merged document meet all the criteria of the set filters. Select Or to include names and addresses that meet any one of the criteria of the set filters.
  8. Click OK. The View Results dialog box appears. You can review individual copies of the letter in the merged document to see the results of the filter.
  9. Click Close (X) to close the View Results dialog box.
Notes
  • To remove a filter, click Clear Filter on the Filter tab.
  • If you have created a merged document by using Select Names, you cannot filter by using only the names that you have selected.
  • If the data source is a Works Database, you can use the filter only to merge Marked Records. To do this, click Use Marked Records on the Filter tab.
  • You can do some advanced filtering and sorting of the data file before you actually complete the mail merge to receive the results that you want. To obtain help performing advanced filtering and sorting, click Help (?) on the Filter or Sort tabs, and then click the area where you want more help.

Complete the mail merge

  1. On the File menu, click Print.
  2. If you viewed the results in your mail merge and noticed that blank lines were not suppressed, click to select the Don't print lines with empty fields check box.
  3. To output the merged document, use one of the following methods:
    • If you want to directly print the merged document, click OK to complete the mail merge and to print your envelopes to the printer. If you select this option, the rest of the steps in this article may not apply.
    • To save your mail merge to a new document so that you can print it later, click to select the Send merge result to a new document check box, and then click OK.
  4. A new document that contains your merged address list will now open. To save this file for printing later, click Save on the File menu.
  5. In the Save As dialog box, type the name that you want to use for the new document in the File name box. For example, type My Envelopes.
  6. Click Save. This will create a new Works Word Processor document (*.wps) that contains all the pages of the merged documents. For example, all the envelopes that you want to mail. You can print the document later to complete the mailing.

REFERENCES

For more information about how to perform a mail merge in Works 7.0 or in Works 8.0, click the following article number to view the article in the Microsoft Knowledge Base:
832797 How to perform a mail merge in Works 7.0 and in Works 8.0

Properties

Article ID: 940002 - Last Review: July 19, 2007 - Revision: 1.2
APPLIES TO
  • Microsoft Works 9
Keywords: 
kbhowto kbhowtomaster kbdatabase kbmerge kbfield kbexpertiseinter KB940002

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com