Windows Media 서비스는 스트림 오디오 또는 비디오 % 사용하려고 하면 오류 메시지: "지정한 프로토콜이 지원되지 않습니다."

기술 자료 번역 기술 자료 번역
기술 자료: 940029 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

이 페이지에서

현상

문제가 1

오디오 또는 비디오 Microsoft Windows Media 서비스의 스트리밍할 때 Microsoft % 다음과 유사한 오류 메시지가 나타날 수 있습니다.
지정한 프로토콜이 지원되지 않습니다.
참고 하드 디스크 드라이브에 저장된 콘텐츠를 재생할 때 이 문제가 발생하지 않습니다.

문제 2

% 옵션 메뉴 네트워크 탭을 누르면 아무 일도 발생하지 않습니다.

문제의 3

Windows Media Player 네트워크 탭에서 "스트리밍 프록시 설정" 프로토콜 목록이 비어 있습니다.

원인

다음 조건 중 하나가 참일 경우 이 문제가 발생할 수 있습니다.
  • 등록되지 않은 Wmnetmgr.dll 파일입니다.

    참고 Wmnetmgr.dll 파일은 C:\Windows\System32 폴더에 있습니다.
  • Wmsdkns.xml 파일이 손상되었습니다.

    참고 %의 네트워크 네임스페이스 파일입니다.
  • Wmsdkns.xml 파일에 잘못된 사용 권한이 없습니다.

해결 방법

이 문제를 해결하려면 다음 방법 중 하나를 사용하십시오.

방법 1

Administrators 그룹의 계정을 사용하여 Wmnetmgr.dll 파일을 등록하십시오. 명령 프롬프트에서 다음 명령을 실행하십시오.
regsvr32 wmnetmgr.dll

방법 2

% 사용하여 사용자 계정을 Wmsdkns.xml 파일에 대한 수정 권한을 있는지 확인하십시오.

참고 Windows Vista에서 파일 C:\Users\ Userame \AppData\Local\Microsoft\Windows Media\11.0 폴더에 있습니다. Windows XP에서 파일은 C:\Documents 및 Settings\ UserName \Local Settings\Application Data\Microsoft\Windows Media\11.0 폴더에 있습니다.

방법 3

Wmsdkns.xml 파일을 삭제하십시오. 삭제한 후 %Wmsdkns.xml 파일을 다시 만듭니다.

추가 정보

문제를 재현하는 방법

  1. Wmnetmgr.dll 파일을 Administrators 그룹에 속하는 계정을 사용하여 등록을 취소하십시오. 명령 프롬프트에서 다음 명령을 실행하십시오.
    regsvr32 /u wmnetmgr.dll
  2. % 사용하여 사용자 계정을 Wmsdkns.xml 파일에 대한 거부 권한을 있는지 확인하십시오.

속성

기술 자료: 940029 - 마지막 검토: 2008년 2월 18일 월요일 - 수정: 3.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows Media Player 11
키워드:?
kbmt kbtshoot kbprb KB940029 KbMtko
기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com