Pueden producirse diversos problemas en un equipo basado en Windows Server 2003 donde se ejecuta el Servicio de instantáneas de volumen

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Síntomas

En un equipo basado en Microsoft Windows Server 2003 donde se ejecuta el Servicio de instantáneas de volumen (VSS), experimenta uno de los siguientes síntomas:
  • Cuando realiza una operación de copia de seguridad mediante la herramienta NTBackup, se registra el siguiente evento en el registro de aplicaciones:

    Tipo de evento: Error
    Origen del evento: NTBackup
    Identificador de evento: 8019
    Descripción: Finalizar la operación: Se encontraron advertencias o errores. Para obtener más detalles, consulte el informe de copia de seguridad.



    Nota: si examina el archivo de registro de copia de seguridad, se muestra la siguiente información:
    Error devuelto al crear la instantánea de volumen:0xffffffff
  • Si accede a las propiedades de un volumen y hace clic en Instantáneas, recibe uno de los siguientes mensajes de error:
    Error 0x8004230F: Error inesperado en el proveedor de instantáneas al intentar procesar la operación especificada.
    Error 0x80004002: No se admite esa interfaz
  • Se registra uno de los siguientes eventos en el registro de aplicaciones:

    Tipo de evento: Error
    Origen del evento: VSS
    Identificador de evento: 20
    Descripción: Error del Servicio de instantáneas de volumen: un componente crucial requerido por el Servicio de instantáneas de volumen no está registrado. Esto puede ocurrir si se produjo un error durante la instalación de Windows o durante la instalación de un proveedor de instantáneas. Error devuelto desde CoCreateInstance en clase con CLSID {faf53cc4-bd73-4e36-83f1-2b23f46e513e} y el Nombre VSSEvent es [0x80040154].

    Tipo de evento: Error
    Origen del evento: VSS
    Identificador de evento: 20
    Descripción: Error del Servicio de instantáneas de volumen: un componente crucial requerido por el Servicio de instantáneas de volumen no está registrado. Esto puede ocurrir si se produjo un error durante la instalación de Windows o durante la instalación de un proveedor de instantáneas. Error devuelto desde CoCreateInstance en clase con CLSID {faf53cc4-bd73-4e36-83f1-2b23f46e513e} y el Nombre VSSEvent es [0x80004002].

    Tipo de evento: Error
    Origen del evento: VSS
    Identificador de evento: 8193
    Descripción: Error del Servicio de instantáneas de volumen: error inesperado al llamar a la rutina CoCreateInstance. hr = 0x80040154.

    Tipo de evento: Error
    Origen del evento: VSS
    Categoría del evento: ninguna
    Identificador de evento: 8193
    Descripción: Error del Servicio de instantáneas de volumen: error inesperado al llamar a la rutina CoCreateInstance. hr = 0x80004002.

    Tipo de evento: Error
    Origen del evento: VSS
    Identificador de evento: 12302
    Descripción: Error del Servicio de instantáneas de volumen: Se detectó una incoherencia interna en ponerse en contacto con los editores del servicio de instantáneas. Por favor, compruebe que el servicio de sucesos y el servicio de instantáneas de volumen funcionan correctamente.

Causa

Este problema se produce porque los archivos de sistema VSS no están registrados.

Solución

Nota: este artículo no es aplicable a Windows Vista, Windows Server 2008 o sistemas operativos posteriores. A partir de Windows Vista y Windows Server 2008, la instalación de componentes de Windows está basada en manifiestos. Si intenta registrar manualmente componentes específicos, como los que se describen en la sección "Resolución", en los sistemas operativos que se mencionan en esta nota, se podrían producir resultados inesperados que exijan la reinstalación de Windows para resolverlos.

Para que podamos solucionar su problema, vaya a la sección "Solucionarlo en mi lugar". Si prefiere solucionar este problema usted mismo, vaya a la sección "Solucionarlo por mí mismo".

Solucionarlo en mi lugar



Para solucionar el problema de forma automática, haga clic en el vínculo o en el botón Fix it. Haga clic en Ejecutar en el cuadro de diálogo Descarga de archivos y, a continuación, siga los pasos del Asistente de Fix it.


Solucionar este problema
Microsoft Fix it 50633


Notas
  • Este asistente podría estar sólo en inglés. Sin embargo, la solución automática también funciona con otras versiones de idioma de Windows. 
  • Si no está utilizando el equipo que tiene el problema, puede guardar la solución Fix it en una unidad flash o en un CD para posteriormente ejecutarla en el equipo con el problema.

A continuación, vaya a la sección "¿Esta información le ayudó a resolver su problema?".



Solucionarlo por mí mismo



Para resolver el problema, siga estos pasos:
  1. Haga clic en Inicio, Ejecutar, escriba cmd y haga clic en Aceptar.
  2. Escriba los siguientes comandos en el símbolo del sistema: Presione Entrar después de cada comando.
    • cd /d %windir%\system32
    • Net stop vss
    • Net stop swprv
    • regsvr32 ole32.dll
    • regsvr32 oleaut32.dll
    • regsvr32 vss_ps.dll
    • /register Vssvc
    • regsvr32 /i swprv.dll
    • regsvr32 /i eventcls.dll
    • regsvr32 es.dll
    • regsvr32 stdprov.dll
    • regsvr32 vssui.dll
    • regsvr32 msxml.dll
    • regsvr32 msxml3.dll
    • regsvr32 msxml4.dll
    Nota: puede que el último comando no funcione correctamente.
  3. Realice una operación de copia de seguridad para comprobar que se ha resuelto el problema.

¿Esta información le ha ayudado a solucionar el problema?

  • Compruebe si se ha solucionado el problema. Si se ha solucionado, ya ha terminado con esta sección. En caso contrario, puede ponerse en contacto con el soporte técnico.
  • Valoramos sus comentarios. Para realizar algún comentario o informar de cualquier problema con esta solución, deje su comentario en el blog "Solucionarlo en mi lugar" o envíenos un mensaje de correo electrónico.

Más información

Pasos para reproducir este problema

  1. Escriba el siguiente comando en el símbolo del sistema. Presione Entrar después de cada comando.
    regsvr32 /u swprv.dll
  2. Intente realizar una operación de copia de seguridad.

Propiedades

Id. de artículo: 940032 - Última revisión: martes, 20 de diciembre de 2011 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
Palabras clave: 
kbtshoot kbexpertiseinter kbprb kbmsifixme kbfixme KB940032

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