Article ID: 940080 - Last Review: October 30, 2007 - Revision: 1.4

An e-mail message recipient cannot use a Web-based e-mail client to access an attachment when the message is sent by using Exchange 2007

Expand all | Collapse all
An e-mail message that contains an attachment is sent by using Microsoft Exchange Server 2007. When the message recipient uses a Web-based e-mail client to access his or her mailbox, the recipient cannot access the attachment.

Note The recipient can access the attachment if the message is sent by using Microsoft Exchange Server 2003.

CAUSE

This problem occurs because Exchange 2007 incorrectly sets the size parameter of the attachment to 0. This value does not align with RFC 2183. When the size parameter of the attachment is set to 0, some Web-based e-mail clients treat the attachment as nonexistent.

RESOLUTION

To resolve this problem, install Update Rollup 5 for Exchange Server 2007. For more information about Update Rollup 5 for Exchange Server 2007, see the following Exchange Help topic:
Description of Update Rollup 5 for Exchange Server 2007 (http://go.microsoft.com/fwlink/?LinkId=152562)
For more information about how to install the latest Exchange service pack or update rollup, see the following Exchange Help topic:
How to Obtain the Latest Service Pack or Update Rollup for Exchange 2007 (http://go.microsoft.com/fwlink/?LinkId=152570)

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

If you examine the raw data of the message that was sent by Exchange 2007, you may notice the following data:
Content-Type: text/plain; name="test.txt"
Content-Description: test.txt
Content-Disposition: attachment; filename="test.txt"; size=0;
For more information about the size parameter in RFC 2183, visit the following Web site:
http://www.ietf.org/rfc/rfc2183.txt (http://www.ietf.org/rfc/rfc2183.txt)

APPLIES TO
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbexpertiseinter kbqfe KB940080
 

Article Translations

 

Related Support Centers