The performance of a computer that is running Windows Vista may decrease as you run an application that calls the StretchBlt function

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Article ID: 940145 - View products that this article applies to.
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SYMPTOMS

The performance of a computer that is running Windows Vista may gradually decrease as you continually run an application that calls the StretchBlt function. Eventually, Windows Vista may stop responding.

When you use Windows Task Manager to monitor performance, you may notice that physical memory usage increases quickly.

Note When you close the application, Windows Vista releases the memory that the application uses. Therefore, system performance recovers.

CAUSE

When the application calls the StretchBlt function, Windows Vista allocates resources for this call. However, when the call is completed, Windows Vista does not release the resources. However, when the application calls the StretchBlt function again, Windows Vista allocates new resources for the call. Therefore, this problem occurs if the application calls the StretchBlt function many times.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

After you apply this hotfix, you have to restart the computer to load the Win32k.sys file.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Registry information

You do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, 32-bit versions
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File nameFile versionFile sizeDateTimePlatform
Update.mumNot applicable2,00112-Jul-200713:04Not applicable
X86_d57306d1c21b720957822a6842c8e139_31bf3856ad364e35_6.0.6000.20638_none_61b6b1a1afcc1476.manifestNot applicable69412-Jul-200713:04Not applicable
X86_microsoft-windows-win32k_31bf3856ad364e35_6.0.6000.20638_none_b77e6885b68ef9fd.manifestNot applicable6,92812-Jul-200713:06Not applicable
Win32k.sys6.0.6000.206382,028,03212-Jul-200701:34x86
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_5ff04873aa67303c6350ead11ee9b5a3_31bf3856ad364e35_6.0.6000.20638_none_a7b3f1fc4bc28b3d.manifestNot applicable69812-Jul-200713:04Not applicable
Amd64_microsoft-windows-win32k_31bf3856ad364e35_6.0.6000.20638_none_139d04096eec6b33.manifestNot applicable6,94412-Jul-200713:10Not applicable
Update.mumNot applicable2,01312-Jul-200713:04Not applicable
Win32k.sys6.0.6000.206382,749,95212-Jul-200701:50x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

The StretchBlt function copies a bitmap from a source rectangle to a destination rectangle. If the dimensions of the destination rectangle do not fit the dimensions of the source rectangle, the StretchBlt function modifies the bitmap to fit the dimensions of the destination rectangle.

For more information about the StretchBlt function, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/ms532355.aspx
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684Description of the standard terminology that is used to describe Microsoft software updates


For help with system performance issues in Windows Vista, visit the following Microsoft web page:
Problems with overall system speed and system performance

Properties

Article ID: 940145 - Last Review: October 8, 2011 - Revision: 4.0
APPLIES TO
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
Keywords: 
kbautohotfix kbvistasp1fix kbexpertisebeginner kbexpertiseadvanced kbfix kbqfe kbHotfixServer KB940145

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