Artigo: 940267 - Última revisão: quarta-feira, 8 de Agosto de 2007 - Revisão: 1.3

Recebe uma mensagem de erro se tentar instalar um dispositivo USB num computador baseado no Windows Vista foi actualizado do Windows XP

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Se tentar instalar um dispositivo universal serial bus (USB) num computador baseado no Windows Vista foi actualizado a partir do Microsoft Windows XP, poderá receber uma ou ambas as seguintes mensagens de erro:
Mensagem de erro 1
O Windows encontrou um problema ao instalar o software de controlador para o dispositivo.
Mensagem de erro 2
Windows encontrou software de controlador para o dispositivo mas encontrou um erro ao tentar instalá-lo. Dispositivo de disco. Parâmetro está incorrecto.
Nota Um exemplo de um dispositivo USB é uma unidade Flash ou um disco USB.

Além disso, o dispositivo USB não é apresentada como previsto no Gestor de dispositivos. O Gestor de dispositivos pode apresentar uma das seguintes condições:
  • O dispositivo USB é listado na categoria de outros dispositivos como dispositivo desconhecido.
  • É apresentado um ponto de exclamação (!) junto ao nome do dispositivo USB.
Se visualizar as propriedades do dispositivo USB, receberá a seguinte mensagem de erro na área de estado do dispositivo :
Este dispositivo está não está presente, não funcionar correctamente, ou não possui todos os controladores instalados. Tente actualizar os controladores de dispositivo para este dispositivo.

Causa

Este problema pode ocorrer se um ou mais das seguintes condições se verificar:
  • Um controlador de filtro a partir de um terceiro sistema de ficheiros está a interferir com outros controladores de filtro no computador.
  • Instalou o software NETGEAR armazenamento central no computador baseado no Windows XP antes de actualizar para o Windows Vista.
  • O controlador de filtro de classe de armazenamento Zetera (Zetsfd.sys) está instalado no computador.

Resolução

Para resolver este problema, utilize um dos seguintes métodos:
  • Contacte o fabricante do controlador de filtro Zetsfd.sys sobre a disponibilidade de uma actualização para o controlador de filtro Zetsfd.sys.
  • Remova o software NETGEAR armazenamento central no computador. Em seguida, instale a versão compatível com o Windows Vista mais recente do software NETGEAR armazenamento central no computador.

    Para mais informações, visite o seguinte NETGEAR Web site:
    http://kbserver.netgear.com/ (http://kbserver.netgear.com/)

Como contornar

Para contornar este problema, siga estes passos.

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar uma cópia de segurança e restaurar o registo no Windows
  1. Remova o dispositivo USB do computador.
  2. Faça clique sobre
    Reduzir esta imagemExpandir esta imagem
    the Start button
    Iniciar , escreva regedit na caixa Iniciar procura e, em seguida, clique em regedit na lista programas .

    Reduzir esta imagemExpandir esta imagem
    User Access Control permission
    Se lhe for pedido para uma palavra-passe de administrador ou uma confirmação, escreva a palavra-passe ou clique em continuar .
  3. No painel de navegação, localize e, em seguida, clique na seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}
  4. No painel de detalhes, clique com o botão direito do rato em LowerFilters e, em seguida, clique em Eliminar .
  5. Clique em Sim quando lhe for pedido.
  6. Saia do Editor de registo.
  7. Reinicie o computador.
  8. Determine se nenhuma entrada do dispositivo desconhecido é listada no Gestor de dispositivos. Se uma entrada de dispositivo desconhecido estiver listada, elimine a entrada dispositivo desconhecido. Para o fazer, siga estes passos:
    1. Faça clique sobre
      Reduzir esta imagemExpandir esta imagem
      the Start button
      Iniciar , escreva devmgmt.msc na caixa Iniciar procura e, em seguida, clique em devmgmt na lista programas .
    2. Expanda outros dispositivos . Em seguida, elimine as entradas dispositivo desconhecido.
    3. Determine se nenhuma entrada do dispositivo USB está incorrectamente instalada. Se nenhuma entrada do dispositivo USB estiver instalada incorrectamente, elimine a entrada de dispositivo USB.
  9. Liga o dispositivo USB ao computador.
  10. Clique em Iniciar
    Reduzir esta imagemExpandir esta imagem
    the Start button
    escreva Adicionar hardware na caixa Iniciar procura e, em seguida, clique em Adicionar Hardware na lista de programas .
  11. Clique em seguinte . Em seguida, siga as instruções no Assistente para adicionar hardware para configurar o dispositivo USB.
importante Se o controlador de dispositivo USB é eliminado ou está desactivado e se a entrada de registo LowerFilters não é eliminada, receberá uma mensagem de erro Stop semelhante à seguinte quando reiniciar o computador:
PARAR 0X7B INACCESSIBLE_BOOT_DEVICE
Poderá receber este erro fatal uma vez que o controlador de filtro Zetsfd.sys é referenciado no registo.

Mais Informação

O controlador de filtro Zetsfd.sys é utilizado pelo software NETGEAR armazenamento central. Este software é NETGEAR solução de armazenamento de rede.

A solução de armazenamento de rede permite aos clientes cópia de segurança de ficheiros rapidamente. Isto é possível porque a solução de armazenamento de rede funciona como uma unidade de disco local quando está ligado ao router. Por este motivo, os dados podem ser acedidos a partir de qualquer computador da rede sem ter de utilizar um computador dedicado.

Quando o problema mencionado na secção "Sintomas" ocorre, poderá ver as seguintes entradas no ficheiro Setupapi.app.log.
>>>  [DIF_SELECTBESTCOMPATDRV - USBSTOR\DISK&VEN_CORSAIR&PROD_FLASH_VOYAGER&REV_1100\A198000000000174&0]
>>>  Section start 2007/03/07 17:22:52.038
      cmd: rundll32.exe C:\Windows\system32\newdev.dll,pDiDeviceInstallAction \\.\pipe\PNP_Device_Install_Pipe_1.{a1055d68-be1c-418b-8cf5-e72bc2b4f31e} "USBSTOR\Disk&Ven_Corsair&Prod_Flash_Voyager&Rev_1100\A198000000000174&0"
     dvi: CoInstaller 1: Enter 17:22:52.039
     dvi: CoInstaller 1: Exit
     dvi: CoInstaller 2: Enter 17:22:52.040
     dvi: CoInstaller 2: Exit
     dvi: Class installer: Enter 17:22:52.041
     dvi: Class installer: Exit
     dvi: Default installer: Enter 17:22:52.043
     dvi:      {Select Best Driver}
     dvi:           Selected driver installs from section [disk_install] in 'c:\windows\system32\driverstore\filerepository\disk.inf_e0b0b355\disk.inf'.
     dvi:           Class GUID of device remains: {4d36e967-e325-11ce-bfc1-08002be10318}.
     dvi:           Set selected driver complete.
     dvi:           Selected:
     dvi:                Description - [Disk drive]
     dvi:                InfFile     - [c:\windows\system32\driverstore\filerepository\disk.inf_e0b0b355\disk.inf]
     dvi:                Section     - [disk_install]
     dvi:                Signer      - [microsoft windows]
     dvi:                Rank        - [0x0dff0006]
     dvi:      {Select Best Driver - exit(0x00000000)}
     dvi: Default installer: Exit
<<<  Section end 2007/03/07 17:22:52.052
<<<  [Exit status: SUCCESS]

     ndv: Device Install failed for new device...installing NULL driver.

>>>  [DIF_DESTROYPRIVATEDATA - USBSTOR\DISK&VEN_CORSAIR&PROD_FLASH_VOYAGER&REV_1100\A198000000000174&0]
>>>  Section start 2007/03/07 17:22:59.612
      cmd: rundll32.exe C:\Windows\system32\newdev.dll,pDiDeviceInstallAction \\.\pipe\PNP_Device_Install_Pipe_1.{a1055d68-be1c-418b-8cf5-e72bc2b4f31e} "USBSTOR\Disk&Ven_Corsair&Prod_Flash_Voyager&Rev_1100\A198000000000174&0"
     dvi: CoInstaller 1: Enter 17:22:59.613
     dvi: CoInstaller 1: Exit
     dvi: CoInstaller 2: Enter 17:22:59.615
     dvi: CoInstaller 2: Exit
     dvi: Class installer: Enter 17:22:59.616
     dvi: Class installer: Exit
     dvi: Default installer: Enter 17:22:59.617
     dvi: Default installer: Exit
<<<  Section end 2007/03/07 17:22:59.618
<<<  [Exit status: SUCCESS (DI_DO_DEFAULT)]
quando o problema mencionado na secção "Sintomas" ocorre, poderá ver as seguintes entradas no ficheiro Setupapi.dev.log.
Section start 2007/03/07 17:22:54.387
     dvi: {Build Driver List} 17:22:54.388
!    dvi:      Driver list already built
     dvi: {Build Driver List - exit(0x00000000)} 17:22:54.388
     dvi: {DIF_SELECTBESTCOMPATDRV} 17:22:54.389
     dvi:      CoInstaller 1: Enter 17:22:54.389
     dvi:      CoInstaller 1: Exit
     dvi:      CoInstaller 2: Enter 17:22:54.390
     dvi:      CoInstaller 2: Exit
     dvi:      Class installer: Enter 17:22:54.390
     dvi:      Class installer: Exit
     dvi:      Default installer: Enter 17:22:54.391
     dvi:           {Select Best Driver}
     dvi:                Selected driver installs from section [disk_install] in 'c:\windows\system32\driverstore\filerepository\disk.inf_e0b0b355\disk.inf'.
     dvi:                Class GUID of device changed to: {4d36e967-e325-11ce-bfc1-08002be10318}.
     dvi:                {DIF_DESTROYPRIVATEDATA} 17:22:54.393
     dvi:                     CoInstaller 1: Enter 17:22:54.393
     dvi:                     CoInstaller 1: Exit
     dvi:                     CoInstaller 2: Enter 17:22:54.394
     dvi:                     CoInstaller 2: Exit
     dvi:                     Class installer: Enter 17:22:54.395
     dvi:                     Class installer: Exit
     dvi:                     Default installer: Enter 17:22:54.395
     dvi:                     Default installer: Exit
     dvi:                {DIF_DESTROYPRIVATEDATA - exit(0xe000020e)} 17:22:54.396
     dvi:                Set selected driver complete.
     dvi:                Selected:
     dvi:                     Description - [Disk drive]
     dvi:                     InfFile     - [c:\windows\system32\driverstore\filerepository\disk.inf_e0b0b355\disk.inf]
     dvi:                     Section     - [disk_install]
     dvi:                     Signer      - [microsoft windows]
     dvi:                     Rank        - [0x0dff0006]
     dvi:           {Select Best Driver - exit(0x00000000)}
     dvi:      Default installer: Exit
     dvi: {DIF_SELECTBESTCOMPATDRV - exit(0x00000000)} 17:22:54.399
     dvi: {DIF_NEWDEVICEWIZARD_FINISHINSTALL} 17:22:54.570
     dvi:      Using exported function 'DiskClassInstaller' in module 'C:\Windows\system32\StorProp.Dll'.
     dvi:      Class installer == StorProp.Dll,DiskClassInstaller
     dvi:      Using exported function 'StorageCoInstaller' in module 'C:\Windows\system32\SysClass.Dll'.
     dvi:      CoInstaller 1 == SysClass.Dll,StorageCoInstaller
     dvi:      Using exported function 'CriticalDeviceCoInstaller' in module 'C:\Windows\system32\SysClass.Dll'.
     dvi:      CoInstaller 2 == SysClass.Dll,CriticalDeviceCoInstaller
     dvi:      CoInstaller 1: Enter 17:22:54.577
     dvi:      CoInstaller 1: Exit
     dvi:      CoInstaller 2: Enter 17:22:54.579
     dvi:      CoInstaller 2: Exit
     dvi:      Class installer: Enter 17:22:54.580
     dvi:      Class installer: Exit
     dvi:      Default installer: Enter 17:22:54.581
     dvi:      Default installer: Exit
     dvi: {DIF_NEWDEVICEWIZARD_FINISHINSTALL - exit(0xe000020e)} 17:22:54.582
<<<  Section end 2007/03/07 17:22:59.611
<<<  [Exit status: FAILURE(0x00000057)]
Os produtos de outros fabricantes explicado neste artigo são fabricados por empresas independentes da Microsoft. A Microsoft não oferece nenhuma garantia, expressa ou implícita, sobre o desempenho ou fiabilidade destes produtos.

Microsoft fornece informações de contactos outros fabricantes para ajudar a encontrar suporte técnico. Poderá ser alterado estas informações de contacto sem aviso prévio. Microsoft não garante a precisão destas informações de contacto outros fabricantes.

A informação contida neste artigo aplica-se a:
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Starter
Palavras-chave: 
kbmt kbexpertiseadvanced kbtshoot KB940267 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 940267  (http://support.microsoft.com/kb/940267/en-us/ )