ID do artigo: 940267 - Última revisão: quarta-feira, 8 de agosto de 2007 - Revisão: 1.3

Você receber uma mensagem de erro se você tentar instalar um dispositivo USB em um computador baseado no Windows Vista que foi atualizado do Windows XP

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Recolher tudo

Sintomas

Se você tentar instalar um dispositivo de barramento serial universal (USB) em um computador baseado no Windows Vista que foi atualizado do Microsoft Windows XP, poderá receber uma das seguintes mensagens de erro ou ambas:
Mensagem de erro 1
O Windows encontrou um problema ao instalar o software de driver para seu dispositivo.
Mensagem de erro 2
Windows encontrado software de driver para seu dispositivo, mas encontrou um erro ao tentar instalá-lo. Dispositivo de disco. O parâmetro está incorreto.
Observação Um exemplo de um dispositivo USB é um thumb drive ou um disco USB.

Além disso, o dispositivo USB não aparecer como esperado no Gerenciador de dispositivos. O Gerenciador de dispositivos pode exibir uma das seguintes condições:
  • O dispositivo USB está listado na categoria de outros dispositivos como um dispositivo desconhecido.
  • Um ponto de exclamação (!) aparece ao lado do nome de dispositivo USB.
Se você exibir as propriedades do dispositivo USB, você recebe a seguinte mensagem de erro na área de status do dispositivo :
Este dispositivo é não presente, não está funcionando corretamente, ou não tem todos os drivers instalados. Tente atualizar os drivers de dispositivo para este dispositivo.

Causa

Esse problema pode ocorrer se um ou mais das seguintes condições forem verdadeiras:
  • Um driver de filtro de sistema de arquivos de um terceiro estiver interferindo com outros drivers de filtro no computador.
  • Você instalou o NETGEAR armazenamento central software no computador com Windows XP antes de atualizar para o Windows Vista.
  • O driver de filtro de classe de armazenamento Zetera (Zetsfd.sys) está instalado no computador.

Resolução

Para resolver esse problema, use um dos seguintes métodos:
  • Contate o fabricante do driver de filtro Zetsfd.sys sobre a disponibilidade de uma atualização para o driver de filtro Zetsfd.sys.
  • Remova o software NETGEAR armazenamento central no computador. Em seguida, instale a versão compatível com o Windows Vista mais recente do software NETGEAR armazenamento central no computador.

    Para obter mais informações, visite o seguinte site da NETGEAR:
    http://kbserver.netgear.com/ (http://kbserver.netgear.com/)

Como Contornar

Para contornar esse problema, siga estas etapas.

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows
  1. Remova o dispositivo USB do computador.
  2. Clique
    Recolher esta imagemExpandir esta imagem
    the Start button
    Iniciar , digite regedit na caixa Iniciar procura e, em seguida, clique em regedit na lista programas .

    Recolher esta imagemExpandir esta imagem
    User Access Control permission
    Se você for solicitada uma senha de administrador ou uma confirmação, digite a senha ou clique em continuar .
  3. No painel de navegação, localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}
  4. No painel de detalhes, clique com o botão direito do mouse LowerFilters e, em seguida, clique em Excluir .
  5. Clique em Sim quando você for solicitado.
  6. Feche o Editor do Registro.
  7. Reinicie o computador.
  8. Determine se qualquer entrada de dispositivo desconhecido está listada no Gerenciador de dispositivos. Se uma entrada de dispositivo desconhecido é listada, exclua a entrada de dispositivo desconhecido. Para fazer isso, execute as seguintes etapas:
    1. Clique
      Recolher esta imagemExpandir esta imagem
      the Start button
      Iniciar , digite devmgmt.msc na caixa Iniciar procura e, em seguida, clique em devmgmt na lista programas .
    2. Expanda outros dispositivos . Em seguida, exclua as entradas dispositivo desconhecido.
    3. Determine se qualquer entrada do dispositivo USB está instalada incorretamente. Se qualquer entrada do dispositivo USB estiver instalada incorretamente, exclua a entrada de dispositivo USB.
  9. Conecte o dispositivo USB ao computador.
  10. Clique
    Recolher esta imagemExpandir esta imagem
    the Start button
    Iniciar , digite Adicionar hardware na caixa Iniciar procura e, em seguida, clique em Adicionar Hardware na lista programas .
  11. Clique em Avançar . Em seguida, siga as instruções no Assistente para adicionar hardware para configurar o dispositivo USB.
importante Se o driver de dispositivo USB for excluído ou está desativado e se a entrada de registro LowerFilters não for excluída, você pode receber uma mensagem de erro Stop semelhante a seguinte mensagem quando você reinicia o computador:
PARAR 0X7B INACCESSIBLE_BOOT_DEVICE
Você recebe esse erro Stop porque o driver de filtro Zetsfd.sys é referenciado no registro.

Mais Informações

O driver de filtro Zetsfd.sys é usado pelo software NETGEAR armazenamento central. Este software é NETGEAR solução de armazenamento de rede.

A solução de armazenamento de rede permite rapidamente que os clientes faz backup de arquivos. Isso é possível porque a solução de armazenamento de rede funciona da mesma como uma unidade de disco local quando está conectado ao roteador. Portanto, os dados podem ser acessados de qualquer computador da rede sem ter que usar um computador dedicado.

Quando o problema mencionado na seção "Sintomas" ocorre, você pode ver as seguintes entradas no arquivo Setupapi.app.log.
>>>  [DIF_SELECTBESTCOMPATDRV - USBSTOR\DISK&VEN_CORSAIR&PROD_FLASH_VOYAGER&REV_1100\A198000000000174&0]
>>>  Section start 2007/03/07 17:22:52.038
      cmd: rundll32.exe C:\Windows\system32\newdev.dll,pDiDeviceInstallAction \\.\pipe\PNP_Device_Install_Pipe_1.{a1055d68-be1c-418b-8cf5-e72bc2b4f31e} "USBSTOR\Disk&Ven_Corsair&Prod_Flash_Voyager&Rev_1100\A198000000000174&0"
     dvi: CoInstaller 1: Enter 17:22:52.039
     dvi: CoInstaller 1: Exit
     dvi: CoInstaller 2: Enter 17:22:52.040
     dvi: CoInstaller 2: Exit
     dvi: Class installer: Enter 17:22:52.041
     dvi: Class installer: Exit
     dvi: Default installer: Enter 17:22:52.043
     dvi:      {Select Best Driver}
     dvi:           Selected driver installs from section [disk_install] in 'c:\windows\system32\driverstore\filerepository\disk.inf_e0b0b355\disk.inf'.
     dvi:           Class GUID of device remains: {4d36e967-e325-11ce-bfc1-08002be10318}.
     dvi:           Set selected driver complete.
     dvi:           Selected:
     dvi:                Description - [Disk drive]
     dvi:                InfFile     - [c:\windows\system32\driverstore\filerepository\disk.inf_e0b0b355\disk.inf]
     dvi:                Section     - [disk_install]
     dvi:                Signer      - [microsoft windows]
     dvi:                Rank        - [0x0dff0006]
     dvi:      {Select Best Driver - exit(0x00000000)}
     dvi: Default installer: Exit
<<<  Section end 2007/03/07 17:22:52.052
<<<  [Exit status: SUCCESS]

     ndv: Device Install failed for new device...installing NULL driver.

>>>  [DIF_DESTROYPRIVATEDATA - USBSTOR\DISK&VEN_CORSAIR&PROD_FLASH_VOYAGER&REV_1100\A198000000000174&0]
>>>  Section start 2007/03/07 17:22:59.612
      cmd: rundll32.exe C:\Windows\system32\newdev.dll,pDiDeviceInstallAction \\.\pipe\PNP_Device_Install_Pipe_1.{a1055d68-be1c-418b-8cf5-e72bc2b4f31e} "USBSTOR\Disk&Ven_Corsair&Prod_Flash_Voyager&Rev_1100\A198000000000174&0"
     dvi: CoInstaller 1: Enter 17:22:59.613
     dvi: CoInstaller 1: Exit
     dvi: CoInstaller 2: Enter 17:22:59.615
     dvi: CoInstaller 2: Exit
     dvi: Class installer: Enter 17:22:59.616
     dvi: Class installer: Exit
     dvi: Default installer: Enter 17:22:59.617
     dvi: Default installer: Exit
<<<  Section end 2007/03/07 17:22:59.618
<<<  [Exit status: SUCCESS (DI_DO_DEFAULT)]
quando o problema mencionado na seção "Sintomas" ocorre, você pode ver as seguintes entradas no arquivo Setupapi.dev.log.
Section start 2007/03/07 17:22:54.387
     dvi: {Build Driver List} 17:22:54.388
!    dvi:      Driver list already built
     dvi: {Build Driver List - exit(0x00000000)} 17:22:54.388
     dvi: {DIF_SELECTBESTCOMPATDRV} 17:22:54.389
     dvi:      CoInstaller 1: Enter 17:22:54.389
     dvi:      CoInstaller 1: Exit
     dvi:      CoInstaller 2: Enter 17:22:54.390
     dvi:      CoInstaller 2: Exit
     dvi:      Class installer: Enter 17:22:54.390
     dvi:      Class installer: Exit
     dvi:      Default installer: Enter 17:22:54.391
     dvi:           {Select Best Driver}
     dvi:                Selected driver installs from section [disk_install] in 'c:\windows\system32\driverstore\filerepository\disk.inf_e0b0b355\disk.inf'.
     dvi:                Class GUID of device changed to: {4d36e967-e325-11ce-bfc1-08002be10318}.
     dvi:                {DIF_DESTROYPRIVATEDATA} 17:22:54.393
     dvi:                     CoInstaller 1: Enter 17:22:54.393
     dvi:                     CoInstaller 1: Exit
     dvi:                     CoInstaller 2: Enter 17:22:54.394
     dvi:                     CoInstaller 2: Exit
     dvi:                     Class installer: Enter 17:22:54.395
     dvi:                     Class installer: Exit
     dvi:                     Default installer: Enter 17:22:54.395
     dvi:                     Default installer: Exit
     dvi:                {DIF_DESTROYPRIVATEDATA - exit(0xe000020e)} 17:22:54.396
     dvi:                Set selected driver complete.
     dvi:                Selected:
     dvi:                     Description - [Disk drive]
     dvi:                     InfFile     - [c:\windows\system32\driverstore\filerepository\disk.inf_e0b0b355\disk.inf]
     dvi:                     Section     - [disk_install]
     dvi:                     Signer      - [microsoft windows]
     dvi:                     Rank        - [0x0dff0006]
     dvi:           {Select Best Driver - exit(0x00000000)}
     dvi:      Default installer: Exit
     dvi: {DIF_SELECTBESTCOMPATDRV - exit(0x00000000)} 17:22:54.399
     dvi: {DIF_NEWDEVICEWIZARD_FINISHINSTALL} 17:22:54.570
     dvi:      Using exported function 'DiskClassInstaller' in module 'C:\Windows\system32\StorProp.Dll'.
     dvi:      Class installer == StorProp.Dll,DiskClassInstaller
     dvi:      Using exported function 'StorageCoInstaller' in module 'C:\Windows\system32\SysClass.Dll'.
     dvi:      CoInstaller 1 == SysClass.Dll,StorageCoInstaller
     dvi:      Using exported function 'CriticalDeviceCoInstaller' in module 'C:\Windows\system32\SysClass.Dll'.
     dvi:      CoInstaller 2 == SysClass.Dll,CriticalDeviceCoInstaller
     dvi:      CoInstaller 1: Enter 17:22:54.577
     dvi:      CoInstaller 1: Exit
     dvi:      CoInstaller 2: Enter 17:22:54.579
     dvi:      CoInstaller 2: Exit
     dvi:      Class installer: Enter 17:22:54.580
     dvi:      Class installer: Exit
     dvi:      Default installer: Enter 17:22:54.581
     dvi:      Default installer: Exit
     dvi: {DIF_NEWDEVICEWIZARD_FINISHINSTALL - exit(0xe000020e)} 17:22:54.582
<<<  Section end 2007/03/07 17:22:59.611
<<<  [Exit status: FAILURE(0x00000057)]
Os produtos de terceiros mencionados neste artigo são fabricados por empresas que são independentes da Microsoft. Microsoft não oferece garantia, implícita ou não, sobre o desempenho ou confiabilidade desses produtos.

A Microsoft fornece terceiros informações de contatos para ajudá-lo a encontrar suporte técnico. Essa informações de contatos podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações contatos de terceiros.

A informação contida neste artigo aplica-se a:
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Starter
Palavras-chave: 
kbmt kbexpertiseadvanced kbtshoot KB940267 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 940267  (http://support.microsoft.com/kb/940267/en-us/ )