Article ID: 940394 - Last Review: August 4, 2007 - Revision: 2.4

The IRQ for a device appears as a negative number in Device Manager on a computer that is running Windows Vista or Windows Server 2008

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SYMPTOMS

On a computer that is running Windows Vista or Windows Server 2008, you view resources by type in Device Manager. When you expand Interrupt request, the interrupt request (IRQ) for one or more of the devices that are listed may appear as a negative number.

For more information about how to see the devices that are listed under Interrupt request in Device Manager, see the "More Information" section.

CAUSE

This issue can occur if a device uses Message Signaled Interrupts (MSI).

MORE INFORMATION

MSI is supported in the PCI Local Bus Specification, Revision 2.2 standard and in later versions. MSI is the native interrupt mechanism for devices that are connected to a PCI Express bus or to a PCI-X bus. MSI requires Advanced Programmable Interrupt Controllers (APICs).

To see the devices that are listed under Interrupt request in Device Manager, follow these steps:
  1. Start Device Manager.
  2. Click View, and then click Resources by type.
  3. Expand Interrupt request.

REFERENCES

For more information about MSI, visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/bb961238.aspx (http://msdn.microsoft.com/en-us/library/bb961238.aspx)
For more information about APICs, visit the following Microsoft Web site:
http://www.microsoft.com/whdc/archive/apic.mspx (http://www.microsoft.com/whdc/archive/apic.mspx)

APPLIES TO
  • Windows Vista Home Premium
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Home Basic
  • Windows Vista Home Basic 64-bit Edition
  • Windows Server 2008 Standard
  • Windows Server 2008 Enterprise
Keywords: 
kbhardware kbtshoot kbprb KB940394
 

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