The public folder store may take several minutes to mount on an Exchange 2007 server

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Article ID: 940462 - View products that this article applies to.
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SYMPTOMS

You have a Microsoft Exchange Server 2007 environment that has many public folder stores spread out across slow wide area network (WAN) links. In this situation, the public folder store on an Exchange 2007 server may take several minutes to mount.

CAUSE

This problem occurs because Exchange 2007 tries to contact every server that holds public folder stores when a public folder store is mounted. This behavior generates a remote procedure call (RPC) to the servers across the WAN links. The RPC can take several seconds for each server. Therefore, a long delay occurs before the public folder store mounts.

RESOLUTION

To resolve this problem, download and install Update Rollup 2 for Exchange 2007 Service Pack 1. For more information about Update Rollup 2 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic:
Description of Update Rollup 2 for Exchange Server 2007 Service Pack 1
For more information about how to install the latest Exchange service pack or update rollup, see the following Exchange Help topic:
How to Obtain the Latest Service Pack or Update Rollup for Exchange 2007

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 940462 - Last Review: September 10, 2008 - Revision: 3.1
APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 1, when used with:
    • Microsoft Exchange Server 2007 Standard Edition
    • Microsoft Exchange Server 2007 Enterprise Edition
Keywords: 
kbexpertiseinter kbtshoot KB940462

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