ID do artigo: 940508 - Última revisão: quarta-feira, 18 de junho de 2008 - Revisão: 2.1

No Windows Vista, um dispositivo USB pode perder dados se você clicar com o botão direito do mouse no dispositivo no Windows Explorer e clicar em Ejetar

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

No Windows Vista, um dispositivo USB pode perder dados se você clicar com o botão direito do mouse no dispositivo no Windows Explorer e clicar em Ejetar.

Este problema ocorre se o dispositivo usar o sistema de arquivos NTFS.

Observação Este problema não ocorre se o dispositivo USB usar o sistema de arquivos FAT32. Este problema também não ocorre no Windows XP.

Causa

Este problema ocorre porque o Windows Explorer não desmonta o dispositivo USB ao clicar em Ejetar. Por isso, o sistema de arquivos NTFS não pode liberar dados em cache para o dispositivo, e então eles são perdidos.

Resolução

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Vista. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
935791  (http://support.microsoft.com/kb/935791/ ) Como obter o service pack mais recente para o Windows Vista

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Testes adicionais podem ser realizados nesse hotfix. Portanto, se este problema não o prejudicar, é aconselhável aguardar a próxima atualização de software que contenha este hotfix.

Se o hotfix estiver disponível para download, existirá uma seção "Download de hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta seção não é exibida, contate o Serviço de Atendimento ao Cliente da Microsoft para obter o hotfix.

Observação Caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento ao Cliente da Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso seu idioma não seja exibido, um hotfix não está disponível para esse idioma.

Pré-requisitos

Não há pré-requisitos.

Necessidade de reinicialização

É necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui nenhum outro.

Informações do Registro

Não é necessário fazer alterações no Registro..

Informações sobre o arquivo

A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários destes arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário no item Data e hora do Painel de Controle.
Versões de 32 bits do Windows Vista
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataforma
Ntfs.sys6.0.6000.206421.061.04818.07.200703:03x86
Shell32.dll.mui6.0.6000.20642557.05618.07.200702:21Não aplicável
Shell32.dll6.0.6000.2064211.315.20018.07.200702:57x86
Versões de 64 bits do Windows Vista
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataformaRamificação do serviço
Ntfs.sys6.0.6000.206421.487.03218.07.200703:49x64Não aplicável
Shell32.dll.mui6.0.6000.20642549.37618.07.200703:23Não aplicávelNão aplicável
Shell32.dll6.0.6000.2064212.783.61618.07.200703:24x64Não aplicável
Shell32.dll6.0.6000.2064211.315.20018.07.200702:57x86WOW
Shell32.dll.mui6.0.6000.20642557.05618.07.200702:21Não aplicávelNão aplicável

Como Contornar

Para solucionar esse problema, use o item Remover hardware com segurança na área de notificação para remover o dispositivo.

Situação

A Microsoft confirmou que este é um problema que ocorre nos produtos Microsoft que estão listados na seção "Aplica-se a". O problema foi corrigido primeiro no Windows Vista Service Pack 1 (SP1).

Mais Informações

Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para exibir o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
824684  (http://support.microsoft.com/kb/824684/LN/ ) Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft

A informação contida neste artigo aplica-se a:
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
Palavras-chave: 
kbautohotfix kbvistasp1fix kbexpertiseinter kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB940508