╚ disponibile un aggiornamento per risolvere problemi di arresto anomalo di BITS (Background Intelligent Transfer Service - Servizio di trasferimento intelligente in background) su computer con Windows Vista

Traduzione articoli Traduzione articoli
Identificativo articolo: 940520 - Visualizza i prodotti a cui si riferisce l?articolo.
-

Per continuare a ricevere gli aggiornamenti della protezione per Windows, assicurarsi di eseguire Windows Vista con Service Pack 2 (SP2). Per ulteriori informazioni, fare riferimento a questa pagina Web Microsoft: Per alcune versioni di Windows il servizio di supporto non Ŕ pi¨ disponibile

Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Dopo aver scaricato aggiornamenti da Windows Update in un computer con sistema operativo Windows Vista, potrebbero presentarsi i seguenti sintomi:
  • Viene visualizzata una finestra di dialogo segnalante un arresto del processo host per i servizi di Windows.
  • Dopo il riavvio del computer, viene visualizzata una finestra di dialogo di Windows Update con un messaggio analogo al seguente:
    Alcuni aggiornamenti non sono stati installati
    Operazione non riuscita: xx aggiornamenti non eseguiti
    Errori rilevati:
    Codice 800706BA
  • Nel registro eventi Applicazione, viene registrato un evento analogo al seguente:

    Tipo evento: Errore
    Origine evento: Errore dell'applicazione
    Categoria evento: Nessuna
    ID evento: 1000
    Data: data
    Ora: ora
    Computer: nome computer
    Utente: N/D
    Descrizione: Faulting application svchost.exe_BITS, version 6.0.6000.16386, time stamp 0x4549adc4, faulting module qmgr.dll, version 7.0.6000.16386, time stamp 0x4549bd9f, exception code 0xc0000005

Cause

Questo problema si verifica a causa del danneggiamento dei file di stato BITS (Background Intelligent Transfer Service - Servizio trasferimento intelligente in background) e provoca l'arresto del processo host per i servizi di Windows, impedendo di utilizzare BITS per il trasferimento dei file.

Risoluzione

Per risolvere il problema, Ŕ disponibile un aggiornamento. L'utilitÓ di ripristino di BITS aiuta a risolvere i problemi causati dal danneggiamento dei file di stato BITS. Questo tipo di problema provoca l'arresto del processo host per i servizi di Windows. Si tratta di un problema che impedisce di utilizzare BITS per il trasferimento dei file. Per ovviare al danneggiamento dei file, utilizzare l'utilitÓ di ripristino e riattivare la funzionalitÓ di trasferimento file mediante BITS. Dopo aver eseguito l'utilitÓ, potrebbe essere necessario riavviare il computer.

Informazioni sul download

Il seguente file Ŕ disponibile per il download dall'Area download Microsoft:

Windows Vista, edizioni a 32 bit

Download del pacchetto 940520

Windows Vista, edizioni a 64 bit

Download del pacchetto 940520

Per ulteriori informazioni sul download dei file di supporto Microsoft, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
119591 Come ottenere file di supporto Microsoft dai servizi online
Il file Ŕ stato controllato e non contiene virus. Microsoft ha utilizzato il software antivirus pi¨ recente disponibile al momento della data di pubblicazione del file. Il file viene salvato su server con un livello di protezione avanzata per impedire di apportare modifiche non autorizzate.

Il problema pu˛ essere risolto anche manualmente, usando uno dei metodi descritti di seguito.

Metodo 1

  1. Attivare l'opzione per la visualizzazione dei file nascosti. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start
      Riduci l'immagineEspandi l'immagine
      Pulsante
					 Start
      , scegliere Pannello di controllo, fare clic su Opzioni cartella, quindi scegliere la scheda Visualizzazione.
    2. Fare clic su Visualizza cartelle e file nascosti e scegliere OK.
  2. Come amministratore del sistema, individuare la cartella Programdata\Microsoft\Network\Downloader, quindi eliminare tutti i file il cui nome file inizia con Qmgr. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start
      Riduci l'immagineEspandi l'immagine
      Pulsante
					 Start
      , digitare \Programdata\Microsoft\network\downloader nella casella di ricerca, quindi premere INVIO.
    2. Nella finestra dell'utilitÓ di download, selezionare ed eliminare tutti i file il cui nome inizia con Qmgr. Eliminare, ad esempio, i seguenti file:
      • Qmgr0.dat
      • Qmgr1.dat
      Note
      • Se i file non vengono eliminati, riavviare il computer in modalitÓ provvisoria senza supporto di rete. A tal scopo, utilizzare il metodo 2 oppure il metodo 3.
      • Se l'operazione di eliminazione dei file viene eseguita, aprire immediatamente Windows Update e installare gli aggiornamenti pi¨ recenti.

Metodo 2

  1. Riavviare il computer.
  2. Premere F8 durante il riavvio del computer.

    Nota ╚ necessario premere F8 prima che venga visualizzato l'indicatore di stato di Windows Vista.
  3. Quando viene visualizzato il menu Opzioni di avvio avanzate, utilizzare i tasti di direzione per selezionare ModalitÓ provvisoria, quindi premere INVIO.
  4. Attivare l'opzione per la visualizzazione dei file nascosti. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start
      Riduci l'immagineEspandi l'immagine
      Pulsante
					 Start
      , scegliere Pannello di controllo, fare clic su Opzioni cartella, quindi scegliere la scheda Visualizzazione.
    2. Fare clic su Visualizza cartelle e file nascosti e scegliere OK.
  5. Come amministratore del sistema, individuare la cartella Programdata\Microsoft\Network\Downloader, quindi eliminare tutti i file il cui nome file inizia con Qmgr. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start
      Riduci l'immagineEspandi l'immagine
      Pulsante
					 Start
      , digitare Programdata\Microsoft\network\downloader nella casella di ricerca, quindi premere INVIO.
    2. Nella finestra dell'utilitÓ di download, selezionare ed eliminare tutti i file il cui nome inizia con Qmgr. Eliminare, ad esempio, i seguenti file:
      • Qmgr0.dat
      • Qmgr1.dat
  6. Aprire immediatamente Windows Update e installare gli aggiornamenti pi¨ recenti.

Metodo 3

  1. Riavviare il computer in modalitÓ provvisoria senza supporto di rete. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Uscire da tutti i programmi aperti.
    2. Fare clic sul pulsante Start
      Riduci l'immagineEspandi l'immagine
       Pulsante
					 Start
      , digitare Esegui nella casella di ricerca, quindi premere INVIO.
    3. Digitare msconfig, quindi scegliere OK.

      VerrÓ visualizzata l'UtilitÓ Configurazione di sistema.
    4. Fare clic sulla scheda Avvio, selezionare la casella di controllo ModalitÓ provvisoria e la casella di controllo Minima, quindi scegliere OK.
    5. Riavviare il computer quando richiesto.
  2. Attivare l'opzione per la visualizzazione dei file nascosti. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start
      Riduci l'immagineEspandi l'immagine
      Pulsante
					 Start
      , scegliere Pannello di controllo, fare clic su Opzioni cartella, quindi scegliere la scheda Visualizzazione.
    2. Fare clic su Visualizza cartelle e file nascosti e scegliere OK.
  3. Come amministratore del sistema, individuare la cartella "Programdata\Microsoft\Network\Downloader", quindi eliminare tutti i file il cui nome file inizia con Qmgr. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start
      Riduci l'immagineEspandi l'immagine
      Pulsante Start
      , digitare \Programdata\Microsoft\network\downloader nella casella di ricerca, quindi premere INVIO.
    2. Nella finestra dell'utilitÓ di download selezionare ed eliminare tutti i file il cui nome inizia con Qmgr. Eliminare, ad esempio, i seguenti file:
      • Qmgr0.dat
      • Qmgr1.dat
  4. Riavviare il computer in modalitÓ normale. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Uscire da tutti i programmi aperti.
    2. Fare clic sul pulsante Start
      Riduci l'immagineEspandi l'immagine
       Pulsante
					 Start
      , digitare Esegui nella casella di ricerca, quindi premere INVIO.
    3. Digitare msconfig, quindi scegliere OK. VerrÓ visualizzata l'UtilitÓ Configurazione di sistema.
    4. Nella scheda Avvio deselezionare la casella di controllo ModalitÓ provvisoria, quindi scegliere OK per riavviare il computer.
    5. Riavviare il computer quando richiesto.
  5. Aprire immediatamente Windows Update e installare gli aggiornamenti pi¨ recenti.

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Le informazioni in questo articolo si applicano a" del presente articolo.

ProprietÓ

Identificativo articolo: 940520 - Ultima modifica: lunedý 3 ottobre 2011 - Revisione: 5.0
Le informazioni in questo articolo si applicano a:
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
Chiavi:á
kbexpertisebeginner kbtshoot kbprb KB940520
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com