メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

現象

バックアップを復元しようとするか、Microsoft Office Accounting Professional または Microsoft Office Accounting Express で CD-RW または DVD-RW にバックアップを書き込もうとすると、次のいずれかのエラー メッセージが表示されます。

エラー メッセージ 1

ハンドルは同期操作をサポートしません。ハンドルが非同期的に開かれません (つまり、オーバーラップ IO 用に明示的に開かれません)、ファイル画面コンストラクターのパラメーターを変更する必要がある場合があります。

エラー メッセージ 2

デバイス C のメディア ファミリが正しく形成されていません。 SQLサーバーは、このメディア ファミリを処理できません。 RESTORE HEADERONLY が異常終了しています。

エラー メッセージ 3

アクセスが拒否されました。

原因

この問題は、次のいずれかの理由で発生します。

  • エラー メッセージ 1 が表示された場合、コンピューターにMicrosoft SQL Server製品がインストールされていません。 「解決方法」セクションの「方法 1」または「方法 2」を参照してください。

  • エラー メッセージ 2 が表示された場合Microsoft SQL Server 2005 がコンピューターにインストールされます。 ポータブル ストレージ デバイスでバックアップ ファイルを使用してバックアップを復元しようとしている。 ただし、ポータブル ストレージ デバイスは、SQL Server 2005 の復元プロセスと互換性がありません。 「解決方法」セクションの「方法 3」を参照してください。

  • エラー メッセージ 3 が表示された場合は、書き換え可能な CD (CD-RW) または書き換え可能な DVD (DVD-RW) にバックアップを書き込む可能性があります。 メディアに直接書き込まれるバックアップは、書き込みプロセスと競合します。 「解決方法」セクションの「方法 4」を参照してください。

解決策

この問題を解決するには、適切な方法を使用します。

方法 1

Accounting Professional または Accounting Express を手動で削除します。 次に、Accounting Professional または Accounting Express を再インストールします。

Accounting Professional または Accounting Express を手動で削除する方法の詳細については、次の記事番号をクリックして、Microsoft サポート技術情報の記事を表示します。

945462 Accounting Professional 2008 または Accounting Express 2008 および 2005 SQL Server削除する方法

930294 Accounting Professional または Accounting Express を再インストールすると、Microsoft Office Accounting 2007 と Microsoft SQL Server Express

2005 Note Microsoft SQL Server 2005 Express Edition を手動で削除する方法がインストールされます。

方法 2

インストールSQL Server 2005 Express Edition。 アプリを取得する方法についてはSQL Server 2005 Express Edition Microsoft Web サイトを参照してください。

http://msdn.microsoft.com/vstudio/express/sql/download/

方法 3

ポータブル ストレージ デバイスからローカル ハード ディスク ドライブにバックアップ ファイルをコピーします。 次に、このバックアップ ファイルを使用して、コンピューター上のバックアップを復元します。 これを行うには、次の手順に従います。

  1. [スタート ] をクリックし、[マイ コンピューター] をクリックします

  2. Connectを含むポータブル ストレージ デバイスをコンピューターに保存します。

  3. ポータブル ストレージ デバイスの名前をダブルクリックします。

  4. バックアップ ファイルを右クリックし、[コピー] を クリックします

  5. ローカルハード ディスク ドライブをダブルクリックします。 たとえば、ローカル ディスク (C) をダブルクリックします

  6. [編集] メニューの [ 貼り付け] を クリックします

  7. Accounting Professional または Accounting Express を開始します。

  8. ローカル ハード ディスク ドライブにコピーしたバックアップ ファイルを使用して、コンピューター上のバックアップを復元します。

方法 4

会社のバックアップ ファイルを作成し、バックアップ ファイルを CD-RW または DVD-RW にコピーします。 この場合、次の手順を実行します。

  1. Accounting Professional または Accounting Express を開始します。

  2. [ファイル] メニューの [会社を 開く] をクリック して会社を開きます。

  3. [ファイル ] メニュー の [ユーティリティ] をポイントし、[データ ユーティリティ] をクリックします

  4. [基本ツール ] タブで 、[バックアップ] を クリックします

  5. [ 参照]をクリックし、バックアップ ファイルのファイル名を指定し、[保存] を クリックします


    注意 既定では、バックアップ ファイルの場所は次のとおりです。

    C:\Documents and 設定\User_name\My Documents\Small Business Accounting\Backups

  6. バックアップ ファイルを保護するためにパスワードを追加する場合は、パスワードと確認パスワードを入力します。

  7. [OK] をクリックします。

  8. バックアップが完了したら、[Accounting DataUtilities File] ダイアログ ボックスの [Microsoft Office 閉じる] をクリックします。

  9. [Accounting Professional] または [Accounting Express] を閉じます。

  10. [スタート ] をクリックし、[マイ コンピューター] をクリックします

  11. 手順 5 で保存したバックアップ ファイルを見つける。

  12. バックアップ ファイルを右クリックし、[コピー] を クリックします

  13. 書き込み可能な CD または DVD ドライブを探し、ドライブを右クリックし、[貼り付け] を クリックします

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×