Article ID: 940845 - Last Review: March 20, 2009 - Revision: 2.1

Services for Exchange Server 2007 or Exchange Server 2010 cannot start automatically after you install Exchange Server 2007 and Exchange Server 2010 on a global catalog server

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SYMPTOMS

When you install Microsoft Exchange Server 2007 or install Microsoft Exchange server 2010 on a global catalog server, Exchange Server services cannot start. However, you can start other services manually. Servers in this configuration may take a long time to shut down. Additionally, the following events are logged:

Event ID : 1005
Source : MSExchangeSA
Category : General
Type : Error
Description : Unexpected error The Local Security Authority cannot be contacted ID no: 80090304 Microsoft Exchange System Attendant occurred.

Event ID: 2601
Source: MSExchange ADAccess
Category: General
Type: Warning
Description: Process MSEXCHANGEADTOPOLOGY (PID=1624). When initializing a remote procedure call (RPC) to the Microsoft Exchange Active Directory Topology service, Exchange could not retrieve the SID for account <WKGUID=DC1301662F547445B9C490A52961F8FC,CN=Microsoft Exchange,CN=Services,CN=Configuration,...> - Error code=80040934. The Microsoft Exchange Active Directory Topology service will continue starting with limited permissions.

Event ID: 1121
Source: MSExchangeIS
Category: General
Type: Error
Description: Error 0x96e connecting to the Microsoft Active Directory.

Event ID: 5000
Source: MSExchangeIS
Category: General
Type: Error
Description: Unable to initialize the Microsoft Exchange Information Store service. - Error 0x96e.

Note Exchange servers have less dependency on the Microsoft Exchange System Attendant. The Microsoft Exchange Information Store service no longer depends on the Microsoft Exchange System Attendant. Therefore, the symptoms that are described in this article may differ from the symptoms that you may experience in an earlier version of Microsoft Exchange Server.

CAUSE

This problem occurs because the domain controller and other Exchange-Server-dependent services do not start completely when Exchange Server 2007 or Exchange Server 2010 try to start.

WORKAROUND

To work around this problem, use one of the following methods.

Method 1: Manually start the services

Microsoft Windows will inform you that there was a problem with the starting of the Exchange Server services. When this occurs, log on to the server, and then manually start all required Exchange Server services.

Note Monitoring software will also notice that Exchange Server is not running.

On a server that uses a suitable uninterruptible power supply (UPS), restarts are generally overseen by an administrator.

Note Risks that cause additional downtime include unattended restarts or restarts that are generated by other employees.

Method 2: Change the dependencies

An Exchange Server service does not depend on other Exchange Server services that depend directly on the Netlogon service and on the LSASS service.
Collapse this tableExpand this table
Registry pathRegistry subkey (Multi_SZ)Registry value
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSADependOnServiceEventLog, NtLmSsp, RPCSS, LanmanWorkstation, LanmanServer, Netlogon
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeADTopologyDependOnServiceNetlogon
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeISDependOnServiceNetlogon
Note If any Windows service cannot start, Exchange Server will not start. However, the method should reduce the time that is required to shut down the server.

Method 3: Use the BootPause registry key to delay the startup of Exchange Server

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows


Add the following registry key to the affected server to delay the initial attempt to start the Microsoft Exchange System Attendant.
Collapse this tableExpand this table
Registry pathRegistry subkey (DWORD)Registry value (Decimal, the value is in seconds)
HKEY_LOCAL_MACHINE\\System\CurrentControlSet\Services\MSExchangeSA\ParametersBootPause 120
Note A value of 120 is very high. More time may be added to start the server. You can select values that are less than 120. However, selecting the correct value depends on several factors.

You may also have to set the other Exchange Server services to depend on the Microsoft Exchange System Attendant, as in the following example.
Collapse this tableExpand this table
Registry pathRegistry subkey (Multi_SZ)Registry value
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeADTopologyDependOnServiceMSExchangeSA
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS DependOnServiceMSExchangeSA
If you do not set the other Exchange Server services to depend on the Microsoft Exchange System Attendant, other Exchange Server services that access the directory will also fail. Services that depend on the Microsoft Exchange System Attendant could lead to other services being shut down when you restart the Microsoft Exchange System Attendant.

Method 4: Set the Microsoft Exchange System Attendant and other services to restart automatically

Any service can be configured to restart automatically. If a service fails several times, let the service continue to restart on its own.

To configure a service to restart automatically, follow these steps:
  1. Open the properties of the Microsoft Exchange System Attendant in the Services MMC snap-in.
  2. Click Recovery.
  3. In the First failure box, click Restart the Service to restart the service on the first failure.
  4. In the Restart Service After box, type 3 so that the service restarts after three minutes.
  5. Repeat steps 1 to 4 for each Exchange Server service that does not start.

    Note You will not have to modify some newer Exchange Server services. For example, the Microsoft Exchange Transport service contains restart logic.
If you do not have monitoring software or monitoring event logs, the problem on the server will continue to occur. Method 4 will not resolve the problem. Additionally, the errors will still be logged. However, the Exchange Server services will eventually start.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Exchange Server has encountered this problem since Microsoft Exchange 2000 Server. Generally, we do not recommend running Exchange Server on a server that uses the Active Directory directory service. However, we recognize that this configuration is necessary. Additionally, we do support running Exchange Server on a server that uses Active Directory.

This problem persists in Exchange Server 2007 and in Exchange Server 2010. Some newer services such as the Microsoft Exchange Transport service have built-in solutions to this problem. However, fixing this problem for older services is very complex. We hope to minimize this problem in future versions of Exchange Server.

APPLIES TO
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Standard
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Windows Small Business Server 2008 Premium
  • Windows Small Business Server 2008 Standard
Keywords: 
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