グローバル カタログ サーバーで Exchange Server サービスが自動的に開始されない

文書番号: 940845
中小企業のお客様は、中小企業向けサポートサイトで問題解決コンテンツや学習リソースもご利用ください。
すべて展開する | すべて折りたたむ

目次

現象

Microsoft Exchange Server 2007 または?Microsoft Exchange Server 2010 をグローバル カタログ サーバーにインストールした後で Exchange Server サービスが開始されません。他のサービスは手動で開始できます。

この構成に含まれるサーバーはシャットダウンに長い時間がかかることがあります。

さらに、次のイベントがアプリケーション ログに記録され、イベント ビューアーを使用して表示できます。
  • イベント ID: 1005
    ソース: MSExchangeSA
    分類: 全般
    種類: エラー
    説明: 予期しないエラー ローカル セキュリティ機関にアクセスできません ID 番号: 80090304 Microsoft Exchange System Attendant が発生しました。
  • イベント ID: 2601
    ソース: MSExchange ADAccess
    分類: 全般
    種類: 警告
    説明: プロセス MSEXCHANGEADTOPOLOGY (PID=1624)。Microsoft Exchange Active Directory Topology サービスに対するリモート プロシージャ コール (RPC) を初期化中にアカウント <WKGUID=DC1301662F547445B9C490A52961F8FC,CN=Microsoft Exchange,CN=Services,CN=Configuration,...> の SID を取得できませんでした。- エラー コード: 80040934。Microsoft Exchange AD Topology サービスは制限されたアクセス許可を使用して開始処理を続行します。
  • イベント ID: 1121
    ソース: MSExchangeIS
    分類: General
    種類: エラー
    説明: Microsoft Active Directory サービスへ接続中にエラー 0x96e が発生しました。
  • イベント ID: 5000
    ソース: MSExchangeIS
    分類: General
    種類: エラー
    説明: Microsoft Exchange Information Store サービスを初期化できません。- エラー 0x96e。
元に戻す画像を拡大する
注:
?最近のバージョンの Microsoft Exchange Server は Microsoft Exchange System Attendant への依存度が減少しています。たとえば、Microsoft Exchange Information Store サービスは Microsoft Exchange System Attendant に依存しなくなりました。このため、この資料に記載されている現象は、以前のバージョンの Microsoft Exchange Server で発生することがある現象とは異なる場合があります。

原因

この問題は、Exchange 2007 または Exchange Server 2010 の起動時にドメイン コントローラー サービスおよび Exchange Server に依存するその他のサービスが完全には開始されない場合に発生することがあります。Exchange Server を開始する前に他のいくつかのサービスが開始されている必要があります。

回避策

この問題を回避するには、次のいずれかの方法を使用します。

方法 1: サービスを手動で開始する

Microsoft Windows で、Exchange Server サービスの開始に関する問題が発生したことが通知されます。この状況が発生した場合は、サーバーにログオンし、必要な Exchange Server サービスをすべて手動で開始します。サービスを開始するには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。「services.msc」と入力し、[OK] をクリックします。
  2. [結果] ウィンドウで、Microsoft Exchange サービスを見つけます。
  3. サービスを右クリックし、[再起動] をクリックします。
    元に戻す画像を拡大する


注: 監視ソフトウェアでも、Exchange Server が実行されていないことが通知されます。

適切な無停電電源装置 (UPS) を使用しているサーバーでは、通常、再起動は管理者によって監視されます。

注: ダウンタイム増加の原因となるリスクには、無人での再起動や他の従業員による再起動などがあります。

方法 2:依存関係を変更する

Exchange Server サービスが、Netlogon サービスおよび LSASS サービスに直接依存する他の Exchange Server サービスに依存していない場合はこの方法を使用します。この方法を使用して、Exchange Server サービスの依存関係を変更し、依存しているサービスが開始されるまで Exchange Server サービスが開始されないようにすることができます。
依存関係を自動的に変更するには、「Fix it で解決する」セクションに進んでください。自分で依存関係を変更するには、「自分で解決する」セクションに進んでください。

Fix it で解決する

依存関係を自動的に変更するには、[この問題を解決する] リンクをクリックします。次に、[ファイルのダウンロード] ダイアログ ボックスで [実行] をクリックし、このウィザードの手順に従います。


この問題を解決する
Microsoft Fix it 50328


注: この Fix it ソリューションはすべての言語で機能しますが、一部の言語では、ウィザードのテキストが英語になる場合があります。

注: 問題のあるコンピューターとは別のコンピューターを操作している場合、Fix it ソリューションをフラッシュ ドライブまたは CD に保存することで、問題のあるコンピューターで実行することができます。

自分で解決する

重要 このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。レジストリを変更する際には十分に注意してください。万一に備えて、編集の前にレジストリをバックアップしてください。問題が発生した場合でも、レジストリを復元できます。バックアップおよび復元方法の詳細を参照するには、以下のサポート技術情報番号をクリックしてください。322756 Windows でレジストリをバックアップおよび復元する方法
  • Windows Server 2003 ベースのサーバーで依存関係を自分で変更するには、以下の表の値を使用して依存関係の適切な値を決定します。
    元に戻す全体を表示する
    レジストリ パスレジストリ サブキー (Multi_SZ)レジストリの値
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA
    DependOnServiceEventLog、NtLmSsp、RPCSS、LanmanWorkstation、LanmanServer、Netlogon
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeADTopology
    DependOnServiceNetlogon
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS
    DependOnServiceNetlogon
  • Windows Server 2008 ベースのサーバーで依存関係を自分で変更するには、以下の表の値を使用して依存関係の適切な値を決定します。
    元に戻す全体を表示する
    レジストリ パスレジストリ サブキー (Multi_SZ)レジストリの値
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA
    DependOnServiceEventLog、RPCSS、LanmanWorkstation、LanmanServer、Netlogon
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeADTopology
    DependOnServiceNetlogon
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS
    DependOnServiceNetlogon
元に戻す画像を拡大する
注:
?Windows のいずれかのサービスが開始できない場合、Exchange Server は起動しません。この方法では、Windows サービスを開始できない問題は解決されません。ただし、この方法によって、サーバーのシャットダウンに必要な時間が短縮されます。

方法 3: BootPause レジストリ キーを使用して Exchange Server の起動を遅延させる

重要 このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。しかし、レジストリを誤って変更すると、深刻な問題が発生する可能性があります。したがって、これらの手順は慎重に実行する必要があります。万一に備えて、変更前のレジストリをバックアップしてください。これにより、問題が発生した場合にレジストリを復元することが可能になります。レジストリのバックアップ方法と復元方法の詳細については、以下のサポート技術情報番号をクリックしてください。
322756 Windows でレジストリをバックアップおよび復元する方法


問題が発生しているサーバーに以下のレジストリ キーを追加して、Microsoft Exchange System Attendant の起動を遅延させます。 ?
元に戻す全体を表示する
レジストリ パスレジストリ サブキー (DWORD)レジストリの値 (10 進数で表された秒)
HKEY_LOCAL_MACHINE\\System\CurrentControlSet\Services\MSExchangeSA\Parameters
BootPause 120
注: 120 という値は非常に大きな値なので、サーバーの起動に要する時間が長くなることがあります。このため、120 未満の値を選択できます。ただし、適切な値はいくつかの要因によって左右されます。

その他の Exchange Server サービスを Microsoft Exchange System Attendant に依存するように設定することが必要な場合もあります。その他の Exchange Server サービスを Microsoft Exchange System Attendant に依存するように設定しない場合、ディレクトリにアクセスするその他の Exchange Server サービスも失敗します。Microsoft Exchange System Attendant を再起動すると、Microsoft Exchange System Attendant に依存するサービスによって、その他のサービスがシャットダウンされます。以下の例は、その他の Exchange Server サービスを Microsoft Exchange System Attendant に依存するように設定する方法を示しています。 ?
元に戻す全体を表示する
レジストリ パスレジストリ サブキー (Multi_SZ)レジストリの値
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeADTopology
DependOnServiceMSExchangeSA
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS
DependOnServiceMSExchangeSA

方法 4: Microsoft Exchange System Attendant とその他のサービスを自動的に再起動するように設定する

すべてのサービスは自動的に再起動するように構成できます。サービスが数回失敗する場合に、継続して自動的に再起動するように構成します。

監視ソフトウェアがなかったり、イベント ログの監視を行わなかったりする場合、サーバーの問題は引き続き発生します。方法 4 では問題は解決されません。また、エラーも引き続き記録されます。ただし、最終的には Exchange Server サービスは起動します。

Exchange Server サービスが自動的に再開されるようにするには、「Fix it で解決する」セクションに進んでください。自分で Exchange サービスを構成するには、「自分で解決する」セクションに進んでください。

Fix it で解決する

この問題を自動的に解決するには、[この問題を解決する] リンクをクリックします。次に、[ファイルのダウンロード] ダイアログ ボックスで [実行] をクリックし、このウィザードの手順に従います。


この問題を解決する
Microsoft Fix it 50329


注: この Fix it ソリューションはすべての言語で機能しますが、一部の言語では、ウィザードのテキストが英語になる場合があります。

注: 問題のあるコンピューターとは別のコンピューターを操作している場合、Fix it ソリューションをフラッシュ ドライブまたは CD に保存することで、問題のあるコンピューターで実行することができます。

自分で解決する


自動的に再起動するようにサービスを構成するには、以下の手順を実行します。
  1. サービス MMC スナップインで Microsoft Exchange System Attendant のプロパティを開きます。
  2. [回復] をクリックします。
  3. [最初のエラー] ボックスで、[サービスを再起動する] をクリックして、最初のエラーが発生したときにサービスを再起動するようにします。
  4. [サービスの再起動] ボックスに「3」と入力して、サービスが 3 分後に再起動するようにします。
  5. 起動しない Exchange Server サービスそれぞれに対して、手順 1. 〜 4. を繰り返します。

    注: 一部の新しい Exchange Server サービスは変更する必要はありません。たとえば、Microsoft Exchange Transport サービスには再起動ロジックが組み込まれています。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

この資料の手順を実行した後でも、以下の例に示すように、その他の Exchange Server サービスを Microsoft Exchange System Attendant に依存するように設定することが必要な場合もあります。
元に戻す全体を表示する
レジストリ パスレジストリ サブキー (Multi_SZ)レジストリの値
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeADTopology
DependOnServiceMSExchangeSA
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS
DependOnServiceMSExchangeSA
注意
  • その他の Exchange Server サービスを Microsoft Exchange System Attendant に依存するように設定しない場合、ディレクトリにアクセスするその他の Exchange Server サービスも失敗します。
  • Microsoft Exchange System Attendant を再起動すると、Microsoft Exchange System Attendant に依存するサービスによって、その他のサービスがシャットダウンされます。
Microsoft Exchange 2000 Server 以降の Exchange Server でこの問題が発生しています。通常、Active Directory ディレクトリ サービスを使用するサーバーで Exchange Server を実行することはお勧めしません。しかし、マイクロソフトは、この構成が必要であることを認識しています。また、マイクロソフトでは Active Directory を使用するサーバー上での Exchange Server の実行をサポートしています。

この問題は、Exchange 2007 および Exchange Server 2010 でも引き続き発生します。Microsoft Exchange Transport サービスなどの一部の新しいサービスには、この問題の解決方法が組み込まれています。しかし、古いサービスに対するこの問題の解決方法は非常に複雑です。Exchange Server の今後のバージョンでは、この問題の影響を最小限に抑える予定です。
318431 [XADM] イベント ID 1005 のエラー メッセージが記録され、システム アテンダントが応答を停止する


プロパティ

文書番号: 940845 - 最終更新日: 2012年4月30日 - リビジョン: 5.0
キーワード:?
kbtshoot kbprb kbexpertiseinter kbfixme kbmsifixme kbsmbportal KB940845
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック