Article ID: 940970 - Last Review: August 24, 2007 - Revision: 2.1

Error message when you try to perform a file backup operation or a system restore operation in Windows Vista: "Incompatible version of the serializing package. (0x80070724)"

System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.
Expand all | Collapse all

SYMPTOMS

When you try to perform a file backup operation or a system restore operation in Windows Vista, you may receive the following error message:
Incompatible version of the serializing package. (0x80070724)

CAUSE

This problem occurs because the backup metadata that is stored in the volume snapshot files is corrupted.

RESOLUTION

To resolve this problem, remove the volume snapshot files that contain the corrupted metadata. To do this, follow these steps:
  1. Click Start
    Collapse this imageExpand this image
    the Start button
    , click All Programs, click Accessories, and then right-click Command Prompt.
  2. Click Run as administrator.

    Collapse this imageExpand this image
    User Access Control permission
    If you are prompted for an administrator password, type the password. If you are prompted for confirmation, click Continue.
  3. At the command prompt, type the following command, and then press ENTER:
    vssadmin list shadowstorage /for=c:
  4. Note the Maximum Shadow Copy Storage Space value.
  5. At the command prompt, type the following command, and then press ENTER:
    vssadmin resize shadowstorage /for=c: /on=c: /maxsize=300mb
  6. Close the Command Prompt window.
  7. Change the system settings. To do this, install a Windows component, or uninstall a Windows component. For example, install the FreeCell program to change the system settings, or uninstall the FreeCell program to change the system settings. To install the FreeCell program, or to uninstall the FreeCell program, follow these steps:
    1. Click Start
      Collapse this imageExpand this image
      the Start button
      , type Programs and Features in the Start Search box, and then click Programs and Features in the Programs list.
    2. Under Tasks, click Turn Windows features on or off.

      Collapse this imageExpand this image
      User Access Control permission
      If you are prompted for an administrator password, type the password. If you are prompted for confirmation, click Continue.
    3. Expand Games. If the FreeCell check box is selected, click to clear the FreeCell check box, and then click OK. If the FreeCell check box is not selected, click to select the FreeCell check box, and then click OK.
  8. Reset the Maximum Shadow Copy Storage Space value to the default value. To do this, follow these steps:
    1. Click Start
      Collapse this imageExpand this image
      the Start button
      , click All Programs, click Accessories, and then right-click Command Prompt.
    2. Click Run as administrator.

      Collapse this imageExpand this image
      User Access Control permission
      If you are prompted for an administrator password, type the password. If you are prompted for confirmation, click Continue.
    3. At the command prompt, type the following command, and then press ENTER:
      vssadmin resize shadowstorage /for=c: /on=c: /maxsize=original value
      Note The original value placeholder represents the value that you noted in step 4.
    4. Close the Command Prompt window.
Note If you uninstalled the FreeCell program, and you want to install the program again, repeat step 7. In step 7c, click to select the FreeCell check box.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Business 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
Keywords: 
kbexpertiseinter kbtshoot kbprb KB940970