Trace events in the log output are randomly lost on a Windows Vista-based computer that has the ETW trace log enabled

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Article ID: 941061 - View products that this article applies to.
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SYMPTOMS

On a Windows Vista-based computer, you enable the Event Tracing for Windows (ETW) trace log. After you extract a large .psf file, and then you exam the log output, some trace events are randomly lost. If you extract the .psf file again, you may find that a random subset of the trace events is lost.

CAUSE

This issue occurs because the event tracing session runs out of free buffers. When high event rates are processed at the same time, the disk subsystem becomes overloaded. In this case, the event tracing session randomly discards some events instead of holding the process until more buffers become available.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfixes and security updates that are included in SP2 for Windows Vista Service and for Windows Server 2008

For more information about the hotfixes and the security updates that are included in SP2 for Windows Vista and for Windows Server 2008, visit the following Microsoft TechNet Web site: -
http://technet.microsoft.com/en-us/library/dd335033.aspx
Note: Currently, the list of hotfixes and security updates is available only in English.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Package_1_for_kb941061~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,80102-Aug-200711:37Not Applicable
Package_2_for_kb941061~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable2,01402-Aug-200711:37Not Applicable
Update.mumNot Applicable1,91302-Aug-200711:37Not Applicable
X86_4e74f5526c1e8151458ab4d55540581e_31bf3856ad364e35_6.0.6000.20652_none_17ba44abe810e1ae.manifestNot Applicable70802-Aug-200711:37Not Applicable
X86_7229a4a707694806d7e6f8d34d6e79b1_31bf3856ad364e35_6.0.6000.20652_none_9439ab49e9b1990e.manifestNot Applicable71002-Aug-200711:37Not Applicable
X86_microsoft-windows-deltacompressionengine_31bf3856ad364e35_6.0.6000.20652_none_3e9bb54fa1dce9d7.manifestNot Applicable4,73102-Aug-200711:37Not Applicable
X86_microsoft-windows-deltapackageexpander_31bf3856ad364e35_6.0.6000.20652_none_684de3665125ab60.manifestNot Applicable5,09702-Aug-200711:37Not Applicable
Msdelta.dll6.0.6000.20652305,15202-Aug-200702:16x86
Mspatcha.dll6.0.6000.2065235,32802-Aug-200702:16x86
Dpx.dll6.0.6000.20652257,02402-Aug-200702:15x86
Windows Vista, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_23d32b696400bb2b2f9a703ac0d9c6d2_31bf3856ad364e35_6.0.6000.20652_none_185d36aa94f6368d.manifestNot Applicable71202-Aug-200711:37Not Applicable
Amd64_4e74f5526c1e8151458ab4d55540581e_31bf3856ad364e35_6.0.6000.20652_none_73d8e02fa06e52e4.manifestNot Applicable71002-Aug-200711:37Not Applicable
Amd64_62b33e64a8a85ba150e80859052ceac8_31bf3856ad364e35_6.0.6000.20652_none_e690524ca3570901.manifestNot Applicable1,06802-Aug-200711:37Not Applicable
Amd64_microsoft-windows-deltacompressionengine_31bf3856ad364e35_6.0.6000.20652_none_9aba50d35a3a5b0d.manifestNot Applicable4,73902-Aug-200711:41Not Applicable
Amd64_microsoft-windows-deltapackageexpander_31bf3856ad364e35_6.0.6000.20652_none_c46c7eea09831c96.manifestNot Applicable5,11102-Aug-200711:41Not Applicable
Package_1_for_kb941061~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable2,72502-Aug-200711:37Not Applicable
Package_2_for_kb941061~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable2,02602-Aug-200711:37Not Applicable
Update.mumNot Applicable1,92502-Aug-200711:37Not Applicable
Msdelta.dll6.0.6000.20652459,77602-Aug-200703:19x64
Mspatcha.dll6.0.6000.2065246,59202-Aug-200703:20x64
Dpx.dll6.0.6000.20652396,80002-Aug-200703:18x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

For more information about Event Tracing, visit the following Microsoft Web sites:
http://msdn2.microsoft.com/en-us/library/aa363668.aspx
http://msdn2.microsoft.com/en-us/library/aa363802(VS.85).aspx
For more information about how to use Event Tracing, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/aa364158(VS.85).aspx
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 941061 - Last Review: May 15, 2008 - Revision: 2.2
APPLIES TO
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
Keywords: 
kbautohotfix kbvistasp1fix kbexpertiseadvanced kbfix kbqfe kbhotfixserver KB941061

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