El servicio de servidor virtual puede dejar de responder cuando se está iniciando el servicio si uno o más de las máquinas virtuales están configurados para iniciar automáticamente cuando se inicia el servicio de servidor virtual

Seleccione idioma Seleccione idioma
Id. de artículo: 941125 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

En un equipo que tiene Microsoft Virtual Server 2005 R2 Service Pack 1 (SP1) instalado, el servicio de servidor virtual puede dejar de responder cuando se está iniciando el servicio. Este problema puede producirse si uno o más de las máquinas virtuales están configurados para iniciarse automáticamente cuando se inicia el servicio de servidor virtual.

Para recuperarse de este problema, tiene que descartar el estado guardado de las máquinas virtuales. O, tenga que eliminar manualmente los archivos de estado guardado (.vsv) correspondiente de las máquinas virtuales.

Además, recibirá el siguiente mensaje de error cuando intenta iniciar un equipo virtual:
Tiempo de espera CGI
La aplicación CGI especificada excedió el tiempo permitido para procesamiento. El servidor ha eliminado el proceso.
Además, la interfaz de servicios de Internet Information Server (IIS) (vswebapp.exe) y servicios VMRC ya no funcionan y perder el acceso a la vista de administración.

Causa

Una máquina virtual puede detener inesperadamente si el equipo virtual está configurado para iniciarse automáticamente cuando se inicia el servicio de servidor virtual. Porque la máquina virtual se detiene inesperadamente, el equipo virtual no libera todos los recursos. A continuación, el servicio de servidor virtual deja de responder.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe estar ejecutando Virtual Server 2005 R2 con Service Pack 1.

Requisito de reinicio

No es necesario reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Virtual Server 2005 R2 con Service Pack 1, x 86
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Microsoft.VirtualServer.Interop.dll1.1.603.0206,22416 De agosto de 200704: 45x 86
Microsoft.vmrcclientcontrol.Interop.dll1.1.603.037,30416 De agosto de 200704: 45x 86
Vhdmount.dll1.1.603.0150,92016 De agosto de 200704: 45x 86
Vhdmount.exe1.1.603.02,861,47216 De agosto de 200704: 45x 86
Virtualserverlogmessages.dll1.1.603.099,72016 De agosto de 200704: 45x 86
Virtualserverlogmessages.dll1.1.603.099,72016 De agosto de 200704: 45x 86
Vmh.exe1.1.603.0166,80816 De agosto de 200704: 45x 86
Vmm.sys1.1.603.0232,81616 De agosto de 200704: 45x 86
Vmrc.exe1.1.603.0448,40016 De agosto de 200704: 45x 86
Vssrvc.exe1.1.604.03,373,43216 De agosto de 200704: 45x 86
Vswebapp.exe1.1.603.01,788,80816 De agosto de 200704: 45x 86
Vswriter.dll1.1.603.0327,56016 De agosto de 200704: 45x 86
Virtual Server 2005 R2 con Service Pack 1, versiones basadas en 64 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Microsoft.VirtualServer.Interop.dll1.1.603.0206,22416 De agosto de 200704: 46x 86
Microsoft.vmrcclientcontrol.Interop.dll1.1.603.037,30416 De agosto de 200704: 46x 86
Vhdmount.dll1.1.603.0150,92016 De agosto de 200704: 46x 86
Vhdmount.exe1.1.603.02,861,47216 De agosto de 200704: 46x 86
Virtualserverlogmessages.dll1.1.603.099,72016 De agosto de 200704: 46x 86
Virtualserverlogmessages.dll1.1.603.099,72016 De agosto de 200704: 46x 86
Vmh.exe1.1.603.0269,20816 De agosto de 200704: 46x 64
Vmm.sys1.1.603.0297,84016 De agosto de 200704: 46x 64
Vmrc.exe1.1.603.0649,10416 De agosto de 200704: 46x 64
Vssrvc.exe1.1.604.06,018,93616 De agosto de 200704: 46x 64
Vswebapp.exe1.1.603.03,238,79216 De agosto de 200704: 46x 64
Vswriter.dll1.1.603.0505,22416 De agosto de 200704: 46x 64

Solución

Para evitar este problema, utilice uno de los métodos siguientes.

Método 1

Desactivar las máquinas virtuales, o apagar los sistemas operativos de invitado, en lugar de guardar los estados.

Método 2

  1. Crear una máquina virtual que tiene un disco duro virtual en blanco.
  2. Conectar el equipo virtual a la red virtual misma como las máquinas virtuales problemáticas.
  3. Activar la máquina virtual que creó en el paso 1.
  4. Restaurar las máquinas virtuales problemáticas.

Método 3

Si las máquinas virtuales no tienen que la funcionalidad de la red, quite todos los los adaptadores de red virtual que están conectados a las máquinas virtuales.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información acerca de la terminología relativa de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 941125 - Última revisión: jueves, 25 de octubre de 2007 - Versión: 1.2
La información de este artículo se refiere a:
  • Microsoft Virtual Server 2005 R2 Enterprise Edition
  • Microsoft Virtual Server 2005 R2 Standard Edition
Palabras clave: 
kbmt kbautohotfix kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB941125 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 941125

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com