O serviço de servidor virtual pode deixar de responder quando o serviço é iniciado se uma ou mais das máquinas virtuais configurados para iniciar automaticamente quando o serviço de servidor virtual é iniciado

Traduções de Artigos Traduções de Artigos
Artigo: 941125 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Num computador com o Microsoft Virtual Server 2005 R2 Service Pack 1 (SP1) instalado, o serviço de servidor virtual pode deixar de responder quando o serviço é iniciado. Este problema poderá ocorrer se um ou mais máquinas virtuais configurados para iniciar automaticamente quando o serviço de servidor virtual é iniciado.

Para recuperar deste problema, terá de eliminar o estado guardado de máquinas virtuais. Ou, tem de eliminar manualmente os ficheiros de estado guardado (.vsv) correspondente de máquinas virtuais.

Além disso, recebe a seguinte mensagem de erro quando tenta iniciar uma máquina virtual:
Tempo de espera de CGI
A aplicação CGI especificada excedeu o tempo permitido para processamento. O servidor eliminou o processo.
Além disso, a interface de serviços de informação Internet (IIS) (Vswebapp.exe) e serviços VMRC deixar de funcionar e perder o acesso à vista de administração.

Causa

Uma máquina virtual poderá parar inesperadamente se a máquina virtual estiver configurada para iniciar automaticamente quando o serviço de servidor virtual é iniciado. Uma vez que a máquina virtual parar inesperadamente, a máquina virtual não liberta todos os recursos. Em seguida, o serviço de servidor virtual deixa de responder.

Resolução

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Para aplicar esta correcção, tem de ter Virtual Server 2005 R2 com o Service Pack 1.

Requisito de reinício

Não é necessário reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item data e hora no painel de controlo.
Virtual Server 2005 R2 com o Service Pack 1, x 86 versões
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Microsoft.VIRTUALSERVER.Interop.dll1.1.603.0206,22416 De Agosto de 200704: 45x 86
Microsoft.vmrcclientcontrol.Interop.dll1.1.603.037,30416 De Agosto de 200704: 45x 86
Vhdmount.dll1.1.603.0150,92016 De Agosto de 200704: 45x 86
Vhdmount.exe1.1.603.02,861,47216 De Agosto de 200704: 45x 86
Virtualserverlogmessages.dll1.1.603.099,72016 De Agosto de 200704: 45x 86
Virtualserverlogmessages.dll1.1.603.099,72016 De Agosto de 200704: 45x 86
Vmh.exe1.1.603.0166,80816 De Agosto de 200704: 45x 86
Vmm.sys1.1.603.0232,81616 De Agosto de 200704: 45x 86
Vmrc.exe1.1.603.0448,40016 De Agosto de 200704: 45x 86
Vssrvc.exe1.1.604.03,373,43216 De Agosto de 200704: 45x 86
Vswebapp.exe1.1.603.01,788,80816 De Agosto de 200704: 45x 86
Vswriter.dll1.1.603.0327,56016 De Agosto de 200704: 45x 86
Virtual Server 2005 R2 com o Service Pack 1, versões baseadas em 64 x
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Microsoft.VIRTUALSERVER.Interop.dll1.1.603.0206,22416 De Agosto de 200704: 46x 86
Microsoft.vmrcclientcontrol.Interop.dll1.1.603.037,30416 De Agosto de 200704: 46x 86
Vhdmount.dll1.1.603.0150,92016 De Agosto de 200704: 46x 86
Vhdmount.exe1.1.603.02,861,47216 De Agosto de 200704: 46x 86
Virtualserverlogmessages.dll1.1.603.099,72016 De Agosto de 200704: 46x 86
Virtualserverlogmessages.dll1.1.603.099,72016 De Agosto de 200704: 46x 86
Vmh.exe1.1.603.0269,20816 De Agosto de 200704: 46x 64
Vmm.sys1.1.603.0297,84016 De Agosto de 200704: 46x 64
Vmrc.exe1.1.603.0649,10416 De Agosto de 200704: 46x 64
Vssrvc.exe1.1.604.06,018,93616 De Agosto de 200704: 46x 64
Vswebapp.exe1.1.603.03,238,79216 De Agosto de 200704: 46x 64
Vswriter.dll1.1.603.0505,22416 De Agosto de 200704: 46x 64

Como contornar

Para contornar este problema, utilize um dos seguintes métodos.

Método 1

Desactivar máquinas virtuais ou encerrar os sistemas operativos convidados, em vez de guardar os estados.

Método 2

  1. Crie uma máquina virtual que tenha um disco rígido virtual em branco.
  2. Liga a máquina virtual à rede virtual mesma como as máquinas virtuais problemáticas.
  3. Active a máquina virtual que criou no passo 1.
  4. Restaure as máquinas virtuais problemáticas.

Método 3

Se máquinas virtuais não têm de ter a funcionalidade de rede, remova todas as placas de rede virtual estão ligadas a máquinas virtuais.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Para obter mais informações sobre a terminologia de actualização de software, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

Propriedades

Artigo: 941125 - Última revisão: 25 de outubro de 2007 - Revisão: 1.2
A informação contida neste artigo aplica-se a:
  • Microsoft Virtual Server 2005 R2 Enterprise Edition
  • Microsoft Virtual Server 2005 R2 Standard Edition
Palavras-chave: 
kbmt kbautohotfix kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB941125 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 941125

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com