Служба Virtual Server перестает отвечать на запросы при служба запускается, если один или несколько виртуальных машин, настроены на автоматический запуск при запуске виртуального сервера службы

Переводы статьи Переводы статьи
Код статьи: 941125 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

На компьютере с Microsoft Virtual Server 2005 R2 пакетом обновления 1 (SP1) установлен служба Virtual Server перестает отвечать на запросы при запуске службы. Это может происходить, если один или несколько виртуальных машин настроены на автоматический запуск при запуске службы виртуального сервера.

Для восстановления эту проблему, необходимо отказаться от сохраненного состояния виртуальных машин. Или необходимо вручную удалить соответствующие файлы сохранения состояния (.vsv) виртуальных машин.

Кроме того появляется следующее сообщение об ошибке при попытке запуска виртуальной машины:
Тайм-аута CGI
Указанное приложение CGI превышено допустимое время для обработки. Сервер удалил процесса.
Кроме того интерфейс служб информации Интернет (IIS) (Vswebapp.exe) и службы VMRC перестанут работать и потерять доступ в режиме администратора.

Причина

Виртуальная машина может неожиданно завершить работу, если виртуальная машина настроена на автоматический запуск при запуске службы виртуального сервера. Поскольку неустранимой ошибки виртуальной машины, виртуальная машина не освободить все ресурсы. Затем служба Virtual Server перестает отвечать на запросы.

Решение

Сведения об исправлении

Корпорация Майкрософт выпустила исправление. Однако данное исправление предназначено для устранения проблемы, описанной в этой статье. Данное исправление только в тех системах, в которых обнаружена эта специфическая неполадка. Это исправление может проходить дополнительное тестирование. Таким образом Если вы не представляет особой эта проблема, рекомендуется отложить ее решение до выхода ближайшего пакета обновления, содержащего это исправление.

Если исправление доступно для загрузки, имеется раздел «Исправление доступно для загрузки» в верхней части статьи базы знаний. Если этот раздел не отображается, обратитесь в службу и службу поддержки для получения исправления.

Примечание Если возникают другие проблемы или необходимо устранить неполадки, возможно создать отдельный запрос на обслуживание. Затраты на обычные службы поддержки будут применяться дополнительные вопросы и проблемы, не связанные с данным исправлением, оплачиваются. Для получения полного списка телефонов службы поддержки и обслуживания клиентов корпорации Майкрософт или создать отдельный запрос посетите следующий веб-узел корпорации Майкрософт:
http://support.Microsoft.com/contactus/?ws=Support
Примечание В форме «Исправление доступно для загрузки» отображаются языки, для которых доступно исправление. Если язык не отображается, значит исправления недоступна для данного языка.

Необходимые условия

Для установки исправления необходимо наличие Virtual Server 2005 R2 с пакетом обновления 1.

Необходимость перезагрузки

После установки данного исправления перезагружать компьютер не нужно.

Сведения о замене исправлений

Это исправление не заменяет других исправлений.

Сведения о файлах

Английская версия исправления содержит атрибуты файла (или более поздними), приведенные в следующей таблице. Дата и время для файлов указаны в формате общего скоординированного времени (UTC). При просмотре сведений о файле, он преобразуется в локальное время. Чтобы узнать разницу между временем по Гринвичу и местным временем, следует использовать Часовой пояс на вкладке Дата и время элемент панели управления.
Virtual Server 2005 R2 с пакетом обновления 1, 32 разрядных выпусков
Свернуть эту таблицуРазвернуть эту таблицу
Имя файлаВерсия файлаРазмер файлаДатаВремяПлатформа
Microsoft.virtualserver.Interop.dll1.1.603.0206,22416 Августа 2007 г.04: 45X86
Microsoft.vmrcclientcontrol.Interop.dll1.1.603.037,30416 Августа 2007 г.04: 45X86
Vhdmount.dll1.1.603.0150,92016 Августа 2007 г.04: 45X86
Vhdmount.exe1.1.603.02,861,47216 Августа 2007 г.04: 45X86
Virtualserverlogmessages.dll1.1.603.099,72016 Августа 2007 г.04: 45X86
Virtualserverlogmessages.dll1.1.603.099,72016 Августа 2007 г.04: 45X86
Vmh.exe1.1.603.0166,80816 Августа 2007 г.04: 45X86
VMM.sys1.1.603.0232,81616 Августа 2007 г.04: 45X86
VMRC.exe1.1.603.0448,40016 Августа 2007 г.04: 45X86
Программа VPCrvc.exe1.1.604.03,373,43216 Августа 2007 г.04: 45X86
Vswebapp.exe1.1.603.01,788,80816 Августа 2007 г.04: 45X86
Vswriter.dll1.1.603.0327,56016 Августа 2007 г.04: 45X86
Virtual Server 2005 R2 с пакетом обновления 1, 64-разрядных версий
Свернуть эту таблицуРазвернуть эту таблицу
Имя файлаВерсия файлаРазмер файлаДатаВремяПлатформа
Microsoft.virtualserver.Interop.dll1.1.603.0206,22416 Августа 2007 г.04: 46X86
Microsoft.vmrcclientcontrol.Interop.dll1.1.603.037,30416 Августа 2007 г.04: 46X86
Vhdmount.dll1.1.603.0150,92016 Августа 2007 г.04: 46X86
Vhdmount.exe1.1.603.02,861,47216 Августа 2007 г.04: 46X86
Virtualserverlogmessages.dll1.1.603.099,72016 Августа 2007 г.04: 46X86
Virtualserverlogmessages.dll1.1.603.099,72016 Августа 2007 г.04: 46X86
Vmh.exe1.1.603.0269,20816 Августа 2007 г.04: 46X64
VMM.sys1.1.603.0297,84016 Августа 2007 г.04: 46X64
VMRC.exe1.1.603.0649,10416 Августа 2007 г.04: 46X64
Программа VPCrvc.exe1.1.604.06,018,93616 Августа 2007 г.04: 46X64
Vswebapp.exe1.1.603.03,238,79216 Августа 2007 г.04: 46X64
Vswriter.dll1.1.603.0505,22416 Августа 2007 г.04: 46X64

Временное решение

Чтобы обойти эту проблему, используйте один из следующих способов.

Способ 1

Отключение виртуальных машин или завершить работу гостевых операционных систем, вместо сохранения состояния.

Способ 2

  1. Создайте виртуальную машину, имеет пустой виртуальный жесткий диск.
  2. Виртуальная машина подключения к виртуальной сети, проблемных виртуальных машин.
  3. Включите виртуальную машину, созданную на этапе 1.
  4. Восстановление проблемных виртуальных машин.

Способ 3

Если виртуальные машины не требуется функционирование сети, удалите все виртуальные сетевые адаптеры, подключенные к виртуальным машинам.

Статус

Корпорация Майкрософт подтверждает, что это проблема в продуктах Microsoft, перечисленных в разделе «Относится к».

Дополнительная информация

Для получения дополнительных сведений о терминологии, обновление программного обеспечения щелкните следующий номер статьи базы знаний Майкрософт:
824684Стандартные термины, используемые при описании обновлений программных продуктов Майкрософт
Примечание. Это ЭКСПРЕСС-ПУБЛИКАЦИЯ, подготовленная непосредственно службой технической поддержки Майкрософт . Сведения, содержащиеся в данном документе, предоставлены в качестве отклика на возникшие проблемы. Из-за срочности в материалах могут быть опечатки, и в любое время и без уведомления в них могут быть внесены изменения. Чтобы получить дополнительные сведения, см. Условия использования.

Свойства

Код статьи: 941125 - Последний отзыв: 19 июня 2011 г. - Revision: 4.0
Информация в данной статье относится к следующим продуктам.
Ключевые слова: 
kbautohotfix kbexpertiseinter kbbug kbfix kbHotfixServer kbqfe kbmt KB941125 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:941125

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com