Error message when you try to upgrade from a SharePoint 2.0 product to a SharePoint 3.0 product on a computer that is running Windows Server 2008: "Execution of a full-text operation failed"

Article translations Article translations
Article ID: 941142 - View products that this article applies to.
Beta Information
This article discusses a beta release of a Microsoft product. The information in this article is provided as-is and is subject to change without notice.

No formal product support is available from Microsoft for this beta product. For information about how to obtain support for a beta release, see the documentation that is included with the beta product files, or check the Web location where you downloaded the release.
Expand all | Collapse all

SYMPTOMS

You are using a computer that is running Windows Server 2008 and Microsoft SQL Server 2005. When you upgrade from Microsoft Windows SharePoint Services 2.0 or from Microsoft Office SharePoint Portal Server 2003 to Microsoft Windows SharePoint Services 3.0 or to Microsoft Office SharePoint Server 2007, the upgrade process fails. Additionally, the following error is logged in the Upgrade.log file:
Microsoft.SharePoint.Upgrade.SPContentDatabaseSequence failed

Execution of a full-text operation failed. The dependency service does not exist or has been marked for deletion.

CAUSE

This problem occurs because the NTLM Security Support Provider (NTLMSSP) service does not exist in Windows Server 2008. However, the full-text search service in Windows SharePoint Services 3.0 and in SharePoint Server 2007 depends on the NTLMSSP service.

WORKAROUND

To work around this problem, install Microsoft SQL Server 2005 Service Pack (SP2). For more information about SQL Server 2005 SP2, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/sqlserver/bb426877.aspx

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 941142 - Last Review: October 19, 2007 - Revision: 2.0
APPLIES TO
  • Microsoft Windows SharePoint Services 3.0, when used with:
    • Microsoft SQL Server 2005 Enterprise Edition
    • Microsoft SQL Server 2005 Standard Edition
  • Microsoft Office SharePoint Server 2007, when used with:
    • Microsoft SQL Server 2005 Enterprise Edition
    • Microsoft SQL Server 2005 Standard Edition
Keywords: 
kbtshoot kbprb kbexpertiseinter KB941142

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com