Lorsque vous pointez sur « tous les programmes » sur un ordinateur Windows XP, la liste des programmes n'apparaît pas, ou si la liste des programmes est vide

Traductions disponibles Traductions disponibles
Numéro d'article: 941248 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Sur un ordinateur Windows XP, les problèmes de liées de menu Démarrer suivants peuvent se produire :
  • Lorsque vous cliquez sur Démarrer et vous pointez sur Tous les programmes , la liste des programmes ne s'affiche pas.
  • Si vous utilisez le menu Démarrer classique, une liste vide s'affiche lorsque vous cliquez sur Démarrer , puis pointez sur programmes .
Ces problèmes se produisent si vous ne pouvez pas accéder le dossier du menu Démarrer. Par exemple, ces problèmes se produire si vous n'avez pas l'autorisation d'accès au dossier menu Démarrer.

Cause

Ces problèmes se produire si la valeur de l'entrée de Registre courants menu Démarrer est inaccessible ou si la valeur n'est pas valide. Dans ce cas, Windows XP ne peut pas initialiser le shell de programme.

Résolution

Un correctif est disponible pour résoudre ce problème. Après avoir appliqué ce correctif, Windows XP ignore toutes les erreurs lorsque Windows XP initialise le shell de programme. Si la valeur de l'entrée de Registre courants menu Démarrer est inaccessible ou si la valeur n'est pas valide, Windows XP charge un menu de démarrage par défaut.

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Conditions préalables

Vous devez avoir installé Windows XP Service Pack 2 (SP2).

Demande de redémarrage

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations sur le remplacement de correctif

Ce correctif ne remplace aucun autre correctif.

Informations de Registre

Pour utiliser ce correctif, vous ne devez pas apporter de modifications au Registre.

Informations de fichier

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.
Windows XP avec Service Pack 2, versions 32 bits
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-formeDemande de Service Pack
Shell32.dll.6.0.2900.32018,459,26428-Août 200710:45x 86SERVICE PACK 2
Xpsp3res.dll5.1.2600.3158350,72019-Juin-200704:31x 86SERVICE PACK 2

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

L'emplacement pour le menu Démarrer dépend de la valeur de l'entrée de Registre commun menu Démarrer qui se trouve sous la sous-clé de Registre suivante :
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
Par défaut, la valeur de cette entrée de Registre est comme suit :
%ALLUSERSPROFILE%\Menu menu
Par défaut, le dossier du menu Démarrer est dans le « %systemdrive%\Document et Settings\All Users » dossier.

Le dossier du menu Démarrer est inaccessible si une des conditions suivantes est remplie :
  • L'entrée de Registre courants menu Démarrer est endommagée.
  • Une liste de contrôle d'accès discrétionnaire (DACL) empêche les utilisateurs tous les de lire la clé parente de l'entrée de Registre courants menu Démarrer.
  • L'entrée de Registre courants menu Démarrer pointe vers un emplacement qui est inaccessible, tel qu'un partage réseau.
  • L'entrée de Registre courants menu Démarrer pointe vers un emplacement qui les utilisateurs n'ont pas autorisation d'accès.

Comment modifier le menu Démarrer vers la version classique

  1. Cliquez avec le bouton droit sur Démarrer , puis cliquez sur Propriétés .
  2. Sous l'onglet menu Démarrer , cliquez sur menu Démarrer classique .
  3. Cliquez sur OK .
Pour plus d'informations sur la terminologie mise à jour logicielles, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Propriétés

Numéro d'article: 941248 - Dernière mise à jour: vendredi 21 septembre 2007 - Version: 1.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professional
Mots-clés : 
kbmt kbautohotfix kbfix kbexpertisebeginner kbpubtypekc kbqfe kbhotfixserver KB941248 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 941248
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com