Sie können keinen Windows Vista-WIM-Build in Solution Accelerator for Business Desktop Deployment erstellen.

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wichtig Dieser Artikel enthält Informationen zum Ändern der Registrierung. Stellen Sie sicher, dass Sie die Registrierung sichern bevor Sie Sie ändern. Stellen Sie sicher, dass Sie die Registrierung wiederherstellen kennen, wenn ein Problem auftritt. Weitere Informationen zum Sichern, Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322756Zum Sichern und Wiederherstellen der Registrierung in Windows
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Problembeschreibung

Wenn Sie versuchen, einen Build von Windows Vista-basierten Windows Imaging Format (WIM) in Microsoft Solution Accelerator für Business Desktop Deployment (BDD) erstellen, erhalten Sie folgende Fehlermeldung:
Fehler bei der Verarbeitung-Assistenten
Unerwarteter Fehler beim Verarbeiten der Ergebnisse Assistenten.
Auflistung wurde geändert; der Enumerationsvorgang kann nicht ausgeführt werden.
Sie können das WIM-Build nicht erstellen.

Dieses Problem auf, wenn Sie Komponenten wie z. B. einen Hotfix oder ein Update zum WIM-Abbild hinzugefügt haben.

Ursache

Dieses Problem rührt Windows Vista die Antwortdatei kann nicht aktualisieren, wenn Sie die WIM-Image-Datei einige Komponenten hinzufügen.

Manchmal kann eine Komponente, die Sie die WIM-Image-Datei hinzufügen den gleichen Namen und die Version als Komponente haben, bereits in der Datei ist. Jedoch beim Attributs VersionScopes für die neue Komponente von der die vorhandene Komponente abweicht, kann Windows System Image Manager Component Platform-Interface API (WSIM CPI API) falsch bestimmen, dass diese Komponenten nicht übereinstimmen. Die WSIM CPI API kann nicht aus diesem Grund die Antwortdatei aktualisieren. Stattdessen generiert die WSIM CPI API Fehler.

Wenn Sie die WIM-Image-Datei Update 933566 hinzufügen, koexistieren zwei IE-InternetExplorer-Komponenten in der Datei fest. Diese Komponenten sind ähnliche Versionen (6.0.6000.16473 und 6.0.6000.20583). Die Komponenten VersionScopes Attribute sind jedoch unterschiedlich. Eine NonSxS ist und die andere NonSxS .

Lösung

Informationen zu Service Packs

Installieren Sie das neueste Servicepack für Windows Vista, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
935791Wie Sie das neueste Windows Vista Servicepack erhalten

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Um diesen Hotfix anwenden, Sie müssen Windows Automated Installation Kit (Windows AIK) und BDD Solution Accelerator installiert haben.

Neustartanforderung

Sie müssen den Computer nach Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Windows Vista, 32-Bit-Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Microsoft.componentstudio.componentplatforminterface.dll6.0.6000.20679262.14412-Sep 200711: 16X 86
Windows Vista, 64-Bit-Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Microsoft.componentstudio.componentplatforminterface.dll6.0.6000.20679262.14412-Sep 200712: 16X 86

Informationen zur Installation

Warnung Schwerwiegende Probleme können auftreten, wenn Sie die Registrierung falsch mithilfe des Registrierungs-Editors oder mithilfe einer anderen Methode ändern. Diese Probleme erfordern möglicherweise eine das Betriebssystem neu installieren. Microsoft kann nicht garantieren, dass diese Probleme gelöst werden können. Ändern Sie die Registrierung auf eigene Gefahr.

Der Hotfix wird als eine CAB-Datei verpackt, die nicht automatisch installiert wird. Müssen Sie doppelklicken Sie auf die CAB-Datei und extrahieren die DLL-Dateien aus dem Paket.

Gehen Sie folgendermaßen vor um den Hotfix zu installieren:
  1. Ersetzen Sie die Microsoft.ComponentStudio.ComponetPlatformsInterface.dll-Datei im beide der folgenden Ordner mit der DLL-Datei, die Sie aus dem Paket extrahieren:
    • %SystemDrive%\Programme\Windows Files\BDD 2007\bin
    • %SystemDrive%\Programme\Windows c:\Programme\Windows AIK\Tools\ImgMgr
    Hinweis: Die Ordner möglicherweise anders, wenn Sie WAIK oder BDD zu abweichenden Speicherorten installiert. Verwenden Sie in diesem Fall den Pfad des Ordners, der die Software installiert. Stellen Sie sicher, dass Groß-und Kleinschreibung der Dateiname korrekt ist.
  2. Starten Sie den Registrierungseditor.
  3. Suchen Sie den Registrierungsunterschlüssel
    HKLM\SOFTWARE\Microsoft\ComponentStudio\
    .
  4. Klicken Sie mit der rechten Maustaste auf dieses Registrierungsunterschlüssels, zeigen Sie auf neu und klicken Sie dann auf Schlüssel .
  5. Geben Sie 6.0.6000.20679 als Namen des neuen Schlüssels ein, und drücken Sie anschließend die [EINGABETASTE].
  6. Klicken Sie im Menü Bearbeiten auf neu zeigen Sie und klicken Sie auf Zeichenfolge .
  7. Geben Sie ServicingPath als Namen den neuen Eintrag ein, und drücken Sie anschließend die [EINGABETASTE].
  8. Klicken Sie mit der rechten Maustaste auf den Registrierungseintrag ServicingPath, und klicken Sie dann auf Ändern .
  9. Geben Sie in das Feld Wertdaten Installation_folder \\Windows AIK\\Tools\\Servicing\\ und klicken Sie dann auf OK .
    Notizen
    • Der Installation_folder-Platzhalter steht für den Ordner in dem Windows AIK installiert ist.
    • Sie können auch den Wert des Eintrags ServicingPath im folgenden Unterschlüssel der Registrierung in das Feld Wertdaten kopieren:
      HKLM\SOFTWARE\Microsoft\ComponentStudio\6.0.6000.16386
      Die zwei ServicingPath Registrierungseinträge haben denselben Wert.
  10. Beenden Sie den Registrierungs-Editor.

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind. Dieses Problem wurde erstmals in Windows Vista Service Pack 1.

Weitere Informationen

Weitere Informationen über Business Desktop Deployment 2007 die folgende Microsoft-Website:
http://www.microsoft.com/downloadS/details.aspx?familyid=6A67F884-D629-4962-BD0A-C51BAD560354&displaylang=en
Weitere Informationen zu Solution Accelerator for Business Desktop Deployment 2007 die folgende Microsoft-Website:
http://technet.microsoft.com/en-us/library/bb490308.aspx
Weitere Informationen zu Befehlszeilenoptionen im Package Manager die folgenden Microsoft-Website:
http://technet2.microsoft.com/WindowsVista/en/library/bc0c0afa-748d-4cdd-ab38-3868c3ca87151033.mspx?mfr=true
Weitere Informationen zum Bereitstellen von Windows Vista die folgenden Microsoft-Website:
http://technet.microsoft.com/en-us/magazine/cc160880.aspx
Weitere Informationen zur Terminologie für Softwareupdates finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Eigenschaften

Artikel-ID: 941595 - Geändert am: Montag, 19. Mai 2008 - Version: 2.2
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Solution Accelerator for Business Desktop Deployment, wenn verwendet mit:
    • Windows Vista Home Premium
    • Windows Vista Ultimate
    • Windows Vista Business
    • Windows Vista Enterprise
    • Windows Vista Home Premium 64-bit edition
    • Windows Vista Ultimate 64-bit edition
    • Windows Vista Business 64-bit edition
    • Windows Vista Enterprise 64-bit edition
Keywords: 
kbmt kbautohotfix kbvistasp1fix kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB941595 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 941595
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