No puede crear una generación WIM basado en Windows Vista en Solution Accelerator for Business Desktop Deployment

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Id. de artículo: 941595 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de que copia el registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows
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Síntomas

Cuando intenta crear una generación basado en Windows Vista Windows Imaging Format (WIM) en Microsoft Solution Accelerator para Business Desktop Deployment (BDD), puede recibir el siguiente mensaje de error:
Error durante el procesamiento de Asistente
Error inesperado al procesar los resultados del asistente.
Colección modificada; puede que no se ejecute la operación de numeración.
No puede crear la generación WIM.

Este problema se produce si ha agregado componentes como una revisión o una actualización en el archivo de imagen WIM.

Causa

Este problema se produce porque Windows no puede actualizar el archivo de respuesta cuando agregue algunos componentes al archivo de imagen WIM.

A veces, un componente que agregue al archivo de imagen WIM puede tener el mismo nombre y versión como un componente que ya está en el archivo. Sin embargo, cuando el atributo VersionScopes del nuevo componente difiere de que el componente existente, del sistema imagen administrador componentes plataforma interfaz API de Windows (API de IRC WSIM) pueden determinar estos componentes no coinciden. Por tanto, la API de IRC WSIM no puede actualizar el archivo de respuesta. En su lugar, la API de IRC WSIM genera un error.

Por ejemplo, si agrega 933566 de actualización en el archivo de imagen WIM, dos componentes de IE-InternetExplorer coexistan en el archivo. Estos componentes tienen versiones similares (6.0.6000.16473 y 6.0.6000.20583). Sin embargo, VersionScopes atributos los componentes son diferentes. Uno es nonSxS y la otra es NonSxS .

Solución

Información de Service Pack

Para resolver este problema, obtenga el service pack más reciente para Windows Vista. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
935791Cómo obtener el service pack más reciente de Windows Vista

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener el Kit de instalación automatizada de Windows (Windows AIK) y BDD Solution Accelerator instalado.

Requisito de reinicio

No es necesario reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows Vista, versiones de 32 bits
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Microsoft.componentstudio.componentplatforminterface.dll6.0.6000.20679262.14412 De septiembre de 200716: 11x 86
Windows Vista, versiones de 64 bits
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Microsoft.componentstudio.componentplatforminterface.dll6.0.6000.20679262.14412 De septiembre de 200712: 16x 86

Información de instalación

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

La revisión se empaqueta como un archivo .cab que no se instala automáticamente. Tendrá que haga doble clic en el archivo .cab y extraer los archivos DLL del paquete.

Para aplicar la revisión, siga estos pasos:
  1. Reemplazar el archivo Microsoft.ComponentStudio.ComponetPlatformsInterface.dll en ambas de las carpetas siguientes con el archivo .dll que extraiga del paquete:
    • %systemdrive%\Archivos Files\BDD 2007\bin
    • %systemdrive%\Archivos de programa\Windows AIK\Tools\ImgMgr
    Nota Las carpetas pueden ser diferentes si instaló WAIK o BDD a ubicaciones no estándar. En esta situación, utilice la ruta de acceso de la carpeta a la que instaló el software. Asegúrese de que el nombre de archivo correctamente aparece en mayúsculas.
  2. Inicie el Editor del Registro.
  3. Busque la subclave del Registro
    HKLM\SOFTWARE\Microsoft\ComponentStudio\
    .
  4. Haga clic con el botón secundario en esta subclave del registro, seleccione nuevo y, a continuación, haga clic en clave .
  5. Escriba 6.0.6000.20679 nombre a la nueva clave y, a continuación, presione ENTRAR.
  6. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor alfanumérico .
  7. Escriba ServicingPath nombre a la nueva entrada y, a continuación, presione ENTRAR.
  8. Haga clic con el botón secundario en la entrada del registro de ServicingPath y, a continuación, haga clic en Modificar .
  9. En el cuadro datos del valor , escriba Installation_folder \\Windows AIK\\Tools\\Servicing\\ y, a continuación, haga clic en Aceptar .
    notas
    • El marcador de posición Installation_folder representa la carpeta en la que está instalado Windows AIK.
    • También puede copiar el valor de la entrada ServicingPath en la siguiente subclave del registro en el cuadro datos del valor :
      HKLM\SOFTWARE\Microsoft\ComponentStudio\6.0.6000.16386
      Las dos entradas del registro de ServicingPath tienen el mismo valor.
  10. Editor de registro de salida.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:". Este problema se corrigió por primera vez en Windows Vista Service Pack 1.

Más información

Para obtener más información acerca de Business Desktop Deployment 2007, visite el siguiente sitio Web de Microsoft:
http://www.microsoft.com/downloadS/details.aspx?familyid=6A67F884-D629-4962-BD0A-C51BAD560354&displaylang=en
Para obtener más información acerca de Solution Accelerator para Business Desktop Deployment 2007, visite el siguiente sitio Web:
http://technet.microsoft.com/en-us/library/bb490308.aspx
Para obtener más información acerca de las opciones de línea de comandos del Administrador de paquetes, visite el siguiente sitio Web:
http://technet2.microsoft.com/WindowsVista/en/library/bc0c0afa-748d-4cdd-ab38-3868c3ca87151033.mspx?mfr=true
Para obtener más información acerca de cómo implementar Windows Vista, visite el siguiente sitio Web de Microsoft:
http://technet.microsoft.com/en-us/magazine/cc160880.aspx
Para obtener más información acerca de la terminología relativa de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 941595 - Última revisión: lunes, 19 de mayo de 2008 - Versión: 2.2
La información de este artículo se refiere a:
  • Microsoft Solution Accelerator for Business Desktop Deployment sobre las siguientes plataformas
    • Windows Vista Home Premium
    • Windows Vista Ultimate
    • Windows Vista Business
    • Windows Vista Enterprise
    • Windows Vista Home Premium 64-bit edition
    • Windows Vista Ultimate 64-bit edition
    • Windows Vista Business 64-bit edition
    • Windows Vista Enterprise 64-bit edition
Palabras clave: 
kbmt kbautohotfix kbvistasp1fix kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB941595 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 941595

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