Não é possível criar uma compilação WIM baseado no Windows Vista no Solution Accelerator para Business Desktop Deployment

Traduções de Artigos Traduções de Artigos
Artigo: 941595 - Ver produtos para os quais este artigo se aplica.
importante Este artigo contém informações sobre como modificar o registo. Certifique-se uma que a cópia de segurança do registo antes de o modificar. Certifique-se que sabe como restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança, restaurar e modificar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756Como efectuar uma cópia de segurança e restaurar o registo no Windows
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Quando tenta criar uma compilação WIM (baseado no Windows Vista Windows Imaging Format) no Microsoft Solution Accelerator para Business Desktop Deployment (BDD), poderá receber a seguinte mensagem de erro:
Erro durante o processamento do Assistente
Ocorreu um erro inesperado ao processar os resultados do assistente.
Colecção foi modificada; a operação de enumeração não pode ser executado.
Não consegue criar a compilação WIM.

Este problema ocorre se tiver adicionado componentes tais como uma correcção ou uma actualização para o ficheiro de imagens WIM.

Causa

Este problema ocorre porque o Windows Vista não consegue actualizar o ficheiro de resposta quando adicionar alguns componentes ao ficheiro de imagens WIM.

Por vezes, um componente que adicionar ao ficheiro de imagem WIM poderá ter o mesmo nome e versão como um componente que já se encontra no ficheiro. No entanto, quando o atributo VersionScopes do novo componente difere do componente existente, a sistema imagem Gestor de componentes Platform Interface API do Windows (WSIM CPI API) pode incorrectamente determinar que estes componentes não correspondem. Por conseguinte, a API de CPI WSIM não é possível actualizar o ficheiro de resposta. Em vez disso, a API de CPI WSIM gera um erro.

Por exemplo, se adicionar 933566 da actualização para o ficheiro de imagens WIM, os dois componentes do IE InternetExplorer coexistirem no ficheiro. Estes componentes têm versões semelhantes (6.0.6000.16473 e 6.0.6000.20583). No entanto, VersionScopes atributos os componentes são diferentes. Um é nonSxS e o outro é NonSxS .

Resolução

Informações sobre Service Packs

Para resolver este problema, obtenha o service pack mais recente do Windows Vista. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
935791Como obter o Windows Vista service pack mais recente

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Para aplicar esta correcção, tem de ter Kit de instalação automática da Windows (Windows AIK) e BDD Solution Accelerator instalado.

Requisito de reinício

Não é necessário reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item data e hora no painel de controlo.
Windows Vista, versões de 32 bits
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Microsoft.componentstudio.componentplatforminterface.dll6.0.6000.20679262.14412-Set-200711: 16x 86
Windows Vista, versões de 64 bits
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Microsoft.componentstudio.componentplatforminterface.dll6.0.6000.20679262.14412-Set-200712: 16x 86

Informações de instalação

aviso Podem ocorrer problemas graves se modificar o registo incorrectamente utilizando o Editor de registo ou utilizando outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. Microsoft não garante que estes problemas podem ser resolvidos. Modificar o registo por sua conta e risco.

A correcção é fornecida como um ficheiro .cab que não é instalado automaticamente. Terá de duplo clique no ficheiro .cab e extrair os ficheiros DLL do pacote de.

Para aplicar a correcção, siga estes passos:
  1. Substitua o ficheiro Microsoft.ComponentStudio.ComponetPlatformsInterface.dll nas seguintes pastas com o ficheiro .dll que extrair a partir do pacote:
    • %systemdrive%\Programas\Windows Files\BDD 2007\bin
    • %systemdrive%\Programas\Windows Files\Windows AIK\Tools\ImgMgr
    Nota As pastas podem ser diferentes se tiver instalado WAIK ou BDD para localizações não padrão. Nesta situação, utilize o caminho da pasta onde instalou o software. Certifique-se de que o nome do ficheiro correctamente em maiúsculas.
  2. Inicie o Editor de registo.
  3. Localize a subchave de registo
    HKLM\SOFTWARE\Microsoft\ComponentStudio\
    .
  4. Com o botão direito do rato nesta subchave do registo, aponte para Novo e, em seguida, clique em chave .
  5. Escreva 6.0.6000.20679 para a nova chave de nome e, em seguida, prima ENTER.
  6. No menu Editar , aponte para Novo e, em seguida, clique em Valor da cadeia .
  7. Escreva ServicingPath para a nova entrada de nome e, em seguida, prima ENTER.
  8. Clique com o botão direito do rato na entrada de registo ServicingPath e, em seguida, clique em Modificar .
  9. Na caixa dados do valor , escreva Installation_folder \\Windows AIK\\Tools\\Servicing\\ e, em seguida, clique em OK .
    notas
    • O marcador de posição Installation_folder representa a pasta na qual está instalado o Windows AIK.
    • Pode também copiar o valor da entrada ServicingPath na seguinte subchave de registo para a caixa dados do valor :
      HKLM\SOFTWARE\Microsoft\ComponentStudio\6.0.6000.16386
      As duas entradas de registo ServicingPath têm o mesmo valor.
  10. Saia do Editor de registo.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a". Este problema foi corrigido pela primeira vez no Windows Vista Service Pack 1.

Mais Informação

Para obter mais informações sobre Business Desktop Deployment 2007, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/downloadS/details.aspx?familyid=6A67F884-D629-4962-BD0A-C51BAD560354&displaylang=en
Para obter mais informações sobre Solution Accelerator para Business Desktop Deployment 2007, visite o seguinte Web site da Microsoft:
http://technet.microsoft.com/en-us/library/bb490308.aspx
Para mais informações sobre opções da linha de comandos no Gestor de pacotes, visite o seguinte Web site da Microsoft:
http://technet2.microsoft.com/WindowsVista/en/library/bc0c0afa-748d-4cdd-ab38-3868c3ca87151033.mspx?mfr=true
Para mais informações sobre como implementar o Windows Vista, visite o seguinte Web site da Microsoft:
http://technet.microsoft.com/en-us/magazine/cc160880.aspx
Para obter mais informações sobre a terminologia de actualização de software, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

Propriedades

Artigo: 941595 - Última revisão: 19 de maio de 2008 - Revisão: 2.2
A informação contida neste artigo aplica-se a:
  • Microsoft Solution Accelerator for Business Desktop Deployment nas seguintes plataformas
    • Windows Vista Home Premium
    • Windows Vista Ultimate
    • Windows Vista Business
    • Windows Vista Enterprise
    • Windows Vista Home Premium 64-bit edition
    • Windows Vista Ultimate 64-bit edition
    • Windows Vista Business 64-bit edition
    • Windows Vista Enterprise 64-bit edition
Palavras-chave: 
kbmt kbautohotfix kbvistasp1fix kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB941595 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 941595

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com