Você não é possível criar uma compilação WIM baseado no Windows Vista no Solution Accelerator para Business Desktop Deployment

Traduções deste artigo Traduções deste artigo
ID do artigo: 941595 - Exibir os produtos aos quais esse artigo se aplica.
importante Este artigo contém informações sobre como modificar o registro. Certifique-se de que você faça backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756Como fazer backup e restaurar o registro no Windows
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Quando você tenta criar uma compilação WIM (baseado no Windows Vista Windows Imaging Format) no Microsoft Solution Accelerator para Business Desktop Deployment (BDD), você receberá a seguinte mensagem de erro:
Erro durante processamento de Assistente
Ocorreu um erro inesperado ao processar os resultados do assistente.
A coleção foi modificada; operação de enumeração não pode ser executada.
Não é possível criar a compilação do WIM.

Esse problema ocorre se você adicionou componentes, como um hotfix ou uma atualização para o arquivo de imagem WIM.

Causa

Esse problema ocorre pois o Windows Vista não é possível atualizar o arquivo de resposta quando você adiciona alguns componentes ao arquivo de imagem WIM.

Às vezes, um componente que você adicionar ao arquivo de imagem WIM pode conter o mesmo nome e versão como um componente que já está no arquivo. No entanto, quando o atributo VersionScopes do novo componente é diferente do que o componente existente, a sistema imagem Gerenciador componente plataforma interface API do Windows (API de CPI WSIM) pode incorretamente determinar que esses componentes não coincidem. Portanto, a API do CPI WSIM não é possível atualizar o arquivo de resposta. Em vez disso, a API do CPI WSIM gera um erro.

Por exemplo, se você adicionar 933566 (em inglês) da atualização para o arquivo de imagem WIM, dois componentes do IE-InternetExplorer coexistam no arquivo. Esses componentes tem versões semelhantes (6.0.6000.16473 e 6.0.6000.20583). No entanto, VersionScopes atributos os componentes são diferentes. Uma é nonSxS e a outra é NonSxS .

Resolução

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Vista. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
935791Como obter o service pack mais recente do Windows Vista

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve ter o Kit de instalação automatizada do Windows (Windows AIK) e BDD Solution Accelerator instalado.

Requisitos de reinicialização

Não é necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Versões de 32 bits do Windows Vista
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Microsoft.componentstudio.componentplatforminterface.dll6.0.6000.20679262.14412 De setembro de 200711: 16x 86
Versões de 64 bits do Windows Vista
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Microsoft.componentstudio.componentplatforminterface.dll6.0.6000.20679262.14412 De setembro de 200712: 16x 86

Informações sobre a instalação

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstalar o sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

O hotfix é empacotado como um arquivo .cab que não é instalado automaticamente. Você precisa duas vezes no arquivo .cab e extrair os arquivos DLL do pacote.

Para aplicar o hotfix, execute essas etapas:
  1. Substitua o arquivo Microsoft.ComponentStudio.ComponetPlatformsInterface.dll em ambas as seguintes pastas com o arquivo .dll que você extraia do pacote de:
    • %systemdrive%\Arquivos de Programas\BDD 2007\bin
    • %systemdrive%\Arquivos de programas\Windows AIK\Tools\ImgMgr
    Observação As pastas podem ser diferentes se você instalou WAIK ou BDD em locais não-padrão. Nessa situação, use o caminho da pasta para o qual você instalou o software. Certifique-se de que o nome do arquivo corretamente em maiúsculas.
  2. Inicie o Editor do Registro.
  3. Localize a subchave de registro
    HKLM\SOFTWARE\Microsoft\ComponentStudio\
    .
  4. Com o botão direito do mouse esta subchave do Registro, aponte para novo e, em seguida, clique em chave .
  5. Digite 6.0.6000.20679 para nomear a nova chave e, em seguida, pressione ENTER.
  6. No menu Editar , aponte para novo e, em seguida, clique em Valor da seqüência .
  7. Digite ServicingPath para nomear a nova entrada e, em seguida, pressione ENTER.
  8. Clique com o botão direito na entrada de registro ServicingPath e, em seguida, clique em Modificar .
  9. Na caixa dados do valor , digite Installation_folder \\Windows AIK\\Tools\\Servicing\\ e, em seguida, clique em OK .
    anotações
    • O espaço reservado Installation_folder representa a pasta na qual o Windows AIK está instalado.
    • Você também pode copiar o valor da entrada ServicingPath na seguinte subchave do Registro para caixa dados do valor :
      HKLM\SOFTWARE\Microsoft\ComponentStudio\6.0.6000.16386
      As duas entradas do Registro ServicingPath têm o mesmo valor.
  10. Feche o Editor do Registro.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a". Esse problema foi corrigido primeiro no Windows Vista Service Pack 1.

Mais Informações

Para obter mais informações sobre o Business Desktop Deployment 2007, visite o seguinte site:
http://www.microsoft.com/downloadS/details.aspx?familyid=6A67F884-D629-4962-BD0A-C51BAD560354&displaylang=en
Para obter mais informações sobre Solution Accelerator para Business Desktop Deployment 2007, visite o seguinte site:
http://technet.microsoft.com/en-us/library/bb490308.aspx
Para obter mais informações sobre opções de linha de comando no Gerenciador de pacotes, visite o seguinte site:
http://technet2.microsoft.com/WindowsVista/en/library/bc0c0afa-748d-4cdd-ab38-3868c3ca87151033.mspx?mfr=true
Para obter mais informações sobre como implantar o Windows Vista, visite o seguinte site:
http://technet.microsoft.com/en-us/magazine/cc160880.aspx
Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do artigo: 941595 - Última revisão: segunda-feira, 19 de maio de 2008 - Revisão: 2.2
A informação contida neste artigo aplica-se a:
  • Microsoft Solution Accelerator for Business Desktop Deployment nas seguintes plataformas
    • Windows Vista Home Premium
    • Windows Vista Ultimate
    • Windows Vista Business
    • Windows Vista Enterprise
    • Windows Vista Home Premium 64-bit edition
    • Windows Vista Ultimate 64-bit edition
    • Windows Vista Business 64-bit edition
    • Windows Vista Enterprise 64-bit edition
Palavras-chave: 
kbmt kbautohotfix kbvistasp1fix kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB941595 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 941595

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com