Oprava: Směrování zpráv nejsou odebrány z <biztalkhostname>tabulky Q_Suspended na serveru BizTalk Server 2006</biztalkhostname>

Překlady článku Překlady článku
ID článku: 941690 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Zvažte následující scénář:
  • Na serveru Microsoft BizTalk Server 2006 kterou používáte aplikace BizTalk.
  • Dojde k chybě předplatného a pak ukončit pozastavenou službu instance.
V tomto scénáři můžete všimnout, že selhání směrování zprávy hromadí se vBizTalkHostNameTabulka Q_Suspended. To způsobí, žeBizTalkMsgboxDbnárůst velikosti databáze.

Poznámka:NaBizTalkHostNameje zástupný symbol Chcete-li zástupný symbol pro název hostitele.

Příčina

K tomuto problému dochází, protože jsou směrování zprávy o selhání nejsou odebrány zBizTalkHostNameQ_Suspended Tabulka. Tyto směrování zpráv nemohou být zobrazeny v BizTalk Konzola pro správu, protože dotazy konzoly pro správu BizTalk Instance tabulky. Při ukončení pozastavenou službu instance poté, co dojde k chybě předplatné, selhání směrování zprávy jsou odebrány z instancí Tabulka. Nelze také ukončit směrování zprávy o selhání, protože nejsou přidruženy instance služby.

Řešení

Informace o opravě hotfix

UpozorněníNelze vrátit zpět tuto opravu hotfix z BizTalk serveru prostředí. Ujistěte se proto plně otestovat tuto opravu hotfix v testu prostředí, před instalací této opravy hotfix do provozního prostředí. Ne Zkuste použítPřidat nebo odebrat programyodebrat tuto opravu hotfix, protože to není vrátit zpět databáze změny a ponechá v nekonzistentním prostředí BizTalk Server stav.Další informace naleznete v souboru Readme.txt, který je součástí balíčku oprav hotfix.

Podporovaná oprava hotfix je k dispozici od společnosti Microsoft. Tato oprava hotfix je však určena pouze problém popsaný v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud není přísně tento problém, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix je k dispozici ke stažení, je sekce "Hotfix stažení k dispozici" v horní části tohoto článku. Pokud tento oddíl není uveden, obraťte se na podporu a služby zákazníkům společnosti, jak získat opravu hotfix.

Poznámka:Pokud nastanou další problémy nebo řešení potíží je vyžadován, pravděpodobně vytvořit samostatnou žádost. Výdaje na technickou podporu se bude u dalších otázek a problémů, které nelze vyřešit určitou konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu navštivte následující Web společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka:"Hotfix stažení k dispozici" formulář zobrazí jazyky, pro které je oprava hotfix je k dispozici. Pokud váš jazyk není uveden, je to, protože oprava hotfix není k dispozici pro daný jazyk.

Známý problém


Některé databáze BizTalk nemusí být aktualizován, pokud změníte název skupiny BizTalk Server před instalací tohoto balíčku oprav hotfix. Chcete-li předejít tomuto problému, přejmenujte zpět do následující výchozí název skupiny BizTalk Server před instalací opravy hotfix:
Skupiny BizTalk

Požadavky

Musíte mít BizTalk Server 2006 opravy Tato oprava hotfix.

Požadavek na restartování

Tato oprava hotfix aktualizuje databázi BizTalkMsgBoxDB. Chcete-li zabránit chybám a neočekávaným vypnutím počítače během instalace opravy hotfix, vypněte službu SQL Agent je spuštěn Agent SQL Server BizTalk úlohy, služba IIS (izolované hostitelů) a všechny BizTalk hostitele spuštěné instance této skupiny BizTalk. Po instalaci opravy hotfix restartujte službu SQL Agent, služba IIS a hostitelským instancím BizTalk.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné další opravy hotfix.

Informace o souboru

Anglická verze této opravy hotfix má soubor atributy (nebo vyšší) atributy souborů uvedené v následující tabulce. Data a časy těchto souborů, které jsou uvedeny v koordinovaný světový čas (UTC). Při zobrazení informací o souboru, je převeden na místní čas. K rozdíl mezi místním časem a časem UTC naleznete, použijteČas Zónykarty vDatum a časpoložky v ovládacím prvku Panel.
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruSoubor velikostDatumČasPlatforma
Msgboxlogic.SQLNení Použitelné541,36420. Srpna 200712: 51Není Použitelné

Prohlášení

Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro".

Vlastnosti

ID článku: 941690 - Poslední aktualizace: 15. března 2011 - Revize: 1.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft BizTalk Server 2006 Developer Edition
  • Microsoft BizTalk Server 2006 Enterprise Edition
  • Microsoft BizTalk Server 2006 Standard Edition
Klíčová slova: 
kbautohotfix kbbtsmessaging kbbiztalk2006presp1fix kbexpertiseinter kbhotfixserver kbqfe kbmt KB941690 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:941690

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com