CORRECTIF : Les rapports de défaillance du routage ne sont pas supprimés de la <biztalkhostname>table Q_Suspended sur un serveur BizTalk Server 2006</biztalkhostname>

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Sommaire

Symptômes

Considérez le scénario suivant :
  • Sur un serveur Microsoft BizTalk Server 2006, vous exécutez une application BizTalk.
  • Se produit une erreur d'abonnement, et ensuite vous arrêter le service suspendu instance.
Dans ce scénario, vous pouvez remarquer que les rapports de l'échec du routage s'accumulent dans laBizTalkHostNameTable Q_Suspended. Cela provoque laBizTalkMsgboxDbbase de données de croître.

RemarqueLeBizTalkHostNameespace réservé est un espace réservé pour le nom d'ordinateur hôte.

Cause

Ce problème se produit parce que les rapports de défaillance de routage sont ne pas supprimé de laBizTalkHostNameQ_Suspended table. Ces rapports de défaillance du routage ne sont pas visibles dans BizTalk Administration de la console, car les requêtes de la console Administration de BizTalk le Tableau d'instances. Lorsque vous arrêtez le service suspendu instance après une erreur d'abonnement, l'échec du routage des rapports sont supprimés à partir des Instances table. En outre, vous ne pouvez pas Terminer les rapports de défaillance du routage, car ils ne sont pas associés à un instance de service.

Résolution

Informations sur le correctif

AvertissementVous ne pouvez annuler ce correctif à partir du serveur BizTalk environnement. Par conséquent, veillez à tester complètement ce correctif dans un test environnement avant d'appliquer ce correctif dans un environnement de production. Ne pas Essayez d'utiliserAjouter ou supprimer des programmesPour supprimer ce correctif, car cela n'annule pas la base de données change et laisse l'environnement BizTalk Server dans une incohérence état.Pour plus d'informations, consultez le fichier Lisezmoi.txt qui est inclus dans le package de correctifs.

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu uniquement pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes qui rencontrent ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour de logiciels qui comprendra ce correctif.

Si le correctif est disponible au téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » en haut de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle de Microsoft et de Support pour obtenir le correctif.

RemarqueSi des problèmes supplémentaires se produisent ou si des procédures de dépannage est nécessaire, il se peut que vous deviez créer une demande de service distinct. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes qui ne relèvent pas de ce correctif spécifique. Pour une liste complète des numéros de téléphone Microsoft Services de Support technique ou pour créer une demande de service distinct, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.Microsoft.com/contactus/?ws=support
RemarqueLe formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, il est dans la mesure où un correctif n'est pas disponible pour cette langue.

Problème connu


Certaines bases de données BizTalk ne peuvent pas être mis à jour si vous modifiez le nom du groupe BizTalk Server avant d'appliquer ce correctif logiciel. Pour éviter ce problème, renommez le groupe BizTalk Server vers le nom par défaut suivantes avant d'appliquer le correctif :
Groupe BizTalk

Conditions préalables

Vous devez avoir installé à appliquer de BizTalk Server 2006 Ce correctif.

La nécessité de redémarrer

Ce correctif met à jour la base de données BizTalkMsgBoxDB. Pour éviter les erreurs et les arrêts inattendus lors de l'installation du correctif, arrêtez le service Agent SQL qui exécute les travaux de l'Agent SQL de BizTalk, le service IIS (hôtes isolés) et toutes les instances d'ordinateur hôte BizTalk qui sont exécutent dans ce groupe BizTalk. Après avoir installé le correctif, redémarrez le service Agent SQL, le service IIS et les instances d'ordinateur hôte de BizTalk.

Informations de remplacement de correctif

Ce correctif ne remplace pas d'autres correctifs.

Informations sur les fichiers

La version anglaise de ce correctif possède le fichier attributs (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriés dans le temps universel coordonné (UTC). Lorsque vous affichez les informations du fichier, il est converti en heure locale. Pour trouver la différence entre l'UTC et l'heure locale, utilisez laHeure Zonel'onglet dans laDate et heureélément de contrôle Panneau de configuration.
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierFichier tailleDateHeurePlate-forme
Msgboxlogic.SQLPas Applicable541,36420 Août 200712 : 51Pas Applicable

Statut

Microsoft a confirmé qu'il s'agit d'un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Propriétés

Numéro d'article: 941690 - Dernière mise à jour: mardi 15 mars 2011 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft BizTalk Server 2006 Developer Edition
  • Microsoft BizTalk Server 2006 Enterprise Edition
  • Microsoft BizTalk Server 2006 Standard Edition
Mots-clés : 
kbautohotfix kbbtsmessaging kbbiztalk2006presp1fix kbexpertiseinter kbhotfixserver kbqfe kbmt KB941690 KbMtfr
Traduction automatique
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La version anglaise de cet article est la suivante: 941690
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