Help and Support
 

powered byLive Search

The Set-Mailbox cmdlet fails when you run the cmdlet together with the EmailAddressPolicyEnabled parameter in Exchange 2007

Article ID:941774
Last Review:October 30, 2007
Revision:1.5
Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows

SYMPTOMS

In a Microsoft Exchange Server 2007 environment, the Set-Mailbox cmdlet fails when you run the cmdlet together with the EmailAddressPolicyEnabled parameter. Additionally, you receive the following error message:
Set-Mailbox: Exchange Server 2007 <FQDN of the server> returned an error 1727 from the Recipient Update Service
If you use Network Monitor to capture the remote procedure call (RPC) traffic, the captured data contains an RPC_S_ACCESS_DENIED (0x00000005) error.

Back to the top

CAUSE

The Recipient Update Service server imposes its own limit of 65,536 bytes as the maximum RPC size. It does not use the MaxRPCSize variable that is defined by the Windows RPC server. If a mailbox is contained in many address lists, the RPC data may exceed the 64-kilobyte limit. Typically, this situation may occur when a mailbox is contained in more than 350 address lists.

Back to the top

RESOLUTION

To resolve this problem, install Update Rollup 5 for Exchange Server 2007. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
941421 (http://support.microsoft.com/kb/941421/) Description of Update Rollup 5 for Exchange Server 2007
After you apply Update Rollup 5, you can set the maximum RPC size by using a registry entry. To do this, follow these steps.

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
1.Click Start, click Run, type regedit, and then click OK.
2.Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeAL\Parameters
3.On the Edit menu, point to New, and then click DWORD Value.
4.Type RUS Max RPC Size, and then press ENTER.
5.Right-click RUS Max RPC Size, and then click Modify.
6.In the Value data box, type the appropriate value, and then click OK.

Note The value that you type inside the Value data box is the maximum RPC size in bytes that the Recipient Update Service server uses.
7.Exit Registry Editor.
In addition, a new UseRusServer parameter is available for the following cmdlets after you apply Update Rollup 5:
Move-Mailbox
Set-CASMailbox
Set-Mailbox
You can use the UseRusServer parameter to specify which Recipient Update Service server should be used.

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top


APPLIES TO
Microsoft Exchange Server 2007 Enterprise Edition
Microsoft Exchange Server 2007 Standard Edition

Back to the top

Keywords: 
kbexpertiseinter kbqfe KB941774

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.