Una aplicación de .NET Framework 2.0 Windows firmada digitalmente puede iniciarse muy despacio, o un servicio de Windows puede agotar el tiempo durante el inicio

Seleccione idioma Seleccione idioma
Id. de artículo: 941990 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando intenta iniciar una aplicación de Microsoft .NET Framework 2.0 Windows firmado digitalmente o el servicio de Windows, la aplicación se inicia muy despacio. Servicios de Windows firmados digitalmente puede agotar el tiempo durante el inicio y recibe el siguiente mensaje de error del Administrador de control de servicios:
Error 1053: El servicio no respondió a la petición de inicio o del control de forma oportuna.

Causa

Este problema se produce porque la aplicación debe descargar la lista de revocación de certificados (CRL) para la autenticación. Sin embargo, una falta de conectividad de red hace que la descarga de errores por agotar el tiempo de espera. Por ejemplo, un servidor de seguridad potencialmente puede bloquear la descarga. Cuando se inicie Windows, la conexión de red no está inicializada aún.

Solución

Para resolver este problema, utilice uno de los métodos siguientes.

Método 1

Almacenar en caché localmente los certificados.

Nota El certificado caducará dentro de 15 días.

Método 2

Minimizar la configuración de tiempo de espera de red predeterminada. Para obtener más información acerca de cómo cambiar el tiempo de espera predeterminado, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
841632Recibe el mensaje de error "403.13 certificado de cliente revocado" después de instalar la actualización de seguridad MS04 11

Método 3

Para un servicio de Windows, puede aumentar la configuración de tiempo de espera predeterminado para permitir el inicio del servicio. Para ello, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  4. Escriba ServicesPipeTimeout y, a continuación, presione ENTRAR.
  5. Haga clic con el botón secundario del mouse en ServicesPipeTimeout y, a continuación, haga clic en Modificar .
  6. En el cuadro datos del valor , escriba el valor de tiempo de espera deseado en milisegundos (ms) y, a continuación, haga clic en Aceptar . Por ejemplo, si el tiempo de espera nuevo de servicio debe ser 60 segundos, escriba 60000 en el cuadro de datos de valor .
  7. En el menú archivo , haga clic en Salir .
  8. Reinicie el equipo.

    Nota Debe reiniciar el equipo para el Administrador de control para aplicar este cambio de servicios.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Propiedades

Id. de artículo: 941990 - Última revisión: miércoles, 28 de mayo de 2008 - Versión: 2.1
La información de este artículo se refiere a:
  • Microsoft .NET Framework 2.0
Palabras clave: 
kbmt kbdevsicnvrtkb kbpubtypekc kberrmsg kbtshoot kbprb KB941990 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 941990

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com